Subject: [xml2rfc] <spanx> whitespace handling

From: Julian Reschke <[email-masked]>
Date: Tue, 28 Jan 2014 14:18:24 +0100

Hi there,

<http://xml.resource.org/authoring/draft-mrose-writing-rfcs.html> claims:

"(Note that leading and trailing whitespace is significant.)"

Also, the DTD has:

<!ELEMENT spanx (%CTEXT;)>

<!ATTLIST spanx
   xml:space (default|preserve) 'preserve'
   style %ATEXT; 'emph'>

...which implies that whitespace inside <spanx> is significant.

In practice, that doesn't seem to be the case (in xml2rfc.tcl,
rfc2629.xslt, v2).

I thus conclude that the statement was something like wishful thinking,
and that we can remove the xml:space default from the <spanx> definition.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Tue, 28 Jan 2014 14:16:55 +0100

Hi there,

Also, the DTD has:

<!ATTLIST spanx

Best regards, Julian