Subject: [xml2rfc] Stack trace on incorrect date

From: Yaron Sheffer <[email-masked]>
Date: Sun, 26 Jan 2014 22:07:22 +0200

Input:

<date year="2013" />

Output consists of a useful error message, followed by an exception:

WARNING: Incomplete and out-of date <date/> element: <date year="2013"/>
Traceback (most recent call last):
File "/usr/local/bin/xml2rfc", line 225, in <module>
main()
File "/usr/local/bin/xml2rfc", line 192, in main
htmlwriter.write(filename)
File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1152, in write
self._format_date()
File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 473, in _format_date
datetime.datetime.strptime(date.attrib.get('year')+date.attrib.get('month'), '%Y%B')
TypeError: cannot concatenate 'str' and 'NoneType' objects

Thanks,

Yaron

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 26 Jan 2014 23:09:28 +0100

Hi Yaron,

> Output consists of a useful error message, followed by an exception:

Right.  Which version of xml2rfc are you running?

Best regards,

	Henrik

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 27 Jan 2014 00:36:33 +0200

Hi Henrik,

This is the online version.

Thanks,
	Yaron

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 27 Jan 2014 13:46:00 +0100

Hi Yaron,

> This is the online version.

Ok, thanks; I'll track it down.

Best regards,

	Henrik