Subject: Re: [xml2rfc] [rfc-i] Several Internet-Drafts missing at xml.resource.org

From: Alice Russo <[email-masked]>
Date: Mon, 6 Jan 2014 12:21:13 -0500

Stephane,

Yes; this issue with the XML citation libraries for I-Ds and RFCs (bibxml3 and bibxml) has been reported, and Tony Hansen wrote Dec 27, 2013 (to the xml2rfc list):

> The problem has been identified. Hopefully a fix can be worked out soon.

Thank you.
RFC Editor/ar

On Jan 6, 2014, at 5:26 AM, Stephane Bortzmeyer wrote:

> Anything wrong recently in this repository? xml2rfc tells me:
> 
> ERROR: Unable to parse the XML document: draft-bortzmeyer-dnsop-dns-privacy-02BETA.xml
> draft-bortzmeyer-dnsop-dns-privacy-02BETA.xml: Line 0: Unable to resolve external request: "http://xml.resource.org/public/rfc/bibxml3/reference.I-D.wijngaards-dnsop-confidentialdns"
> 
> But there is a wijngaards-dnsop-confidentialdns, since November 2013
> <http://tools.ietf.org/html/draft-wijngaards-dnsop-confidentialdns>
> 
> Same problem for draft-bortzmeyer-dnsop-privacy-sol. You can check in
> <http://xml.resource.org/public/rfc/bibxml3/> that there is nothing
> recent, for instance nothing in 2014 while several -00 drafts have
> been created already this year.
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 07 Jan 2014 08:20:06 +1300

(Switched to xml2rfc list)

There's also an issue with missing RFCs; RFC7084 was missing yesterday,
for example.

Similarly, idnits seems to have an incomplete list of drafts at the
moment. But a different incomplete list from xml2rfc:

  Checking references for intended status: Informational
  ----------------------------------------------------------------------------

  -- No information found for draft-ietf-homenet-arch - is the name correct?

  -- No information found for draft-ietf-v6ops-64share - is the name correct?

    Brian

On 06/01/2014 23:26, Stephane Bortzmeyer wrote:
> .

---

From: Tony Hansen <[email-masked]>
Date: Mon, 06 Jan 2014 14:27:49 -0500

The problem dates back to when one of the tools servers (merlot) croaked 
and xml.resource.org was repointed at another one of the tools servers. 
Unfortunately, the bibxml updating code is not running on that new tools 
server. The fix is to either get the updating code running on the new 
tools server or to repoint xml.resource.org back to merlot. Only Henrik 
knows for sure what the real status of these machines are.

     Tony

On 1/6/14, 12:21 PM, Alice Russo wrote:
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Tony Hansen <[email-masked]>
Date: Wed, 08 Jan 2014 10:59:52 -0500

I manually updated a bunch of bibxml files on xml.resource.org last 
night. This should bring things up-to-date to that point.

Getting the automatic updates fixed is taking longer than expected. 
(Henrik appears to be on vacation still.)

     Tony Hansen

On 1/6/14, 2:27 PM, Tony Hansen wrote:
> The problem dates back to when one of the tools servers (merlot) 
> croaked and xml.resource.org was repointed at another one of the tools 
> servers. Unfortunately, the bibxml updating code is not running on 
> that new tools server. The fix is to either get the updating code 
> running on the new tools server or to repoint xml.resource.org back to 
> merlot. Only Henrik knows for sure what the real status of these 
> machines are.
>
>     Tony
>
>> Yes; this issue with the XML citation libraries for I-Ds and RFCs 
>> (bibxml3 and bibxml) has been reported, and Tony Hansen wrote Dec 27, 
>> 2013 (to the xml2rfc list):
>>
>>> ERROR: Unable to parse the XML document: 
>>> draft-bortzmeyer-dnsop-dns-privacy-02BETA.xml
>>> draft-bortzmeyer-dnsop-dns-privacy-02BETA.xml: Line 0: Unable to 
>>> resolve external request: 
>>> "http://xml.resource.org/public/rfc/bibxml3/reference.I-D.wijngaards-dnsop-confidentialdns"
>>>