Subject: [xml2rfc] private='yes' and left_header in xml2rfc

From: Miek Gieben <[email-masked]>
Date: Fri, 24 Jan 2014 22:00:38 +0000

Hello,

There are some patches underway to make PI private='yes' work really well in
xml2rfc v2. If I use it however, the left page header in the paginated txt output
is set to empty and this makes the page header look a bit odd. Would it make
sense to use the value of of the private PI to set the left page header? So
you can use private='xyz' and the string 'xyz' is then used as the left page
header?

Regards,

-- 
   Miek Gieben

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 24 Jan 2014 14:37:55 -0800

Would you want to keep private='yes' as producing nothing?

> -----Original Message-----
> From: xml2rfc [mailto:[email-masked]] On Behalf Of Miek Gieben
> Sent: Friday, January 24, 2014 2:01 PM
> To: Xml2rfc list
> Subject: [xml2rfc] private='yes' and left_header in xml2rfc
> 
> Hello,
> 
> There are some patches underway to make PI private='yes' work really well
> in xml2rfc v2. If I use it however, the left page header in the paginated
txt
> output is set to empty and this makes the page header look a bit odd.
Would
> it make sense to use the value of of the private PI to set the left page
> header? So you can use private='xyz' and the string 'xyz' is then used as
the
> left page header?
> 
> Regards,
> 
> --
>    Miek Gieben
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Miek Gieben <[email-masked]>
Date: Fri, 24 Jan 2014 23:01:46 +0000

[ Quoting <[email-masked]> in "RE: [xml2rfc] private='yes' and lef..." ]
> Would you want to keep private='yes' as producing nothing?

Excellent observation.... Yes, that would make things really weird. A new PI
then?

Grtz, Miek

---

From: Miek Gieben <[email-masked]>
Date: Fri, 24 Jan 2014 23:55:09 +0000

[ Quoting <[email-masked]> in "Re: [xml2rfc] private='yes' and lef..." ]
> Excellent observation.... Yes, that would make things really weird. A new PI then?

...and while looking through the code to implement this, it turns out it
already exist. The PI is named 'header' (and there is 'footer' too for the
center footer text)

Regards,
Miek