Subject: [xml2rfc] align='center' ignored in figure

From: Michael Tuexen <[email-masked]>
Date: Sun, 2 Feb 2014 13:17:10 +0100

Dear all,

I want to show a stack centered. This worked in earlier versions of xml2rfc. I use

<figure title='Basic stack diagram'
        anchor='fig-stack'
        align='center'>
<artwork>
+----------+
|   SCTP   |
+----------+
|   DTLS   |
+----------+
| ICE/UDP  |
+----------+
</artwork>
</figure>

However, using the current online version of xml2rfc, the stack shows up aligned to the
left. Is this is bug or am I using the options in a wrong way. Using align='center' at
the artwork level doesn't show any difference.

Best regards
Michael

---

From: Julian Reschke <[email-masked]>
Date: Sun, 02 Feb 2014 13:46:04 +0100

> <figure title='Basic stack diagram'

In the HTML output I assume? The TXT output seems to respect it (sample 
attached).

That seems to a bug; you may want to report it at 
<http://trac.tools.ietf.org/tools/xml2rfc/trac/report>.

Best regards, Julian

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 2 Feb 2014 16:14:14 +0100

On Feb 2, 2014, at 1:46 PM, Julian Reschke <[email-masked]> wrote:

> In the HTML output I assume? The TXT output seems to respect it (sample attached).
I confirm, that your example shows correct behaviour on .txt, but wrong for .html.
However, my document contains
<!DOCTYPE rfc SYSTEM 'rfc2629.dtd'>
as suggested in
http://xml.resource.org/authoring/draft-mrose-writing-rfcs.html
The attached example, which is yours with the above line added, shows
for .txt a correct behaviour for align='center' on artwork, but incorrect
behaviour for align='center' on figure. For .html it shows incorrect
behaviour in both cases.

> 
> That seems to a bug; you may want to report it at <http://trac.tools.ietf.org/tools/xml2rfc/trac/report>.
I don't see a possibility to submit a bug report... Possibly I need to login, not sure, however,
I don't have a username/password.

Best regards
Michael
> 
> Best regards, Julian
> 
> 
> 
> 
> <sample_centered_figure.xml>

---

From: Miek Gieben <[email-masked]>
Date: Tue, 4 Feb 2014 11:33:16 +0000

[ Quoting <[email-masked]> in "Re: [xml2rfc] align='center' ignore..." ]
> behaviour for align='center' on figure. For .html it shows incorrect

I'm seeing the same thing (with xml2rfc 2.4.5) a "center" attribute set in
<figure> does not work (anymore). 

Regards,

-- 
   Miek Gieben