Subject: [xml2rfc] #230: center in figure does not work in 2.4.5

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 09 Feb 2014 16:21:23 -0000

#230: center in figure does not work in 2.4.5

 The following code does not result in a centered figure in the txt output.

 {{{
     <figure anchor="fig:servicename" align="center" title="A fully
 qualified SkyDNS DNS service name."><artwork>
 "Region" "Version" "Name" "Environment"
 </artwork></figure>
     <t>
 }}}

-- 
---------------------------+----------------------------------
 Reporter:  [email-masked]   |      Owner:  [email-masked]
     Type:  defect         |     Status:  new
 Priority:  medium         |  Milestone:
Component:  Version 2 cli  |    Version:  2.4.x
 Keywords:                 |
---------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/230>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 12 Feb 2014 09:39:38 -0800

I have tracked down the problem with this.

The code for the tcl and the python assume that they can do this, but the
dtd currently disallows for the feature to be implemented.  The DTD
specifies  a default value for the align attribute of left.  This means that
there is no ability to inherit the value from the figure.

Two options - 
Close the bug as won't fix and make sure it is correctly documented
Change the dtd so that the align attribute on artwork is implicit.
    Another possible change is to make the align attribute on figure as
implicit as well based on the fact there is a default figure align PI
implemented in the python version, but I am not sure it exists in the tcl
version.

Jim

> -----Original Message-----
> From: xml2rfc [mailto:[email-masked]] On Behalf Of xml2rfc issue
> tracker
> Sent: Sunday, February 09, 2014 8:21 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [xml2rfc] #230: center in figure does not work in 2.4.5
> 
qualified
> SkyDNS DNS service name."><artwork>  "Region" "Version" "Name"
> "Environment"
>  </artwork></figure>
>      <t>
>  }}}
> 
> --
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Julian Reschke <[email-masked]>
Date: Sat, 15 Feb 2014 15:24:09 +0100

> there is no ability to inherit the value from the figure.

That's why DTD defaults are a bad thing; the infoset of the document 
varies depending on whether you use a validating parser or not.

> Close the bug as won't fix and make sure it is correctly documented

The vocabulary spec currently says in 
<http://greenbytes.de/tech/webdav/draft-reschke-xml2rfc-05.html#rfc.section.2.17.1>:

> Used to change the alignment of <preamble> and <postamble>.
>
> Note: does not affect title or <artwork> alignment.
>
> Allowed values:
>
>     "left" (default)
>     "center"
>     "right"

So the behavior is consistent with the spec. Note also that you *can* 
align the artwork by setting the align attribute on <artwork>.

> Change the dtd so that the align attribute on artwork is implicit.

That's a good change as well. We should do that consistently for all 
attributes.

> implemented in the python version, but I am not sure it exists in the tcl

Please, no more processing instructions for things that are not specific 
to a certain processor.

Best regards, Julian