Subject: [xml2rfc] vspace usage statistics

From: Julian Reschke <[email-masked]>
Date: Sun, 16 Feb 2014 19:41:48 +0100

...obtained from XML versions of RFCs in AUTH48, starting with RFC6000 
(only RFCs with parseable XML counted).

"vspace.xslt" attempts to list all instance of vspace, and to categorize 
them by known usage patterns. Output file is "log".

   <xsl:choose>
     <xsl:when test="parent::t[@hangText] and 
normalize-space(preceding-sibling::node())=''">
       <xsl:text> DIAG-dictionary-list</xsl:text>
     </xsl:when>
     <xsl:when test="parent::t and @blankLines='1'">
       <xsl:text> DIAG-paragraph-break</xsl:text>
     </xsl:when>
     <xsl:when test="parent::t and @blankLines='0'">
       <xsl:text> DIAG-line-break</xsl:text>
     </xsl:when>
     <xsl:when test="parent::t and @blankLines>=10">
       <xsl:text> DIAG-form-feed</xsl:text>
     </xsl:when>
     <xsl:otherwise>
       <xsl:text> UNKNOWN-USE</xsl:text>
     </xsl:otherwise>
   </xsl:choose>

DIAG-dictionary-list is the use case we want to address with a new list 
style.

DIAG-paragraph-break is for cases where vspace apparently was used to 
emulate a paragraph break; this is needed in list items (but some users 
seem to use it for regular paragraph breaks as well)

DIAG-line-break is about forcing ... a line break; I haven't 
investigated all of these; some were used for creating entries in a 
"contributors" section, which we should address separately.

DIAG-form-feed is about cases where it was tried to enforce a page 
break; something we don't need in the future.

log2 contains those entries that were outside the known categories, 
sorted by # of instance:

       1 /rfc/middle/section/list/vspace[@blankLines=1] UNKNOWN-USE
       1 
/rfc/middle/section/section/section/texttable/ttcol/vspace[@blankLines=0] UNKNOWN-USE 

       1 /rfc/middle/section/section/t/vspace[@blankLines=5] UNKNOWN-USE
       1 /rfc/middle/section/t/vspace[@blankLines=2] UNKNOWN-USE
       1 /rfc/middle/section/t/vspace[@blankLines=5] UNKNOWN-USE
       1 /rfc/middle/section/vspace[@blankLines=5] UNKNOWN-USE
       2 /rfc/middle/section/section/vspace[@blankLines=1] UNKNOWN-USE
       2 /rfc/middle/section/vspace[@blankLines=1] UNKNOWN-USE
       3 /rfc/back/section/figure/preamble/vspace[@blankLines=1] 
UNKNOWN-USE
      38 /rfc/middle/section/vspace[@blankLines=99] UNKNOWN-USE

These seem to fall into these categories:

- use of vspace in a place where it's neither allowed nor needed: list, 
section

- use in elements where it's allowed but might be useful: ttcol, preamble

- attempts to control vertical white space

Best regards, Julian

---

From: Tom Taylor <[email-masked]>
Date: Sun, 16 Feb 2014 15:21:44 -0500

My typical use of vspace is to create paragraphs within a list element. 
Is there another way to do this?

Tom Taylor

On 16/02/2014 1:41 PM, Julian Reschke wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Sun, 16 Feb 2014 21:24:26 +0100

On 2014-02-16 21:21, Tom Taylor wrote:
> ...

Not yet, but it's one of the things you'll be able to do in future versions.

Best regards, Julian