Subject: Re: [xml2rfc] Author names in RFC references

From: Elwyn Davies <[email-masked]>
Date: Sun, 23 Mar 2014 22:55:14 +0000

Hi.

I looked into the origin of this naming scheme (which I also thought was rather odd).  As far as I could discover it was Jon Postel's slightly idiosyncratic scheme  which was possibly a misinterpretation of the Chicago Manual of Style.

The Chicago Manual of Style ref style might be:

Mouse, Mickey, Daffy Duck, and Donald Duck, "A cartoon", ....

[This was intended so that refs that used the author name as the ref anchor could be sorted in author surname order I suspect.  If numerical refs are used the names are all in conventional order i.e., Mickey Mouse, Daffy Duck, etc.]

whereas RFCs use

Mouse, M., Duck, D., and Donald Duck, "A cartoon", ... 

There isn't really any logic to it AFAICS... we just have to live with it.

Regards,
Elwyn

Sent from my ASUS Pad

Joachim Fabini <[email-masked]> wrote:

>Dear group,
>
>a question concerning the reference section, in particular the display 
>of author names of publications referenced by RFCs:
>xml2rfc uses two distinct variants for displaying a) the name of the 
>_last_ co-author in the author's list and b) all other author names.
>The last co-author in a publication's author list is shown as "F. 
>Lastname" whereas all others are shown as "Lastname, F.". Is this 
>inconsistent naming really by design (suppose it is, as it has been used 
>already in early RFCs)?
>Could someone please detail on the rationale behind?
>
>tia,
>regards
>Joachim
>
>_______________________________________________
>xml2rfc mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Julian Reschke <[email-masked]>
Date: Mon, 24 Mar 2014 08:03:47 +0100

On 2014-03-23 23:55, Elwyn Davies wrote:
> ...

...or we could fix it.

Best regards, Julian

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 24 Mar 2014 16:55:16 +0900

>> I looked into the origin of this naming scheme (which I also thought
>> was rather odd).  As far as I could discover it was Jon Postel's
>> slightly idiosyncratic scheme  which was possibly a misinterpretation
>> of the Chicago Manual of Style.

>> There isn't really any logic to it AFAICS... we just have to live with

+many

Regards,   Martin.