Subject: [xml2rfc] Fwd: I-D Action: draft-reschke-xml2rfc-06.txt

From: Julian Reschke <[email-masked]>
Date: Wed, 02 Apr 2014 18:00:49 +0200

Hi there,

with this version, the draft should cover all elements and attributes.

The last missing piece was to describe how titles, anchors, and 
suppress-title on texttable/figure interact -- that wasn't specified at 
all before, and consequently my implementation (rfc2629.xslt) did things 
different from the TCL and python version. I have now changed 
rfc2629.xslt to do exactly what the others do, and documented that.

Feedback appreciated.

Best regards, Julian

-------- Original Message --------
Subject: I-D Action: draft-reschke-xml2rfc-06.txt
Date: Wed, 02 Apr 2014 08:01:11 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

         Title           : The 'XML2RFC' version 2 Vocabulary
         Author          : Julian F. Reschke
	Filename        : draft-reschke-xml2rfc-06.txt
	Pages           : 63
	Date            : 2014-04-02

Abstract:
    This document defines the 'XML2RFC' version 2 vocabulary; an XML-
    based language used for writing RFCs and Internet-Drafts.

Editorial Note (To be removed by RFC Editor)

    Discussion of this draft takes place on the XML2RFC mailing list
    ([email-masked]), which has its home page at
    <https://www.ietf.org/mailman/listinfo/xml2rfc>.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-reschke-xml2rfc/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-reschke-xml2rfc-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-reschke-xml2rfc-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Heather Flanagan (RSE)" <[email-masked]>
Date: Wed, 2 Apr 2014 19:06:44 +0200

Well done, Julian!  This work was very much needed.

-Heather

Sent from my iPad

> On Apr 2, 2014, at 18:00, Julian Reschke <[email-masked]> wrote:
> 
> Hi there,
> 
> The last missing piece was to describe how titles, anchors, and suppress-title on texttable/figure interact -- that wasn't specified at all before, and consequently my implementation (rfc2629.xslt) did things different from the TCL and python version. I have now changed rfc2629.xslt to do exactly what the others do, and documented that.
> 
> Feedback appreciated.
> 
> Best regards, Julian
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Tom Taylor <[email-masked]>
Date: Wed, 02 Apr 2014 15:57:29 -0400

Section 2.17.6 states that setting 'suppress-title' to "false" will 
disable the auto-generation of title. This is counter-intuitive -- 
should it be the other way around?

Tom Taylor

> rfc2629.xslt to do exactly what the others do, and documented that.
...

---

From: Julian Reschke <[email-masked]>
Date: Wed, 02 Apr 2014 22:13:14 +0200

> should it be the other way around?

Right. Good catch.