Subject: [xml2rfc] Statistics on non-ASCII unicode code points in AUTH48 XML files

From: Julian Reschke <[email-masked]>
Date: Sat, 05 Apr 2014 19:00:44 +0200

...counted in all AITH48 RFC copies I have that parse as well-formed 
XML, sorted by # of occurrences:

       1 167
       1 195
       1 199
       1 211
       1 223
       1 224
       1 227
       1 229
       1 232
       1 235
       1 237
       1 240
       1 250
       1 8482 - trademark sign
       3 8805 - greather-than or equal to
       4 231
       4 8194 - en space
       5 228
       6 252
       7 246
       8 233
       8 8222 - double low-9 quotation mark
       8 8722 - minus sign
      11 8230 - horizontal ellipsis
      21 8211 - en dash
      31 8216 - left single quotation mark
      33 8212 - em dash
      33 8804 - less-than or equal to
      51 8288 - word joiner
      66 8221 - right double quotation mark
      69 8217 - right single quotation mark
      72 8220 - left double quotation mark
     435 8209 - non-breaking hyphen
     823 160 - non breaking space

Best regards, Julian

---

From: "Martin J. Dürst" <[email-masked]>
Date: Mon, 07 Apr 2014 20:06:10 +0900

Hello Julian,

> XML, sorted by # of occurrences:

Am I right that the first column is occurrence, the second is character 
number? At least for next time, if at all possible, please give the 
character number in hex. That way, you save everybody the dec->hex 
conversion when they want to look up the character.

Regards,   Martin.

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 07 Apr 2014 13:45:22 +0200

> number? At least for next time, if at all possible, please give the

Yes.

> conversion when they want to look up the character.

I looked up by googling "unicode NNN", and that worked just fine :-)

Best regards, Julian

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 08 Apr 2014 18:00:38 +0900

>> At least for next time, if at all possible, please give the

That's something you have to do for each character. Given that most of 
these characters are concentrated in a very small number of ranges, it's 
much more efficient to look at a few pages of Unicode (either online or 
in an actual book). In that case, decimal numbers are utterly useless, 
and hexadecimal numbers are definitely what you want. And for those who 
want, googling "unicode HHH" will still work :-).

Regards,   Martin.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 08 Apr 2014 17:48:05 +0200

> want, googling "unicode HHH" will still work :-).

Notice that all characters where I didn't add the Unicode name are in 
the range 128..255 anyway. So there's really no need to do any 
additional lookups.

That being said: that statistics was done to inform the edits in 
<http://greenbytes.de/tech/webdav/draft-reschke-xml2rfc-07.html#special.unicode.code.points> 
-- do you happen to have any feedback about that?

Best regards, Julian