Subject: [xml2rfc] PDF problem on http://xml.resource.org/

From: Stephen E Slevinski Jr <[email-masked]>
Date: Thu, 15 May 2014 11:28:30 -0500

Using http://xml.resource.org/ , I am trying to create a PDF from the 
XML source.  I am getting the following error.  It appears to be a 
configuration problem.

  Unable to Convert File

Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number

Does anyone know who to contact to see if they can fix the configuration?

Thanks,
?Steve

---

From: Tony Hansen <[email-masked]>
Date: Fri, 16 May 2014 13:12:07 -0400

> Does anyone know who to contact to see if they can fix the configuration?

I've reproduced this and am looking for a fix.

     Tony Hansen

---

From: Elwyn Davies <[email-masked]>
Date: Sat, 17 May 2014 00:34:15 +0100

On Fri, 2014-05-16 at 13:12 -0400, Tony Hansen wrote:
> > Using http://xml.resource.org/ , I am trying to create a PDF from
> > the XML source.  I am getting the following error.  It appears to be
> > a configuration problem.
> > 
> > 
> > Unable to Convert File
Interesting: This happens for PDF output for HTML and and RFCmarkup but
not for TXT.  Just checked PDF on the http:/tools.ietf.org/html/draft...
pages is running fine. 

This is not xml2rfc specific.
See https://bugs.freedesktop.org/show_bug.cgi?id=70258
http://www.h3dapi.org/modules/newbb/viewtopic.php?viewmode=flat&order=DESC&topic_id=2066&forum=3
http://lists.freebsd.org/pipermail/freebsd-questions/2013-December/254857.html
https://forums.freebsd.org/viewtopic.php?&t=43046

The last one may have the answer.
Checkout /etc/fonts/conf.d and /etc/fonts/conf.avail.
It looks like there is an old font config file
10-scale-bitmap-fonts.conf in conf.d.  The suggestion in the last
posting is to delete it and add 70-no-bitmaps.conf if it isn't already
there.

See also http://weiwu.sdf.org/100921.html for more on bitmap fonts.  I'm
not sure why the xml2rfc machine needs bit map fonts if that is what is
going on.

I saw the source of 10-scale-bitmap-fonts.conf here:
http://code.ohloh.net/file?fid=4hixVfv08aHg4ckucq6BkIhCDXs&cid=B2NOWoobNZY&s=&fp=302904&mp&projSelected=true#L0
I suspect that line 69 of this file is throwing the problem:
OLD:
<double>0</double> <name>pixelsizefixupfactor</name>
NEw (maybe):
<double>0.0</double> <name>pixelsizefixupfactor</name>

Might be worth a try?

Regards,
Elwyn

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Elwyn Davies <[email-masked]>
Date: Sat, 17 May 2014 00:38:26 +0100

MInor update to suggested fix at end.

/E

I saw the source of 10-scale-bitmap-fonts.conf here:
http://code.ohloh.net/file?fid=4hixVfv08aHg4ckucq6BkIhCDXs&cid=B2NOWoobNZY&s=&fp=302904&mp&projSelected=true#L0
I suspect that lines 68 and 69 of this file is throwing the problem:
OLD:
<name>pixelsizefixupfactor</name> <double>0</double>
<double>0</double> <name>pixelsizefixupfactor</name>
NEw (maybe):
<name>pixelsizefixupfactor</name> <double>0.0</double>
<double>0.0</double> <name>pixelsizefixupfactor</name>

Might be worth a try?

Regards,
Elwyn

---

From: Elwyn Davies <[email-masked]>
Date: Sat, 17 May 2014 16:37:30 +0100

Hi.

After some more investigation, the probable problem is that the fontconfig libraries 
being used are older than v2.10.91.

The bug fix below won't help.

The problematic config file 10-scale-bitmap-fonts.conf was introduced in 2.10.91. See
http://cgit.freedesktop.org/fontconfig/commit/?id=dc11dd581f228623f0f14b3a6a1e4beaa659266b
and
http://cgit.freedesktop.org/fontconfig/commit/?id=1c4c4978adb0fa59767ac7d8c7f98a86928b2fdc

This change was introduced (also in 2.10.91) to get round the problem that we are seeing here:
http://cgit.freedesktop.org/fontconfig/commit/?id=1fbb0b3b15774c187c697a80fb3c89bc1f3e0006

This bug report indicates the need for an upgrade to fontconfig if you need to use this new 
config file.  It is possible that one of the apps used by xml2rfc is pulling in an old 
version of fontconfig.

Presumably the quick fix is just to delete 10-scale-bitmap-fonts.conf while investigating.

Regards,
Elwyn

/E

Might be worth a try?

Regards,
Elwyn

---

From: Tony Hansen <[email-masked]>
Date: Sun, 18 May 2014 15:14:55 -0400

Thanks for the debugging, Elwyn.

I ran into a roadblock on fixing it and need to engage Henrik.

     Tony

---

From: Elwyn Davies <[email-masked]>
Date: Sun, 18 May 2014 22:09:52 +0100

> Thanks for the debugging, Elwyn.
NP.

> I ran into a roadblock on fixing it and need to engage Henrik.

Regrettably nothing more I can do since I don't have access to the
machine(s).

It sounds from reading between the lines that some of these programs
pull in the actual libraries or even statically link them.  No obvious
clues to which one might be the problem (and I haven't looked at the
back end of the GUI for xml2rfc to see what is used to do the
conversions - something common to HTML and RFCmarkup presumably).  

Good luck.

Elwyn

---

From: Tony Hansen <[email-masked]>
Date: Sun, 18 May 2014 23:22:20 -0400

Just fyi, the program that is croaking is wkhtmltopdf.

     Tony Hansen