Subject: [xml2rfc] #255 (Version 2 cli): index sort should disregard capitalization

From: "xml2rfc issue tracker" <[email-masked]>
Date: Thu, 29 May 2014 13:51:18 -0000

#255: index sort should disregard capitalization

 In the index, the sort should be alphabetical without regard for
 capitalization. Example from the attached file.

 v1 txt (desired)
 {{{
    G
       Grammar
          Accept-Ranges  6
          acceptable-ranges  6
          byte-content-range  11
          byte-range  11
          byte-range-resp  11
          byte-range-set  4
          byte-range-spec  4
          byte-ranges-specifier  4
          bytes-unit  4
          complete-length  11
          Content-Range  11
          first-byte-pos  4
          If-Range  8
 ...
 }}}

 v2 text - specifically v2.4.7 (not desired)
 {{{
    G
       Grammar
          Accept-Ranges  6
          Content-Range  11
          If-Range  8
          Range  6
          acceptable-ranges  6
          byte-content-range  11
          byte-range  11
          byte-range-resp  11
          byte-range-set  4
          byte-range-spec  4
          byte-ranges-specifier  4
          bytes-unit  4
          complete-length  11
          first-byte-pos  4
 ...
 }}}

-- 
-----------------------------+----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect           |     Status:  new
 Priority:  medium           |  Milestone:
Component:  Version 2 cli    |    Version:  2.4.x
 Keywords:                   |
-----------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/255>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Thu, 29 May 2014 14:48:00 -0000

Comment (by [email-masked]):

 From [1459]:

 Updated a test to show the problem described in issue #255.

-- 
------------------------------+----------------------------------
Resolution:                   |   Keywords:
------------------------------+----------------------------------

Ticket URL: </ticket/255#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Thu, 29 May 2014 14:53:54 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [1460]:

 Changed the sort order of iref index items to not be case sensitive.
 Fixes issue #255.

-- 
------------------------------+----------------------------------
  Reporter:  [email-masked]  |      Owner:  [email-masked]
      Type:  defect           |     Status:  closed
  Priority:  medium           |  Milestone:
 Component:  Version 2 cli    |    Version:  2.4.x
Resolution:  fixed            |   Keywords:
------------------------------+----------------------------------

Ticket URL: </ticket/255#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>