Subject: [xml2rfc] #249 (Version 2 cli): index is missing lots of entries

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 04 May 2014 15:36:19 -0000

#249: index is missing lots of entries

 Lots of irefs in the input file are not showing up in the v2 output.

 For example from the attached files.
 Using v1:
 {{{
 Index

    A
       absolute-form (of request-target)  42
       accelerator  10
       application/http Media Type  62
       asterisk-form (of request-target)  42
       authoritative response  66
       authority-form (of request-target)  42

    B
       browser  7

    C
       cache  11
       cacheable  11
       captive portal  11
       chunked (Coding Format)  28, 31, 35
       client  7
       close  50, 55
       compress (Coding Format)  38
       connection  7
       Connection header field  50, 55
       Content-Length header field  30

    D
       deflate (Coding Format)  38
       Delimiters  26
       downstream  9
 ...
 }}}

 Using v2:
 {{{
 Index

    A
       accelerator 10

    C
       cacheable 11
       captive portal 11

    D
       Delimiters 26
       downstream 10
 ...
 }}}

-- 
-----------------------------+----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect           |     Status:  new
 Priority:  medium           |  Milestone:
Component:  Version 2 cli    |    Version:  2.4.x
 Keywords:                   |
-----------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/249>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Tue, 13 May 2014 14:59:43 -0000

Comment (by [email-masked]):

 It turns out that despite <iref/> being permitted directly inside
 <section/>, the code
 doesn't handle it.  The workaround is to put irefs inside <t/>.  Fix
 coming.

-- 
------------------------------+----------------------------------
Resolution:                   |   Keywords:
------------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/249#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Thu, 15 May 2014 17:44:58 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [1429]:

 Added iref handling directly under section, and for figures, both of which
 were missing previously.  Fixes issue #249.  Also modified the format in
 which iref index page lists are emitted, to combine consecutive page
 numbers into range indications, and eliminate repeat mentions of the same
 page number.  Finally, changed things to avoid compressing the double
 space between index item and page list to a single space.  This should
 bring the iref output closer to that of xml2rfc v1.

-- 
------------------------------+----------------------------------
  Reporter:  [email-masked]  |      Owner:  [email-masked]
      Type:  defect           |     Status:  closed
  Priority:  medium           |  Milestone:
 Component:  Version 2 cli    |    Version:  2.4.x
Resolution:  fixed            |   Keywords:
------------------------------+----------------------------------

Ticket URL: </ticket/249#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>