Subject: [xml2rfc] reference formatting question

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 17 Jun 2014 11:23:39 +0000

Hi,

anyone know why this:

      <reference anchor="UPnP">
        <front>
          <title>Internet Gateway Device (IGD) Standardized Device Control
          Protocol V 1.0</title>

          <author surname="UPnP Forum">
            <organization></organization>
          </author>

          <date month="November" year="2001" />
        </front>
      </reference>

now renders as this:

   [UPnP]     UPnP Forum, , "Internet Gateway Device (IGD) Standardized
              Device Control Protocol V 1.0", November 2001.

The old xml2rfc didn't have the extra comma in there.

Lars

---

From: Tony Hansen <[email-masked]>
Date: Tue, 17 Jun 2014 07:58:36 -0400

> The old xml2rfc didn't have the extra comma in there.

I believe that there's a trac defect about that one that hasn't been 
fixed yet.

     Tony Hansen

---

From: Alice Russo <[email-masked]>
Date: Tue, 17 Jun 2014 09:59:01 -0400

Hi Lars,
The extra comma is b/c surname only is used. When an organization is the author, you can put it in the organization element and not set the author attributes:

          <author>
            <organization>UPnP Forum</organization>
          </author>

yields

   [UPnP]     UPnP Forum, "Internet Gateway Device (IGD) Standardized
              Device Control Protocol V 1.0", November 2001.

Thanks,
Alice

On Jun 17, 2014, at 7:58 AM, Tony Hansen wrote:

> I believe that there's a trac defect about that one that hasn't been fixed yet.
> 
>    Tony Hansen
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Jun 2014 08:07:34 +1200

Lars,

>>            <date month="November" year="2001" />

Try this:

<author><organization>UPnP Forum</organization></author>

   Brian

> .