Subject: [xml2rfc] Missing organization in Jan 23rd references batch

From: JF Tremblay <[email-masked]>
Date: Wed, 3 Dec 2014 14:11:40 -0500

Hello xml2rfc list. 

I was grabbing a few references from http://xml2rfc.ietf.org/public/rfc/bibxml/ <http://xml2rfc.ietf.org/public/rfc/bibxml/> and I noticed all references generated on or after Jan 23rd 2014 (roughly two thirds of all references in there) seem to miss the <organization> tag content. 

For example: 

 <reference anchor="RFC3315">
<front>
<title>
Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
</title>
<author initials="R." surname="Droms" fullname="R. Droms">
<organization/>
</author>
<author initials="J." surname="Bound" fullname="J. Bound">
<organization/>
</author>
<author initials="B." surname="Volz" fullname="B. Volz">
<organization/>
</author>
<author initials="T." surname="Lemon" fullname="T. Lemon">
<organization/>
</author>
<author initials="C." surname="Perkins" fullname="C. Perkins">
<organization/>
</author>
<author initials="M." surname="Carney" fullname="M. Carney">
<organization/>
</author>
<date year="2003" month="July"/>
</front>
<seriesInfo name="RFC" value="3315"/>
<format type="TXT" octets="231402" target="http://www.rfc-editor.org/rfc/rfc3315.txt"/>
</reference>

Is this a bug? A feature? ;)

JF

---

From: Julian Reschke <[email-masked]>
Date: Wed, 03 Dec 2014 20:36:03 +0100

On 2014-12-03 20:11, JF Tremblay wrote:
> Hello xml2rfc list.
>
> I was grabbing a few references from
> http://xml2rfc.ietf.org/public/rfc/bibxml/ and I noticed all references
> generated on or after Jan 23rd 2014 (roughly two thirds of all
> references in there) seem to miss the <organization> tag content.
>
> For example:
>
> <referenceanchor="RFC3315">
> <front>
> <title>
> <format type="TXT" octets="231402"
> target="http://www.rfc-editor.org/rfc/rfc3315.txt"/>
> </reference>
>

<organization> is meaningless information inside <reference>, it's not 
used by formatters anyway.

Why does it matter to you?

Best regards, Julian

---

From: JF Tremblay <[email-masked]>
Date: Wed, 3 Dec 2014 14:53:23 -0500

> On Dec 3, 2014, at 2:36 PM, Julian Reschke <[email-masked]> wrote
> 
> <organization> is meaningless information inside <reference>, it's not used by formatters anyway.

True, it’s not used at this time. 

> Why does it matter to you?

^shrug^
I won’t wake up in the night thinking about this. Just for the sake of completion I guess. If a large field such as <abstract>, which isn’t used either, is kept in the files, it wouldn’t hurt to have the org right. 

JF

---

From: Julian Reschke <[email-masked]>
Date: Thu, 04 Dec 2014 08:07:00 +0100

> I won’t wake up in the night thinking about this. Just for the sake of completion I guess. If a large field such as <abstract>, which isn’t used either, is kept in the files, it wouldn’t hurt to ha…

<abstract> IMHO shouldn't be there either.

Best regards, Julian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 05 Dec 2014 08:03:41 +1300

On 04/12/2014 20:07, Julian Reschke wrote:
>> I won’t wake up in the night thinking about this. Just for the sake of
>> completion I guess. If a large field such as <abstract>, which isn’t
>> used either, is kept in the files, it wouldn’t hurt to have the org
>> right.
> 

Doesn't that depend on whether the files are considered to have a wider
purpose than just feeding xml2rfc processors?

Some generally available bibliographies do indeed contain more complete
information such as abstracts and author affiliations. If the bibxml files
are intended to be a source for such bibliographies, then it's reasonable
for them to contain the lot.

I too will not stay awake over this, but if we follow Julian's approach,
we should be clear that it implies a very limited purpose for the files.

    Brian

---

From: Tony Hansen <[email-masked]>
Date: Thu, 04 Dec 2014 17:34:27 -0500

> we should be clear that it implies a very limited purpose for the files.

I think Marshall Rose expected the bibxml files to be used more broadly 
than just within xml2rfc for generating RFCs and Internet-Drafts.

Up until he stopped working on the project, he (or people who worked for 
him) spent to a lot of care extracting that additional information for 
organization and other fields in order to populate the RFC bibxml files. 
In the bibxml generation tools, there is a secondary database used just 
for the purposes of populating those fields. However, that secondary 
database has not been maintained since then. And that's why those fields 
are only spottily populated past a certain number.

There are efforts underway to improve the bibxml generation tools. If 
you feel that <abstract/> and <organization/> are important to be 
populated, it would be good to speak up.

     Tony Hansen