Subject: [xml2rfc] Outdent artwork

From: Sean Leonard <[email-masked]>
Date: Tue, 23 Dec 2014 08:13:36 -0800

How do I outdent an artwork?

Outdenting (i.e., 0, 1, or 2 space indents to the artwork) happens if 
the artwork is naturally too long, and a WARNING is issued.

How can I force the artwork to be outdented?

Thanks, Sean

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Dec 2014 14:31:01 +0100

On 2014-12-23 17:13, Sean Leonard wrote:
> ...

Why would you?

/me confused...

---

From: Sean Leonard <[email-masked]>
Date: Wed, 24 Dec 2014 09:24:32 -0800

>> How can I force the artwork to be outdented?

In draft-josefsson-pkix-textual, there is artwork of textual encodings 
such as:

-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----

However for optimum illustration, it is necessary for there to be *no 
leading spaces* at the beginning of lines.

This is discussed in the text somewhat, but the specific issue is that 
OpenSSL trims whitespace from the ends of lines, but not the beginnings 
of lines, so at least that major implementation will fail if the 
examples are fed into it.

Sean

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Dec 2014 18:39:57 +0100

On 2014-12-24 18:24, Sean Leonard wrote:
> MIICLDCCAdKgAwIBAgIBADAKBggqhkjOPQQDAjB9MQswCQYDVQQGEwJCRTEPMA0G
> A1UEChMGR251VExTMSUwIwYDVQQLExxHbnVUTFMgY2VydGlmaWNhdGUgYXV0aG9y
> aXR5MQ8wDQYDVQQIEwZMZXV2ZW4xJTAjBgNVBAMTHEdudVRMUyBjZXJ0aWZpY2F0
> ZSBhdXRob3JpdHkwHhcNMTEwNTIzMjAzODIxWhcNMTIxMjIyMDc0MTUxWjB9MQsw
> CQYDVQQGEwJCRTEPMA0GA1UEChMGR251VExTMSUwIwYDVQQLExxHbnVUTFMgY2Vy
> dGlmaWNhdGUgYXV0aG9yaXR5MQ8wDQYDVQQIEwZMZXV2ZW4xJTAjBgNVBAMTHEdu
> dVRMUyBjZXJ0aWZpY2F0ZSBhdXRob3JpdHkwWTATBgcqhkjOPQIBBggqhkjOPQMB
> BwNCAARS2I0jiuNn14Y2sSALCX3IybqiIJUvxUpj+oNfzngvj/Niyv2394BWnW4X
> uQ4RTEiywK87WRcWMGgJB5kX/t2no0MwQTAPBgNVHRMBAf8EBTADAQH/MA8GA1Ud
> DwEB/wQFAwMHBgAwHQYDVR0OBBYEFPC0gf6YEr+1KLlkQAPLzB9mTigDMAoGCCqG
> SM49BAMCA0gAMEUCIDGuwD1KPyG+hRf88MeyMQcqOFZD0TbVleF+UsAGQ4enAiEA
> l4wOuDwKQa+upc8GftXE2C//4mKANBC6It01gUaTIpo=

It's a problem that will get fixed by switching away from the stupid 
plain text format :-)

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 24 Dec 2014 09:41:51 -0800

On Dec 24, 2014, at 9:24 AM, Sean Leonard <[email-masked]> wrote:
> In draft-josefsson-pkix-textual, there is artwork of textual encodings such as:
> 
> However for optimum illustration, it is necessary for there to be *no leading spaces* at the beginning of lines.

"Necessary"? Really? Do you really think so little of your readers that they won't understand that there are no spaces at the beginnings of those lines when the artwork is used in the real world?

> This is discussed in the text somewhat, but the specific issue is that OpenSSL trims whitespace from the ends of lines, but not the beginnings of lines, so at least that major implementation will fail if the examples are fed into it.

Similar problems have existed in drafts and RFCs literally for decades, and have never been a problem in the real world.

--Paul Hoffman

---

From: Sean Leonard <[email-masked]>
Date: Wed, 24 Dec 2014 10:50:04 -0800

On Dec 24, 2014, at 9:41 AM, Paul Hoffman <[email-masked]> wrote:

> "Necessary"? Really?

“...for optimum illustration…”

Yes. Necessary for optimum illustration.

This is a clear-cut case where the tool is getting in the way not only of clear specification text, but also in the way of the basic capabilities of the canonical format.

In the current canonical format (US-ASCII text), figures can be spaced out however you want.

So is there a way to do it with the xml2rfc tool?

In retrospect, I should have used nroff for this one.

Sean