Subject: [xml2rfc] trouble installing xml2rfc-2.4.0

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 22 Dec 2014 13:58:18 +0000

Hi,

I am trying to install the package but got the following error.

[root@zzh_linux xml2rfc-2.4.0]# python setup.py install
Traceback (most recent call last):
  File "setup.py", line 8, in <module>
    from setuptools import setup
ImportError: No module named setuptools

[root@zzh_linux xml2rfc-2.4.0]# ls
changelog  LICENSE      mkrelease  requirements.txt  setup.py  xml2rfc
doc        Makefile     PKG-INFO   scripts           test.py   xml2rfc.egg-info
INSTALL    MANIFEST.in  README     setup.cfg         tests

I don't know much about it and really appreciate some help.

I got the package link from the IETF tools page.

Thanks!
Jeffrey

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 31 Dec 2014 00:42:56 +0000

Hi.

If you haven't sorted the problem out by now ... You need to have the 
Python 'setuptools' package installed.

This is generally a prerequisite for installing almost any add-on 
package for Python.  You can bootstrap  yourself from here:
https://pypi.python.org/pypi/setuptools

We probably ought to have a note in the INSTALL and/or README in the 
xml2rfc package to this effect.

Regards,
Elwyn

On 22/12/14 13:58, Jeffrey (Zhaohui) Zhang wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>
>