Subject: Re: [xml2rfc] Issue in upgrading to XMLMind v 6_1_0

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 16 Dec 2014 20:42:50 +0000

Reviving a thread from August.

I have updated to MacOSX Yosemite, and find myself Really Really wanting to use XMLMind 6. There was, last I tried it, an issue with the xml2rfc plugin, and I note that https://code.google.com/p/xml2rfc-xxe/w/list only has an update to XmlMind 5.

Has someone generated the update for XMLMind 6? If so, could they post it and point the rest of us to it?

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 16 Dec 2014 21:43:42 +0000

On Dec 16, 2014, at 1:11 PM, Warren Kumari <[email-masked]<mailto:[email-masked]>> wrote:

On Tue, Dec 16, 2014 at 3:42 PM, Fred Baker (fred) <[email-masked]<mailto:[email-masked]>> wrote:
Reviving a thread from August.

AFAIK, no-one has gotten to this yet.
Can you remember what the issue was?

The problem I had going from 5_9_0 to 6_0_0 was that it required a file called rfc2629-xhtml.ent to open an XML file. I didn’t get that message with 6_1_0.

I’m following https://code.google.com/p/xml2rfc-xxe/wiki/Installation. It says to copy http://xml2rfc-xxe.googlecode.com/svn/release/xml2rfc.xxe_addon into “install addons”.

I just installed version 6_1_0. It asked me whether there were any add ons I thought might need to be checked, and I told it to check them. It said It didn’t find any it could update.

Added the above to the add ons list.

Then I opened a file, and saw the attached result.

What’s pretty clear is that it’s not doing what we expect. I don’t have the debug environment or information to say why. My first guess is that it’s missing some variable setting.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Dec 2014 11:30:06 +1300

I found that the tool called XML Copy Editor insisted on having three files:

rfc2629.dtd
rfc2629-other.ent
rfc2629-xhtml.ent

Not a big burden to find and install them, though.

Regards
   Brian

On 17/12/2014 10:43, Fred Baker (fred) wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 16 Dec 2014 22:35:08 +0000

BTW, I should tell you I’m on MacOSX 10.10.1 and using Java 8 version 25, not the standard java 6 bundled in MacOSX.

On Dec 16, 2014, at 1:43 PM, Fred Baker <[email-masked]<mailto:[email-masked]>> wrote:

<XLMMind 6_1_0 Result.png>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 16 Dec 2014 16:11:03 -0500

A while back I was planning on changing the URL that is used for the
"Text preview using xml.resource.org", but discovered that the Java is
written in XCode, which changed its project format in some obscure way
and now spits some unuseful error message. I started trying to figure
out how to fix that, then simply move to a Makefile (or similar), but
quickly lost the will to live.

If the only thing we need is a version bump, that might not be too
hard to get done...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 17 Dec 2014 05:10:31 +0000

is it kinda sorta wysiwyg-ish? If the point is to edit XML, I can do that with what I have (or for that matter with a text editor). The nice thing about this editor is that it has some of the features of a word processor, such as showing you what you’re trying to create rather than the language you’re using to describe that creation.

> On Dec 16, 2014, at 2:30 PM, Brian E Carpenter <[email-masked]> wrote:
>