Subject: Re: [xml2rfc] Issue in upgrading to XMLMind v 6_1_0

From: Warren Kumari <[email-masked]>
Date: Mon, 19 Jan 2015 20:46:42 -0500

Apologies to everyone for the delay, but I have finally gotten a
chance to try make this better...

It ended up requiring a fair number of changes, because of various
changes made by XMLMind - for example, they decided to change the
Configuration schema to make the 'help' tag require a JavaHelp(tm)
helpset instead of a .jar file, etc... Partial changelog below.

Anyway, I'd like some people to test this before I post it on the main
download location.
So, if you are running XMLMind XMLEditor (XXE) 6 or above, please give
this new version a whirl and let me know how it works. The previous
version of the plugin (0.8.0) would only run on XXE 5.x, and this new
version of the plugin (0.8.1) will only run on XXE 6.x, so in theory
this shouldn't break anything :-)

In order to test this version, please do (in XXE):
Options -> Preferences...
Scroll down to 'Install add-ons'
Click 'Add..' in the 'Download add-ons from these servers:' section
and paste in 'http://snozzages.com/xml2rfc.xxe_addon'
Click OK.
then:
Options -> Install Add-ons...   (note: This is different to where you
went before - before was "Options -> Prefernces..." then "Install
add-ons")
this will go query a bunch of servers, including snozzages.com.
Scroll down till you see 'XML2RFC plug-in' (it is in the
'Configuration' category) and check the little box.
Hit OK.

It should prompt you to restart, and now you should have a xml2rfc
option at the bottom of 'File -> New...'. Also, when you open an
Internet Draft XML file, you should have a new menu entry called
XML2RFC.

Please report back how this works...

W

0.8.1 - Jan 19, 2015

Update to support XMLmind XML Editor Version 6.x.
In order to support multiple major version (5.x, 6.x, etc) we have to
have multiple packages.
This is annoying, but necessary - this addon includes Java, and so the
xxeVersion tag must match the version of XXE against which we
compiled. See the XXE Addon Packaging Guide for details.

Converted the xml2rfc.xxe configuration to new help attribute
XMLMind changed the format for the 'help' configuration element. It no
longer takes a location of a _help.jar file, but rather a path to a
JavaHelp™ helpset.

Removed the keyPressed binding for DELETE and BACKSPACE.
No-one can remember what there were supposed to do, but, apparently
they are not doing that :-)

Cleaned up some of the HTML (like in the ChangeLog).

On Wed, Dec 17, 2014 at 12:10 AM, Fred Baker (fred) <[email-masked]> wrote:
> is it kinda sorta wysiwyg-ish? If the point is to edit XML, I can do that with what I have (or for that matter with a text editor). The nice thing about this editor is that it has some of the features of a word processor, such as showing you what you’re trying to create rather than the language you’re using to describe that creation.
>
>> On Dec 16, 2014, at 2:30 PM, Brian E Carpenter <[email-masked]> wrote:
>>
>> I found that the tool called XML Copy Editor insisted on having three files:
>>
>> rfc2629.dtd
>> rfc2629-other.ent
>> rfc2629-xhtml.ent
>>
>> Not a big burden to find and install them, though.
>>
>> Regards
>>   Brian
>>
>> On 17/12/2014 10:43, Fred Baker (fred) wrote:
>>> On Dec 16, 2014, at 1:11 PM, Warren Kumari <[email-masked]<mailto:[email-masked]>> wrote:
>>>
>>> On Tue, Dec 16, 2014 at 3:42 PM, Fred Baker (fred) <[email-masked]<mailto:[email-masked]>> wrote:
>>> Reviving a thread from August.
>>>
>>> I have updated to MacOSX Yosemite, and find myself Really Really wanting to use XMLMind 6. There was, last I tried it, an issue with the xml2rfc plugin, and I note that https://code.google.com/p/xml2rfc-xxe/w/list only has an update to XmlMind 5.
>>>
>>> Has someone generated the update for XMLMind 6? If so, could they post it and point the rest of us to it?
>>>
>>> AFAIK, no-one has gotten to this yet.
>>> Can you remember what the issue was?
>>>
>>> The problem I had going from 5_9_0 to 6_0_0 was that it required a file called rfc2629-xhtml.ent to open an XML file. I didn’t get that message with 6_1_0.
>>>
>>> I’m following https://code.google.com/p/xml2rfc-xxe/wiki/Installation. It says to copy http://xml2rfc-xxe.googlecode.com/svn/release/xml2rfc.xxe_addon into “install addons”.
>>>
>>> I just installed version 6_1_0. It asked me whether there were any add ons I thought might need to be checked, and I told it to check them. It said It didn’t find any it could update.
>>>
>>> Added the above to the add ons list.
>>>
>>> Then I opened a file, and saw the attached result.
>>>
>>> What’s pretty clear is that it’s not doing what we expect. I don’t have the debug environment or information to say why. My first guess is that it’s missing some variable setting.
>>>
>>>
>>>
>>> ------------------------------------------------------------------------
>>>
>>> _______________________________________________
>>> xml2rfc mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/xml2rfc
>>
>

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 20 Jan 2015 09:50:09 +0000

> On Jan 19, 2015, at 5:46 PM, Warren Kumari <[email-masked]> wrote:
> 

No reason to apologize. We really shouldn’t have to change this every release.

I followed your instructions, and can inform you that it works as advertised (MacOSX 10.10.1 and XMLMind 6.1), works correctly (I edited a file, made a minor change, and observed that it did what I expected), and BTW fixed the “delete key” bug that was in the previous version (which the XMLMind people informed me was our fault).

Thanks much!

---

From: Warren Kumari <[email-masked]>
Date: Tue, 20 Jan 2015 08:47:57 -0500

On Tue, Jan 20, 2015 at 4:50 AM, Fred Baker (fred) <[email-masked]> wrote:
> I followed your instructions, and can inform you that it works as advertised (MacOSX 10.10.1 and XMLMind 6.1), works correctly (I edited a file, made a minor change, and observed that it did what I expected),

Excellent!

> and BTW fixed the “delete key” bug that was in the previous version (which the XMLMind people informed me was our fault).

Yup. That's because we had special handling for backspace and delete
that called xml2rfc.joinOrDeleteChar - it's been many years, and so
no-one (read: Billo) can remember quite what that was supposed to do.
It seems that it was to work around odd behavior in earlier versions
of XMLMind, which they have since fixed, and so it is no longer
needed...

> Thanks much!

No worries.
W

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 26 Jan 2015 17:58:39 +0000

Problem: I just downloaded XMLMind 6_2_0. It doesn’t pick up the plugin, and as a result it is not there in the list for the “Install Addons” step. Did the URL change?

---

From: Warren Kumari <[email-masked]>
Date: Mon, 26 Jan 2015 13:56:24 -0500

[ - Bill @ ATT, +Bill @ gMail ]

> Problem: I just downloaded XMLMind 6_2_0. It doesn’t pick up the plugin, and as a result it is not there in the list for the “Install Addons” step. Did the URL change?

Give this a whirl: https://code.google.com/p/xml2rfc-xxe/wiki/Installation

I'm only running 6.1.0, and so cannot definitively test, but it
*should* be fine.

The plugin itself uses Java, and XMLMind requires that the version
stated in the plugin matches the major version of XMLEditor. This
means that we need to publish 2 versions of the plugin, one for XXE
5.x and one for XXE 6.x.
I have updated the instructions page in the wiki (above) to say this,
but I do not have permissions to update the main page of the
xml2rfc-xxe page (Billo has to do that...)

Please confirm that the instructions above work for you (I just
deleted from my 6.1.0 and reinstalled, so it *should* work, but...)

Sorry for all the drama, etc.
W

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 26 Jan 2015 21:07:28 +0000

> On Jan 26, 2015, at 10:56 AM, Warren Kumari <[email-masked]> wrote:
> 

As of this morning, I’m on 6.2.0. I have attached screen shots of what I see, which is that what worked quite well on 6_1_0 doesn’t appear to be working on 6_2_0.

---

From: Warren Kumari <[email-masked]>
Date: Tue, 27 Jan 2015 13:57:26 -0500

On Mon, Jan 26, 2015 at 4:07 PM, Fred Baker (fred) <[email-masked]> wrote:

> As of this morning, I’m on 6.2.0. I have attached screen shots of what I
> see, which is that what worked quite well on 6_1_0 doesn’t appear to be
> working on 6_2_0.
>

Ah, I just upgraded to 6.2.0 as well, and think I know what the issue is...

You are probably not seeing it in the "Install" list because it is already
installed (from when you had 6.1.0) - can you click on "Uninstall" and see
if it is listed there? (Install will only show the subset of things that
are not installed)

Another option is to click "File -> New..." and scroll all the way to the
bottom and see if "xml2rfc" is listed...

W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 31 Jan 2015 02:28:07 +0000

> On Jan 27, 2015, at 10:57 AM, Warren Kumari <[email-masked]> wrote:
> 
> You are probably not seeing it in the "Install" list because it is already installed (from when you had 6.1.0) - can you click on "Uninstall" and see if it is listed there? (Install will only show the subset of things that are not installed)

Not sure where the “uninstall” you want is located. More detail please?

> Another option is to click "File -> New..." and scroll all the way to the bottom and see if "xml2rfc" is listed...

Did that and want to the bottom. There is indeed an “xml2rfc” that allows me to create a new file. I’d like to be able to work on an existing file...

---

From: Warren Kumari <[email-masked]>
Date: Fri, 30 Jan 2015 22:35:00 -0500

On Friday, January 30, 2015, Fred Baker (fred) <[email-masked]> wrote:

>
> On Jan 27, 2015, at 10:57 AM, Warren Kumari <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> On the screenshot you sent -- there is Install, and right next to it,
Unistall (just above the list of items)

> Did that and want to the bottom. There is indeed an “xml2rfc” that allows
> me to create a new file. I’d like to be able to work on an existing file...
>

Yup, and if you click "File, open..." and choose an existing Internet Draft
formatted file it should just work - if not, send me the file and I'll have
a look - perhaps it is just not recognizing it as an ID?

W

>  --
> You received this message because you are subscribed to the Google Groups
> "xml2rfc-xxe users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> .
> To post to this group, send email to [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>.
> Visit this group at http://groups.google.com/group/xml2rfc-xxe-users.
> For more options, visit https://groups.google.com/d/optout.
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 31 Jan 2015 09:13:13 +0000

Color me confused. The same file that opened in the “I’m showing you XML” format is now opening in the What-you-see-is-kinda-neat” format.

But thanks.

> On Jan 30, 2015, at 7:35 PM, Warren Kumari <[email-masked]> wrote:
> 
> 
> 
> On Friday, January 30, 2015, Fred Baker (fred) <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On Jan 27, 2015, at 10:57 AM, Warren Kumari <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> 
> On the screenshot you sent -- there is Install, and right next to it, Unistall (just above the list of items)
> 
> 
> Yup, and if you click "File, open..." and choose an existing Internet Draft formatted file it should just work - if not, send me the file and I'll have a look - perhaps it is just not recognizing it as an ID?
> 
> W
> 
> 
> --
> You received this message because you are subscribed to the Google Groups "xml2rfc-xxe users" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>.
> To post to this group, send email to [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>.
> Visit this group at http://groups.google.com/group/xml2rfc-xxe-users <http://groups.google.com/group/xml2rfc-xxe-users>.
> For more options, visit https://groups.google.com/d/optout <https://groups.google.com/d/optout>.
> 
> 
> --
> I don't think the execution is relevant when it was obviously a bad idea in the first place.
> This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
>    ---maf