Subject: [xml2rfc] draft-reschke-xml2rfc-latest, "2.22.3 'style' attribute"

From: <[email-masked]>
Date: Thu, 1 Jan 2015 20:05:45 +0000

http://greenbytes.de/tech/webdav/draft-reschke-xml2rfc-latest.html#rfc.section.2.22.3:

Your recent change restricting what can be done in <list style=”format …”> is a real problem for me.

In particular, I can no longer control the symbol to be used for bullets by saying, for example, <list  style= “format  o ”>.

I find this necessary when I have <list style=”symbols” nested inside <list style=”none”>.   The xml2rfc processor in its wisdom, gave me pluses in this case, which I had a problem with.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 02 Jan 2015 08:47:21 +0100

> …”> is a real problem for me.

I'm not aware of having made any change with respect to this.

> In particular, I can no longer control the symbol to be used for bullets
> by saying, for example, <list  style= “format  o ”>.

Why can't you?

> I find this necessary when I have <list style=”symbols” nested inside
> <list style=”none”>.   The xml2rfc processor in its wisdom, gave me
> pluses in this case, which I had a problem with.

In the TCL processor, you can override the selection of symbols with a 
processing instruction. Dunno about the Python version.

Best regards, Julian

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 2 Jan 2015 08:44:58 -0800

> -----Original Message-----
> From: xml2rfc [mailto:[email-masked]] On Behalf Of Julian
Reschke
> Sent: Thursday, January 01, 2015 11:47 PM
> To: [email-masked]; [email-masked]
> Subject: Re: [xml2rfc] draft-reschke-xml2rfc-latest, "2.22.3 'style'
attribute"
> > Your recent change restricting what can be done in <list style="format
> > ."> is a real problem for me.
> 
> > In particular, I can no longer control the symbol to be used for
> > bullets by saying, for example, <list  style= "format  o ">.
> 
> Why can't you?
> 
> > I find this necessary when I have <list style="symbols" nested inside
> > <list style="none">.   The xml2rfc processor in its wisdom, gave me

Yes the python code also follows the "text-list-symbols" PI.

Jim

> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc