Subject: [xml2rfc] Not a bug report, but a request for advice...

From: Charlie Perkins <[email-masked]>
Date: Fri, 06 Feb 2015 16:22:01 -0800

Hello folks,

In the past, I have gotten advice from this list...

In my top level list, the following:

   <t>Check the msg_hop_limit.
       <list style="symbols">
       <t>If it is zero, do not regenerate.</t>
       <t>Otherwise, decrement the value by one.</t>
       </list>  </t>

gives

    1.  Check the msg_hop_limit.

        *  If it is zero, do not regenerate.
        *  Otherwise, decrement the value by one.

I'd rather not have the blank line after the outer
list item:

    1.  Check the msg_hop_limit.
        *  If it is zero, do not regenerate.
        *  Otherwise, decrement the value by one.

How can I get xml2rfc to do this?  Is there a place in the
user manual where it discusses this?

Thanks in advance,
Charlie P.

---

From: Tom Taylor <[email-masked]>
Date: Fri, 06 Feb 2015 20:52:41 -0500

I think you can achieve this by having the processing instruction PI:

    <?rfc subcompact="yes" ?>

in front of the <rfc ... tag.

That PI may already be present with the value set to "no". It is in 
Elwyn's template. I suspect this is the RFC Editor's preference.

Tom Taylor

On 06/02/2015 7:22 PM, Charlie Perkins wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>