Subject: [xml2rfc] xml2rfc version?

From: Dave Dolson <[email-masked]>
Date: Fri, 17 Apr 2015 13:58:38 +0000

Hi,
(I thought maybe I should be asking someone from the RFC editor, but I couldn't find contact info anywhere.)

I'm trying to use this validator: http://xml2rfc.ietf.org/

I'm starting from this template: http://www.rfc-editor.org/template-bare-05.txt
(Found from IETF tools page)

But the validator doesn't load the template; there are multiple problems.

Can you tell me which is more correct, the template or the validator?
I think the template is probably more correct, since it has,
<rfc category="info" docName="draft-ietf-xml2rfc-template-05" ipr="full3978">

But the validator doesn't understand that value of "ipr".
Also confusing is http://tools.ietf.org/html/rfc2629, which indicates "full2026" as a possible value of "ipr".

Can you help me sort out which templates and tools are current?

Thanks,

David Dolson

---

From: Alice Russo <[email-masked]>
Date: Fri, 17 Apr 2015 09:14:08 -0700

Dave,

We have updated that template to use one of the current options (ipr='trust200902') as described on http://xml2rfc.ietf.org/ under "To generate the latest boilerplate".

The RFC Editor can be reached at [email-masked]. Additional contact info is here: http://www.rfc-editor.org/contacts.html

Thank you.
RFC Editor/ar

On Apr 17, 2015, at 6:58 AM, Dave Dolson <[email-masked]> wrote:

> Hi,
> (I thought maybe I should be asking someone from the RFC editor, but I couldn’t find contact info anywhere.)
>  
> I’m trying to use this validator: http://xml2rfc.ietf.org/
>  
> I’m starting from this template: http://www.rfc-editor.org/template-bare-05.txt
> But the validator doesn’t load the template; there are multiple problems.
>  
> But the validator doesn’t understand that value of “ipr”.
> Also confusing is http://tools.ietf.org/html/rfc2629, which indicates “full2026” as a possible value of “ipr”.
>  
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Dave Dolson <[email-masked]>
Date: Fri, 17 Apr 2015 18:29:47 +0000

Alice,
Thanks, that worked.

Another thing I've noted is that the tool at http://xml2rfc.ietf.org/ doesn't generate working links for references to RFCs or I.Ds

For example, this is the link generated for "BCP 78" in the boilerplate:
http://xml2rfc.ietf.org/home/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup?bcp=78

And this is the link generated for RFC2119:
http://xml2rfc.ietf.org/home/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup?rfc=2119

This is the link generated for an ID:
http://xml2rfc.ietf.org/home/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup?draft=draft-homma-sfc-forwarding-methods-analysis-01

These links don't work for me, getting "Object not found!" errors.

-Dave

-----Original Message-----
From: Alice Russo [mailto:[email-masked]] 
Sent: Friday, April 17, 2015 12:14 PM
To: Dave Dolson
Cc: [email-masked]
Subject: Re: [xml2rfc] xml2rfc version?

Dave,

Thank you.
RFC Editor/ar

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 18 Apr 2015 08:15:02 +1200

Dave,
> http://xml2rfc.ietf.org/home/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup?bcp=78

Normally there are no links generated in the boilerplate. I'm not clear
why you are getting a link there.

> http://xml2rfc.ietf.org/home/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup?rfc=2119

I assume you're referring to the HTML output format. That is indeed what
it generates, but if you save the .htm file to disk, this becomes an internal
link to the list of references, and the list of references has an external link
to http://tools.ietf.org/html/rfc2119. No problem there.

> http://xml2rfc.ietf.org/home/www/tools.ietf.org/tools/rfcmarkup/rfcmarkup?draft=draft-homma-sfc-forwarding-methods-analysis-01

And similarly for I-Ds.

Mostly though, you need to worry about the text output format, which is what we
post on-line. I find the HTML format useful for proof-reading.

(Although I generate http://www.ietf.org/about/process-docs.html using XML2RFC;
it looks different because of the IETF style sheet.)

    Brian

---

From: Dave Dolson <[email-masked]>
Date: Fri, 17 Apr 2015 21:22:02 +0000

Sorry, I should have said I'm using the RfcMarkup output.
This seems to be the way the I-Ds are generated on tools.ietf.org:

E.g,
http://tools.ietf.org/html/draft-homma-sfc-forwarding-methods-analysis-01

Note the links to BCP 78, 79 in the boilerplate.

This is strange; my links are working properly now.
I could have sworn they were broken.

Anyhow, thanks.

-Dave

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Friday, April 17, 2015 4:15 PM
To: Dave Dolson; Alice Russo
Cc: [email-masked]
Subject: Re: [xml2rfc] xml2rfc version?

Dave,

And similarly for I-Ds.

    Brian