Subject: [xml2rfc] <artwork src="filename.jpg">

From: Yaakov Stein <[email-masked]>
Date: Mon, 19 Oct 2015 13:31:29 +0000

All,

Is <artwork src="filename.jpg"> supposed to insert a figure in the html or PDF version ?

I use this extensively in draft-ietf-pals-congcons-01, and require a sequence of hacks to produce the PDF version.

Y(J)S

---

From: Julian Reschke <[email-masked]>
Date: Mon, 19 Oct 2015 16:28:23 +0200

> Is <artwork src="filename.jpg"> supposed to insert a figure in the html

Yes.

> I use this extensively in draft-ietf-pals-congcons-01, and require a
> sequence of hacks to produce the PDF version.

How do you generate the PDF?

Best regards, Julian

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 20 Oct 2015 07:20:25 +0000

Julian, 

For the last 2 versions (since the draft moved from PWE3 to PALS) were produced the on-line xml2rfc tool.
Since I could not coax it to actually insert a figure into the HTML or PDF, 
I produced both text and html, and wrote a script that replaced the CDATA with IMG tags in the html,
and then manually opened the html in a browser and saved to PDF.

Y(J)S

-----Original Message-----
From: Julian Reschke [mailto:[email-masked]] 
Sent: 19/10/2015 17:28
To: Yaakov Stein <[email-masked]>; [email-masked]
Subject: Re: [xml2rfc] <artwork src="filename.jpg">

Yes.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Tue, 20 Oct 2015 10:08:32 +0200

> and then manually opened the html in a browser and saved to PDF.

If it doesn't place the figure into the HTML that sounds like a bug that 
should be reported.

Best regards, Julian

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 20 Oct 2015 11:57:23 -0400

How could the online xml2rfc tool do this insertion? It would need 
access to the file. Where would it get that?

Perhaps if you ran the tool locally it would work.

	Thanks,
	Paul

On 10/20/15 3:20 AM, Yaakov Stein wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Tony Hansen <[email-masked]>
Date: Tue, 20 Oct 2015 13:36:37 -0400

Paul is correct.

If the src were a full http/https URL to the image, or a data: URL, the
online xml2rfc tool could inline the image properly. However, it cannot
do anything with a reference to a local filename.

    Tony Hansen