Subject: [xml2rfc] 2.5.1 goes into a trance

From: Randy Bush <[email-masked]>
Date: Sun, 01 Nov 2015 19:34:52 +0900

13" 2014 rMBP maxed out
macosx 10.11.1
xml2rfc 2.5.1
refs are local (rsynced)

% make
xml2rfc draft-ietf-sidr-rtr-keying.xml --html --text
Parsing file draft-ietf-sidr-rtr-keying.xml
< like five minutes go bye >

and then finally

ERROR: Unable to parse the XML document: draft-ietf-sidr-rtr-keying.xml
 draft-ietf-sidr-rtr-keying.xml: Line 563: Unable to resolve external request: "reference.I-D.draft-ylonen-sshkeybcp"
make: *** [all] Error 1

the big time gap is there irrespective of the missing ref

and, btw, how to i reference an expired draft?

randy

---

From: Miek Gieben <[email-masked]>
Date: Sun, 1 Nov 2015 11:55:42 +0000

[ Quoting <[email-masked]> in "[xml2rfc] 2.5.1 goes into a trance..." ]
>< like five minutes go bye >

What happens when you use the -N flag:
-N, --no-network          don't use the network to resolve references

/Miek

--
Miek Gieben

---

From: Randy Bush <[email-masked]>
Date: Mon, 02 Nov 2015 03:06:04 +0900

> -N, --no-network          don't use the network to resolve references

aha!  thanks.

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 2 Nov 2015 08:03:23 +1300

>  draft-ietf-sidr-rtr-keying.xml: Line 563: Unable to resolve external request: "reference.I-D.draft-ylonen-sshkeybcp"

Hmm... I-D.ylonen-sshkeybcp might work better.

> and, btw, how to i reference an expired draft?

That works if it's in the database. Except for I-D.odell-8+8 from 1996, which crashes on the + sign.

   Brian

---

From: Randy Bush <[email-masked]>
Date: Mon, 02 Nov 2015 04:11:07 +0900

> Hmm... I-D.ylonen-sshkeybcp might work better.

doh

thanks

> 1996, which crashes on the + sign.

that draft should be used to sabotage.  

randy