Subject: [xml2rfc] automatic generation of contributors section

From: Chris Bowers <[email-masked]>
Date: Sun, 20 Dec 2015 00:14:59 +0000

I have the following scenario.  I have a draft with more than five authors, so we have agreed to move some of them to a Contributors section.  It would be nice to be able to add a role="contributor" tag to the existing author element, and have that automatically generate a "Contributors" section that looks just like the "Author's addresses" section, except it only lists the contributors.

I found a rather long discussion on this topic from 2011, but it is not clear if anything was decided or implemented.

What is the current recommended practice for creating the Contributors section with xml2rfc?  If it is just writing the XML by hand, can someone provide a pointer to some example XML that does this, so that I can just cut and paste.

Thanks,
Chris

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 22 Dec 2015 11:01:26 +0530

Hi,

What chris suggested is great idea, and would be quite useful if it could
incorporated in the tool itself.

What I do in my drafts, is to put this in the <back> just after
<references> and it shows up in appendix.  I use <figure> to format the
address.

Regards,
Dhruv

On Sun, Dec 20, 2015 at 5:44 AM, Chris Bowers <[email-masked]> wrote:

> I have the following scenario.  I have a draft with more than five
> authors, so we have agreed to move some of them to a Contributors section.
> It would be nice to be able to add a role=”contributor” tag to the existing
> author element, and have that automatically generate a “Contributors”
> section that looks just like the “Author’s addresses” section, except it
> only lists the contributors.
>
> I found a rather long discussion on this topic from 2011, but it is not
> clear if anything was decided or implemented.
>
> What is the current recommended practice for creating the Contributors
> section with xml2rfc?  If it is just writing the XML by hand, can someone
> provide a pointer to some example XML that does this, so that I can just
> cut and paste.
>
> Thanks,
> Chris
>
>
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>
>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Dec 2015 09:08:05 +0100

On 2015-12-22 06:31, Dhruv Dhody wrote:
> Hi,
>
> What chris suggested is great idea, and would be quite useful if it
> could incorporated in the tool itself.

This hasn't been done because contributors are not authors, and we 
didn't want to change the semantics of the <author> element.

> <references> and it shows up in appendix.  I use <figure> to format the

Figures display as monospaced text in HTML, thus I'd rather not use them 
for this.

Best regards, Julian