Subject: [xml2rfc] #307 (Version 2 cli): If there are no authors, references in HTML are badly formatted

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 21 Dec 2015 07:31:14 -0000

#307: If there are no authors, references in HTML are badly formatted

 You can see this in the latest TLS 1.3 output:
 <https://tlswg.github.io/tls13-spec/#rfc.references.2>

 Patch:

 --- html.py     2015-12-14 11:52:04.000000000 +1100
 +++ /Users/martin/html.py       2015-12-21 18:28:15.000000000 +1100
 @@ -538,7 +538,7 @@
              bullet_td.attrib['class'] = 'reference'
              ref_td = E.TD()
              ref_td.attrib['class'] = 'top'
 -            last = ref_td
 +            last = None
              authors = reference.findall('front/author')
              for j, author in enumerate(authors):
                  organization = author.find('organization')
 @@ -576,11 +576,15 @@
                  title_string = ''
              if title_string:
                  if reference.attrib.get("quote-title", "true") == "true":
 # attribute default value: yes
 -                    last.tail = ', "' if len(authors) else '"'
 +                    if last is not None:
 +                        last.tail = ', "'
 +                    else:
 +                        ref_td.text = '"'
                      title_a = E.A(title_string)
                      title_a.tail = '"'
                  else:
 -                    last.tail = ', ' if len(authors) else ''
 +                    if last is not None:
 +                        last.tail = ', '
                      title_a = E.A(title_string)
                      title_a.tail = ''
                  ref_td.append(title_a)

-- 
--------------------------------------+----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect                    |     Status:  new
 Priority:  medium                    |  Milestone:
Component:  Version 2 cli             |    Version:  2.4.x
 Keywords:                            |
--------------------------------------+----------------------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/307>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 21 Dec 2015 07:32:08 -0000

Comment (by [email-masked]):

 Formatting screwup:

 {{{
 }}}

-- 
---------------------------------------+----------------------------------
Resolution:                            |   Keywords:
---------------------------------------+----------------------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/307#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>