Subject: [xml2rfc] Help with lists with embedded text block

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jan 2016 01:08:13 -0500

I am trying to get a little better in my formatting and am trying to do:

     list discriptor 1

         blah, blah, blah

     list discriptor 2

         blah, blah, blah

     list discriptor 3

         blah, blah, blah

Etc.

I have tried

<list style="hanging">
<t hangText="list discriptor 1">blah, blah, blah</t>
...

But that clearly does not yield what I want.  I am assuming there is 
this nice help page that tells me all the different list styles and what 
they produce, but my search foo is weak and perhaps it is just too late 
tonight.

Anyway, any help here is greatly appreciated.

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jan 2016 06:58:19 -0500

On 01/21/2016 02:36 AM, Jim Schaad wrote:
> <list style="hanging">
> <t hangText="list discriptor 1"><vspace>blah, blah, blah</t> ...

failed with:

Unable to Validate File

WARNING: Parsing Error: Opening and ending tag mismatch: vspace line 153 
and t, line 157, column 5
ERROR: Unable to parse the XML document: INPUT
  INPUT: Line 157: Opening and ending tag mismatch: vspace line 153 and t
  INPUT: Line 157: Opening and ending tag mismatch: vspace line 153 and t
  INPUT: Line 160: Opening and ending tag mismatch: vspace line 158 and t
  INPUT: Line 167: Opening and ending tag mismatch: vspace line 161 and t
  INPUT: Line 175: Opening and ending tag mismatch: vspace line 168 and t

>
> But I personally don't like that style myself.   Note that it appears this
> will be the default style for the v3 world.
>
> Jim
>
>> -----Original Message-----
>> From: xml2rfc [mailto:[email-masked]] On Behalf Of Robert
>> Moskowitz
>> Sent: Wednesday, January 20, 2016 10:08 PM
>> To: [email-masked]
>> Subject: [xml2rfc] Help with lists with embedded text block
>>
>> <t hangText="list discriptor 1">blah, blah, blah</t> ...
>>
>> But that clearly does not yield what I want.  I am assuming there is this
> nice help
>> page that tells me all the different list styles and what they produce,
> but my
>> search foo is weak and perhaps it is just too late tonight.
>>
>> _______________________________________________
>> xml2rfc mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 21 Jan 2016 13:49:27 +0100

> Anyway, any help here is greatly appreciated.

Try:

<t>
   list discriptor 1
   <list style="empty">
     blah, blah, blah
   </list>
</t>

(repeat...)

Best regards, Julian

---

From: Loa Andersson <[email-masked]>
Date: Thu, 21 Jan 2016 21:04:35 +0800

Robert,

the only reason I see that what you have (and failed with), is that
vsapce takes a trailing /, <space /> not <vspace>. I actually find it
a good practice to include the "blanklines" in vspace;
i.e. <vspace blankLines="1" />

/Loa

On 2016-01-21 19:58, Robert Moskowitz wrote:
>>> this

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jan 2016 10:22:51 -0500

> i.e. <vspace blankLines="1" />

AH, that works well.

Now next I would really like the <t hangText="list discriptor 1"> to 
start with a bullet.

Not asking too much here, I hope!

---

From: Loa Andersson <[email-masked]>
Date: Fri, 22 Jan 2016 09:07:39 +0800

Robert,

> Now next I would really like the <t hangText="list discriptor 1"> to
The only way to make that happen that I know of is to put in manually,
i.e. <t hangText="* list discriptor 1">.

Not pretty, and there might be other ways.

/Loa

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jan 2016 20:23:41 -0500

> i.e. <t hangText="* list discriptor 1">.

I used an 'o'; it looks a bit better.

> Not pretty, and there might be other ways.

This will do for the ID.  :)