Subject: [xml2rfc] #310 (Version 2 cli): section ordering: index placement

From: "xml2rfc issue tracker" <[email-masked]>
Date: Tue, 09 Feb 2016 23:14:09 -0000

#310: section ordering: index placement

 Desired output places an index after any appendix.

 Current output:
 {{{
   Appendix C.  RELAX NG Schema
     C.1.  Checking Validity
   IAB Members at the Time of Approval
   Acknowledgments
   Index
   Author's Address
 }}}

 Desired output:
 {{{
   Appendix C.  RELAX NG Schema
     C.1.  Checking Validity
   Index
   IAB Members at the Time of Approval
   Acknowledgments
   Author's Address
 }}}

 From https://www.rfc-editor.org/styleguide/part2/ :

 Index Placement: If included, an index appears directly after any
 appendices and before the Acknowledgements (if any). Where applicable, it
 appears before the “IAB Members at the Time of Approval” section. This is
 an update to RFC 7322.

-- 
-----------------------------+----------------------------------
 Reporter:  [email-masked]  |      Owner:  [email-masked]
     Type:  defect           |     Status:  new
 Priority:  medium           |  Milestone:
Component:  Version 2 cli    |    Version:  2.4.x
 Keywords:                   |
-----------------------------+----------------------------------

Ticket URL: <http://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/310>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Wed, 10 Feb 2016 10:56:31 -0000

Comment (by [email-masked]):

 Maybe the rule is "Index is inserted before unnumbered appendices"?

-- 
------------------------------+----------------------------------
Resolution:                   |   Keywords:
------------------------------+----------------------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/310#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>