Subject: [xml2rfc] issues with the wizard http://xml2rfc.ietf.org/xml2rfc-wizard/

From: Jaume Rius I Riu <[email-masked]>
Date: Tue, 8 Mar 2016 10:11:13 +0000

To whom it might concern,

After using the wizard (some 3 times now) to create a draft (informational, titled: “Analysis of IPv6 Neighbour Discovery for Mobile and Wireless Networks” in case it can be recovered) every time, when I come to the final step to “Download a Copy to save to a file” I get redirected to the initial page: http://xml2rfc.ietf.org/xml2rfc-wizard/, with no download and no place where ego get to the XML file generated during the process to get there.

Please, any one can advice if I actually have the XML hidden somewhere (I looked for in the obvious places on my Mac) or if this is a bug in the wizard, well, please, fix it.
Cheers,
Jaume

PS: yes,  in all the 3 times I tried I did not “copy and paste “ the generated XML in the last step, all times I made the same mistake to trust the “download a copy” button… :(

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 8 Mar 2016 16:40:38 +0000

Thanks for the report. I just tried the wizard now and when I click from page 6 to the last page, I get the "save a file" popup in FireFox to save the XML right then.

What browser are you using? What platform?

Tony Hansen

From: xml2rfc <[email-masked]<mailto:[email-masked]>> on behalf of Jaume Rius I Riu <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, March 8, 2016 at 5:11 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [xml2rfc] issues with the wizard http://xml2rfc.ietf.org/xml2rfc-wizard/

---

From: Jaume Rius I Riu <[email-masked]>
Date: Wed, 9 Mar 2016 09:38:19 +0000

Thank you very much Tony!
I am using Firefox 42.0, on a MB Pro 2013, with OSX 10.9.5

Yes, I did get a “download a copy” button. But when I pressed it I did not get any popup or a message that a popup was being blocked.  …

Ok, I will try again today and let you know if there was any change
Thank you for getting back to me!

Cheers
Jaume

From: "HANSEN, TONY L" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 8 March 2016 17:40
To: Ericsson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [xml2rfc] issues with the wizard http://xml2rfc.ietf.org/xml2rfc-wizard/

Tony Hansen

---

From: Jaume Rius I Riu <[email-masked]>
Date: Wed, 9 Mar 2016 13:16:30 +0000

Thanks Tony,
Now it did work exactly as you described and I got the popup and the file downloaded locally… so I am all set!

Thank you for your support!

Cheers,
Jaume

Tony Hansen

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 9 Mar 2016 14:04:27 +0000

After sending that previous posting, I temporarily disabled the "Download a Copy" button and changed the wording to recommend doing a cut and paste. I don't know why the button is not working using FireFox on a MacBook, yet. But at least no one else will get trapped by the same problem.

Tony Hansen

From: Jaume Rius I Riu <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 9, 2016 at 4:38 AM
To: Tony Hansen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [xml2rfc] issues with the wizard http://xml2rfc.ietf.org/xml2rfc-wizard/

Cheers
Jaume

Tony Hansen