Subject: [xml2rfc] Umlauts in reference author names

From: Ari Keränen <[email-masked]>
Date: Wed, 29 Jun 2016 14:54:02 +0000

Hi,

Xml2rfc seems to get confused now with names with umlauts (like my last name) in references.

For example,in draft-ietf-hip-native-nat-traversal-12 it says:
>    [I-D.ietf-ice-rfc5245bis]
>               Ker&#52292;nen, A., Holmberg, C., and J. Rosenberg,

Any ideas how to fix that?

Cheers,
Ari Keränen

---

From: Julian Reschke <[email-masked]>
Date: Wed, 29 Jun 2016 18:00:25 +0200

> Any ideas how to fix that?

For now, xml2rfc lives in a plain ASCII world. You'll have to substitute 
the "ä" with "ae" or "a" (depends on your locale, I guess).

Best regards, Julian

---

From: Ari Keränen <[email-masked]>
Date: Wed, 29 Jun 2016 16:11:07 +0000

> On 29 Jun 2016, at 19:00, Julian Reschke <[email-masked]> wrote:
> 
> For now, xml2rfc lives in a plain ASCII world. You'll have to substitute the "ä" with "ae" or "a" (depends on your locale, I guess).

Actually, that has been the case for all references up until very recently (it's been "Keranen" in all drafts and RFCs). I wonder if the bibxml files, or how they are handled, have been changed recently?

Cheers,
Ari

---

From: Julian Reschke <[email-masked]>
Date: Wed, 29 Jun 2016 19:05:53 +0200

> Actually, that has been the case for all references up until very recently (it's been "Keranen" in all drafts and RFCs). I wonder if the bibxml files, or how they are handled, have been changed rec…

That is indeed strange.

The ID being referenced is US-ASCII only, but

http://xml2rfc.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-ice-rfc5245bis-02.xml

has the "ä" in the contact information. Where does this come from?

Best regards, Julian

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 1 Jul 2016 03:32:05 +0000

Bibxml3 is created from 1id-index.txt and 1id-abstract.txt. Those files somehow got an umlaut in that field.

Henrik?

	Tony

On 6/29/16, 1:05 PM, "xml2rfc on behalf of Julian Reschke" <[email-masked] on behalf of [email-masked]> wrote:

That is indeed strange.

Best regards, Julian

_______________________________________________
xml2rfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xml2rfc