Subject: [xml2rfc] Comments on XML2RFC

From: Watson Ladd <[email-masked]>
Date: Fri, 1 Jul 2016 18:38:39 -0700

First, the email address for submitting comments is incorrect.

Secondly the following happens when installing on a Mac through Macports
$man xm2rfc
No manual entry for xml2rfc
$xml2rfc -h
xml2rfc: error: couldn't open "-h.xml": no such file or directory
$xml2rf --help

A window opens with an error.

What should happen is there should be usage information and a manual
page, and windows should never open from the command line usage.
Sincerely,
Watson

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 1 Jul 2016 20:07:01 -0700

Watson,

This works correctly with the version of xml2rfc that I have on my machine
for the -h and --help options.

As far as I know nobody has ever done a man page for xml2rfc, but it is
possible that I am wrong.  

>From your previous message it appears that you may be using the tcl rather
than the python version of xml2rfc.  This will make a major difference in a
number of issues.

Jim

> -----Original Message-----
> From: xml2rfc [mailto:[email-masked]] On Behalf Of Watson Ladd
> Sent: Friday, July 01, 2016 6:39 PM
> To: [email-masked]
> Subject: [xml2rfc] Comments on XML2RFC
> 
> $man xm2rfc No manual entry for xml2rfc $xml2rfc -h
> xml2rfc: error: couldn't open "-h.xml": no such file or directory $xml2rf
--help
> What should happen is there should be usage information and a manual page,
> and windows should never open from the command line usage.
> Sincerely,
> Watson
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc