Subject: Re: [xml2rfc] [media-types] Filling out templates in XML

From: Sean Leonard <[email-masked]>
Date: Tue, 5 Jul 2016 20:35:21 -0700

> On Jun 28, 2016, at 10:18 PM, Julian Reschke <[email-masked]> wrote:
> 
> On 2016-06-29 05:24, Sean Leonard wrote:
>> Just curious if people have thought about using XML elements to fill out
>> templates, in xml2rfc, rather than sticking the template instance in an
>> artwork blob.
>> ...
> 
> 
> I have always put registrations either into tables or lists. I agree that using artwork is a very bad thing.
> 

Okay. How can we move forward on a proposal?

* figure out what features we want
  (suggested: kind of like <form> in HTML, in that it’s embedded in the source text. The idea is that the style of the <template-instance template="media-types"> or whatever could be put together by tools so that it looks appropriate for the data.)
* figure out what elements needed
* new sections in xml2rfc v3 about elements
* update Relax NG schema

Main thing at a high level is: is it preferable to embed elements from another namespace (like <svg> does) or make elements in xml2rfc? I think the latter because the text inside template instances should be treated like specification text (searchable, etc.).

Best regards,

Sean

---

From: Julian Reschke <[email-masked]>
Date: Wed, 6 Jul 2016 08:53:37 +0200

> Okay. How can we move forward on a proposal?

My point being that no new elements are needed.

Could you explain why what's there (or is in v3) isn't sufficient?

Best regards, Julian