Subject: [xml2rfc] Add bibliography entries based on DOI?

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 29 Jul 2016 07:07:55 +0000

Hi,

I wonder if it would be possible to add code that would let one use DOIs as shorthand to automatically generate bibliography entries, similar to how this is possible for I-Ds and RFCs.

For example, I'd like to simply add "&10.1145/2413176.2413185" to the references section and have that be expanded to something like:

Luigi Rizzo and Giuseppe Lettieri. 2012. VALE, a switched ethernet for virtual machines. In Proceedings of the 8th international conference on Emerging networking experiments and technologies (CoNEXT '12). ACM, New York, NY, USA, 61-72. DOI=http://dx.doi.org/10.1145/2413176.2413185

Lars

---

From: Julian Reschke <[email-masked]>
Date: Fri, 29 Jul 2016 09:28:27 +0200

> Luigi Rizzo and Giuseppe Lettieri. 2012. VALE, a switched ethernet for virtual machines. In Proceedings of the 8th international conference on Emerging networking experiments and technologies (CoNE…

a) Is there a DOI database we can query (preferably in XML)?

b) FWIW, "&10.1145/2413176.2413185;" wouldn't work; the start character 
can't be a digit, and a forward slash would not be allowed.

Best regards, Julian

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 29 Jul 2016 07:45:38 +0000

> a) Is there a DOI database we can query (preferably in XML)?

I think there is a way to get XML and/or JSON from doi.org: https://www.doi.org/doi_handbook/5_Applications.html#5.4.1

There are also related services like crossref.org that seem to offer a JSON API, e.g., https://api.crossref.org/v1/works/http://dx.doi.org/10.1145/2413176.2413185, but going via doi.org is probably better.

> b) FWIW, "&10.1145/2413176.2413185;" wouldn't work; the start character can't be a digit, and a forward slash would not be allowed.

That shouldn't be too much of an issue, we can define some transformation.

Thanks,
Lars

---

From: Sean Leonard <[email-masked]>
Date: Fri, 29 Jul 2016 01:59:42 -0700

> That shouldn't be too much of an issue, we can define some transformation.

FYI, xml2rfc conforms to DTD ID, which is XML Name:
https://www.w3.org/TR/2008/PER-xml-20080205/#NT-Name

minus the characters beyond ASCII.

Sean

---

From: "John Levine" <[email-masked]>
Date: 30 Jul 2016 03:35:50 -0000

>a) Is there a DOI database we can query (preferably in XML)?

Yes, the whole point of a DOI is that it's a key to a bibliography
database.  The info is available in a bunch of formats which you can
get using the usual http content negotiation.

The largest part of the work I had to do adding the DOIs to RFCs was
the script that parsed the bibliographic info out of the existing formats
and uploaded it to Crossref.

Here's a typical example of what you can get.  For more info see
http://crosscite.org/cn/

$ curl -LH "Accept: application/rdf+xml" http://dx.doi.org/10.17487/RFC7942

<rdf:RDF
    xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
    xmlns:j.0="http://purl.org/dc/terms/"
    xmlns:j.1="http://prismstandard.org/namespaces/basic/2.1/"
    xmlns:owl="http://www.w3.org/2002/07/owl#"
    xmlns:j.2="http://purl.org/ontology/bibo/"
    xmlns:j.3="http://xmlns.com/foaf/0.1/">
  <rdf:Description rdf:about="http://dx.doi.org/10.17487/RFC7942">
    <owl:sameAs rdf:resource="http://dx.doi.org/10.17487/rfc7942"/>
    <owl:sameAs rdf:resource="doi:10.17487/rfc7942"/>
    <j.0:publisher>RFC Editor</j.0:publisher>
    <j.0:title>Improving Awareness of Running Code: The Implementation Status Section</j.0:title>
    <j.0:date rdf:datatype="http://www.w3.org/2001/XMLSchema#gYearMonth"
    >2016-07</j.0:date>
    <j.0:creator>
      <j.3:Person rdf:about="http://id.crossref.org/contributor/a-farrel-2ckdliq1jz8gg">
        <j.3:name>A. Farrel</j.3:name>
        <j.3:familyName>Farrel</j.3:familyName>
        <j.3:givenName>A.</j.3:givenName>
      </j.3:Person>
    </j.0:creator>
    <j.1:doi>10.17487/rfc7942</j.1:doi>
    <owl:sameAs rdf:resource="info:doi/10.17487/rfc7942"/>
    <j.0:creator>
      <j.3:Person rdf:about="http://id.crossref.org/contributor/y-sheffer-2ckdliq1jz8gg">
        <j.3:name>Y. Sheffer</j.3:name>
        <j.3:familyName>Sheffer</j.3:familyName>
        <j.3:givenName>Y.</j.3:givenName>
      </j.3:Person>
    </j.0:creator>
    <j.2:doi>10.17487/rfc7942</j.2:doi>
    <j.0:identifier>10.17487/rfc7942</j.0:identifier>
  </rdf:Description>
</rdf:RDF>