Subject: [xml2rfc] Fwd: http://xml2rfc.ietf.org/ broken?

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Aug 2016 13:49:08 +1200

FYI. I have sent a ticket to ietf-action.

-------- Forwarded Message --------
Subject: http://xml2rfc.ietf.org/ broken?
Date: Sat, 27 Aug 2016 13:47:53 +1200
From: Brian E Carpenter <[email-masked]>
Organization: University of Auckland
To: IETF action <[email-masked]>

Today, http://xml2rfc.ietf.org/ (redirected from http://xml.resource.org/) consistently says: No input file

http://xml2rfc.tools.ietf.org/ works normally

Regards
   Brian Carpenter

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Sat, 27 Aug 2016 02:23:57 +0000

Whenever I try to go to http://xml2rfc.ietf.org I get redirected to https://xml2rfc.tools.ietf.org via a CNAME.

If I go to http://xml.resource.org my browsers also get redirected to https://xml2rfc.tools.ietf.org, after going through the hop to xml2rfc.ietf.org first via another CNAME.

If I go directly to https://xml2rfc.ietf.org or https://xml.resource.org I get a bad certificate message complaining about the cert only being valid for *.tools.ietf.org and tools.ietf.org. Going through anyway gives me “page not found” messages.

I haven’t been able to get xml2rfc.ietf.org to come up in a way that sticks with a form there.

Sorry, but I can’t reproduce your issue.

	Tony

On 8/26/16, 9:49 PM, "xml2rfc on behalf of Brian E Carpenter" <[email-masked] on behalf of [email-masked]> wrote:

    -------- Forwarded Message --------
    Subject: http://xml2rfc.ietf.org/ broken?
    Date: Sat, 27 Aug 2016 13:47:53 +1200
    From: Brian E Carpenter <[email-masked]>
    Organization: University of Auckland
    To: IETF action <[email-masked]>

    
    Regards
       Brian Carpenter

    _______________________________________________
    xml2rfc mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Aug 2016 14:40:30 +1200

> Whenever I try to go to http://xml2rfc.ietf.org I get redirected to https://xml2rfc.tools.ietf.org via a CNAME.

Interesting. My resolver sees the CNAME too, but it took for ever to resolve.
But the problem is reproducible (today). Also, I don't get flipped to https.
I'm wondering if Cloudflare is getting into the act somehow. Maybe I should just
wait until tomorrow.

> xml2rfc.ietf.org
Server:  fritz.box
Address:  fd00::be05:43ff:fe8e:ce39

Non-authoritative answer:
xml2rfc.ietf.org        ??? unknown type 46 ???
xml2rfc.ietf.org        canonical name = xml2rfc.tools.ietf.org

ietf.org        nameserver = ns1.mia1.afilias-nst.info
ietf.org        nameserver = ns1.ams1.afilias-nst.info
ietf.org        nameserver = ns0.amsl.com
ietf.org        nameserver = ns1.sea1.afilias-nst.info
ietf.org        nameserver = ns1.yyz1.afilias-nst.info
ietf.org        nameserver = ns1.hkg1.afilias-nst.info
ns0.amsl.com    internet address = 4.31.198.40
ns0.amsl.com    AAAA IPv6 address = 2001:1900:3001:11::28
ns1.ams1.afilias-nst.info       internet address = 65.22.6.79
ns1.hkg1.afilias-nst.info       internet address = 65.22.6.1
ns1.hkg1.afilias-nst.info       AAAA IPv6 address = 2a01:8840:6::1
ns1.mia1.afilias-nst.info       internet address = 65.22.7.1
ns1.mia1.afilias-nst.info       AAAA IPv6 address = 2a01:8840:7::1
ns1.sea1.afilias-nst.info       internet address = 65.22.8.1
ns1.sea1.afilias-nst.info       AAAA IPv6 address = 2a01:8840:8::1
ns1.yyz1.afilias-nst.info       internet address = 65.22.9.1
ns1.yyz1.afilias-nst.info       AAAA IPv6 address = 2a01:8840:9::1

    Brian

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Sat, 27 Aug 2016 02:45:16 +0000

There is also the http->https flipping that’s getting into the act and might be wrecking havoc.

	Tony

On 8/26/16, 10:40 PM, "Brian E Carpenter" <[email-masked]> wrote:

    
    Server:  fritz.box

    
        Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Aug 2016 14:57:02 +1200

> There is also the http->https flipping that’s getting into the act and might be wrecking havoc.

It is. When I manually go to https://xml2rfc.ietf.org/, firstly I get a certificate
error and if I accept that, I get to something that looks mighty like the tools.ietf.org
main page.

I wonder if IPv6 is also part of the story.

   Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 27 Aug 2016 22:13:32 +0200

> error and if I accept that, I get to something that looks mighty like the tools.ietf.org

I've just fixed the missing redirect from https://xml2rfc.ietf.org/ to
https://xml2rfc.tools.ietf.org/.  The cert is of course still broken, but
the redirect is there now.  I'll talk with Glen about an alternative
approach which may work better (but that depends on him having wildcard
certs for ietf.org).

Best regards,

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 28 Aug 2016 11:42:28 +1200

Right, thanks, and that works.

What is still broken (and this is very recent) is that when I go to
http://xml2rfc.ietf.org/, browse to an xml file, and click submit,
I get a "No input file" from https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi

So, what seems to be happening is that the flip to https happens too late.
It should happen *before* I am able to browse to a file.

I have an open ticket [www.ietf.org/rt #139048] for this.

Regards
    Brian

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Sun, 28 Aug 2016 00:36:38 +0000

It’s weird: when I go to http://xml2rfc.ietf.org/, my browsers immediately redirect to https://xml2rfc.tools.ietf.org/ and all is good from then on. I’ve tried several different browsers and they all do it properly. I tried Safari, FF and Chrome on a Mac, and FF and IE on a PC. All worked.

I’m flummoxed as to why your experience is different.

- Tony

On 8/27/16, 7:42 PM, "Brian E Carpenter" <[email-masked]> wrote:

    

    Regards
        Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 28 Aug 2016 17:03:21 +1200

> I’m flummoxed as to why your experience is different.

Ditto. The redirect only seems to happen when I hit submit, i.e. trigger a POST and
presumably a CGI script.

I just disabled IPv6: same problem
I just had TunnelBear transport me to the UK: same problem.
I just had TunnelBear transport me to the USA: same problem.

I just cleared my browser cache.

Problem solved - http://xml.resource.org/ now redirects to https://xml2rfc.tools.ietf.org/
instead of http://xml2rfc.ietf.org/. And http://xml2rfc.ietf.org/ also redirects.

So, something changed that invalidated whatever my browser had cached.

Sorry for the distraction. I will update the ietf-action ticket.

    Brian

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 28 Aug 2016 13:31:16 +0200

FWIW, https://github.com/cabo/kramdown-rfc2629/issues/27

It seems a bug in Ruby's open-uri library gets triggered by some of the
recent changes.

Fortunately, there is a reasonably easy workaround while this is being
fixed.

(Fetching a resource via HTTP used to be simple, foolproof, robust...)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 28 Aug 2016 13:43:36 +0200

> Fortunately, there is a reasonably easy workaround while this is being

To turn the workaround into a more permanent fix, it would be nice to
agree a *stable* prefix as a replacement for what used to be

http://xml2rfc.ietf.org/public/rfc

for a while (was a similar URI with xml.resource.org before).

Grüße, Carsten

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Sun, 28 Aug 2016 23:21:21 +0000

Do things work correctly if you use https instead of http? I think the intent of the recent changes is to make https://xml2rfc.ietf.org/public/rfc be the stable prefix. Unfortunately, it isn’t currently because of the “bad certificate” warning we get.

	Tony

On 8/28/16, 7:43 AM, "xml2rfc on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    

    Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 29 Aug 2016 01:58:32 +0200

Hi Tony,

The workaround currently uses xml2rfc.tools.ietf.org and so avoids the cert issue.  

Would it be appropriate to rely on this for now and switch to the stable URI once the cert is fixed?

Grüße, Carsten

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 29 Aug 2016 00:11:07 +0000

Yes, you can certainly do that.

                Tony

From: Carsten Bormann <[email-masked]>
Date: Sunday, August 28, 2016 at 7:58 PM
To: Tony Hansen <[email-masked]>
Cc: xml2rfc <[email-masked]>
Subject: Re: [xml2rfc] Fwd: http://xml2rfc.ietf.org/ broken?

Hi Tony,

Grüße, Carsten

On 29 Aug 2016 01:21, HANSEN, TONY L wrote:

Tony

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 29 Aug 2016 19:58:55 +0200

I've had Glen set up a server with proper certificates for xml2rfc.ietf.org,
which redirects to xml2rfc.tools.ietf.org.  The cert issue should now be
fixed, and when we're ready to move the online xml2rfc service off of tools,
we can put it in place on the server which currently does the redirect.

Best regards,

	Henrik

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 29 Aug 2016 18:02:39 +0000

Excellent. Thanks Henrik and Glen.

	Tony

On 8/29/16, 1:58 PM, "Henrik Levkowetz" <[email-masked]> wrote:

    Best regards,
    
    	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 29 Aug 2016 20:34:43 +0200

Henrik Levkowetz wrote:
> The cert issue should now be
> fixed,

Thanks.  I can confirm that https://xml2rfc.ietf.org now works with
kramdown-rfc (which will however continue to default on
https://xml2rfc.tools.ietf.org for now to avoid an additional redirect).

Grüße, Carsten