Subject: Re: [xml2rfc] OpenID Foundation bibrefs

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 21 Oct 2016 13:16:03 +0000

This list is just fine for proposing this.

Is there a simple-to-parse-by-a-computer list of the Open ID specs?

                Tony

From: xml2rfc <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Friday, October 21, 2016 at 8:09 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [xml2rfc] OpenID Foundation bibrefs

Hi,

the openid foundation’s spec editors are using xml2rfc and I would like to suggest to add the OpenID Foundations specifications to https://xml2rfc.tools.ietf.org/public/rfc/bibxml2/

Current files are attached.
A list of all OIDF specs is here: http://openid.net/developers/specs/

What do you think?

Kind regards
Axel

Ps.: Sorry if this is not the right list for this.

Deutsche Telekom AG
T-Labs (Research & Innovation)
Dipl.-Inform. Axel Nennker
Winterfeldtstr. 21, 10781 Berlin
+491702275312 (Mobile)
E-Mail: [email-masked]

---

From: <[email-masked]>
Date: Fri, 21 Oct 2016 17:12:31 +0000

To my knowledge there is no such list.
The three files I provided are the main specs. The others are drafts or old.

Adding Nat who has write permissions on the OIDF specs pages. OIDF could add a list there although the danger is that that machine readable list and the Wordpress generated main specs pages diverge later.
Alternatively we could put the machine readable list on our bitbucket server.
How authoritative do you need it to be?

How do you handle this with other orgs like 3GPP or ISO?

//Axel

Attaching the files again for Nat. We might put the refs on openid.net too…

From: HANSEN, TONY L [mailto:[email-masked]]
Sent: Friday, October 21, 2016 3:16 PM
To: Nennker, Axel; [email-masked]; [email-masked]
Subject: Re: [xml2rfc] OpenID Foundation bibrefs

                Tony

From: xml2rfc <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 21, 2016 at 8:09 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [xml2rfc] OpenID Foundation bibrefs

Hi,

What do you think?

Kind regards
Axel

Deutsche Telekom AG
T-Labs (Research & Innovation)
Dipl.-Inform. Axel Nennker
Winterfeldtstr. 21, 10781 Berlin
+491702275312 (Mobile)
E-Mail: [email-masked]<mailto:[email-masked]>

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 21 Oct 2016 17:48:18 +0000

Where possible, we prefer creating and updating bibxml references based on authorative files from the given organization. When we haven’t, we’ve always gotten out of date (rather quickly in some instances). For any new bibxml entries, we’ve been trying to use official feeds wherever possible, and not do any screen scraping of web pages.

Since there are so few documents though, an alternative approach would be for you to put together the half dozen bibxml files by hand and we can add them to bibxml2. Please send them to [email-masked]<mailto:[email-masked]>. Just realize that they WILL get out of date.

                Tony

From: "[email-masked]" <[email-masked]>
Date: Friday, October 21, 2016 at 1:12 PM
To: "HANSEN, TONY L" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [xml2rfc] OpenID Foundation bibrefs

//Axel

                Tony

Hi,

What do you think?

Kind regards
Axel

Deutsche Telekom AG

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 21 Oct 2016 17:56:08 +0000

An alternative approach is to do what the Jabber Foundation does – they have their OWN bibxml server for their documents.

                Tony

From: xml2rfc <[email-masked]> on behalf of "HANSEN, TONY L" <[email-masked]>
Date: Friday, October 21, 2016 at 1:48 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [xml2rfc] OpenID Foundation bibrefs

                Tony

//Axel

                Tony

Hi,

What do you think?

Kind regards
Axel

Deutsche Telekom AG

---

From: Nat Sakimura <[email-masked]>
Date: Sat, 22 Oct 2016 12:56:37 +0900

Hi

Thank you very much for raising this topic.

We will discuss it in the next board executive committee of the OpenID 
Foundation.

Best,

Nat Sakimura
Chairman, OpenID Foundation

On 2016-10-22 02:56, HANSEN, TONY L wrote:
> An alternative approach is to do what the Jabber Foundation does –
> they have their OWN bibxml server for their documents.
> 
>  Tony
> 
> FROM: xml2rfc <[email-masked]> on behalf of "HANSEN, TONY L"
> <[email-masked]>
>  DATE: Friday, October 21, 2016 at 1:48 PM
>  TO: "[email-masked]" <[email-masked]>,
> "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>
>  SUBJECT: Re: [xml2rfc] OpenID Foundation bibrefs
> 
> Where possible, we prefer creating and updating bibxml references
> based on authorative files from the given organization. When we
> haven’t, we’ve always gotten out of date (rather quickly in some
> instances). For any new bibxml entries, we’ve been trying to use
> official feeds wherever possible, and not do any screen scraping of
> web pages.
> 
> Since there are so few documents though, an alternative approach would
> be for you to put together the half dozen bibxml files by hand and we
> can add them to bibxml2. Please send them to [email-masked].
> Just realize that they WILL get out of date.
> 
>  Tony
> 
> FROM: "[email-masked]" <[email-masked]>
>  DATE: Friday, October 21, 2016 at 1:12 PM
>  TO: "HANSEN, TONY L" <[email-masked]>, "[email-masked]"
> <[email-masked]>, "[email-masked]" <[email-masked]>
>  CC: "[email-masked]" <[email-masked]>
>  SUBJECT: RE: [xml2rfc] OpenID Foundation bibrefs
> 
> Adding Nat who has write permissions on the OIDF specs pages. OIDF
> could add a list there although the danger is that that machine
> readable list and the Wordpress generated main specs pages diverge
> later.
> 
> FROM: HANSEN, TONY L [mailto:[email-masked]]
>  SENT: Friday, October 21, 2016 3:16 PM
>  TO: Nennker, Axel; [email-masked]; [email-masked]
>  SUBJECT: Re: [xml2rfc] OpenID Foundation bibrefs
> 
> FROM: xml2rfc <[email-masked]> on behalf of
> "[email-masked]" <[email-masked]>
>  DATE: Friday, October 21, 2016 at 8:09 AM
>  TO: "[email-masked]" <[email-masked]>,
> "[email-masked]" <[email-masked]>
>  SUBJECT: [xml2rfc] OpenID Foundation bibrefs
> 
> Hi,
> 
> the openid foundation’s spec editors are using xml2rfc and I would
> like to suggest to add the OpenID Foundations specifications to
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml2/ [1]
> 
> [2]
> DEUTSCHE TELEKOM AG
> Links:
> ------
> [1] https://xml2rfc.tools.ietf.org/public/rfc/bibxml2/
> [2] http://openid.net/developers/specs/