Subject: [xml2rfc] Error uploading an XML2RFC draft

From: Jim Schaad <[email-masked]>
Date: Tue, 22 Nov 2016 14:13:04 -0800

Henrik, 

I am getting the error

An exception occurred when trying to process the XML file: 'X509' object has
no attribute '_x509'

When I try to upload and convert an XML document.  The last one I uploaded
worked just time.  The time is Tue 10:10 UTC.

Jim

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Nov 2016 13:17:15 +1300

Assuming you mean upload with https://datatracker.ietf.org/submit/:

As I understand it from another list, a ticket has already been submitted to
the secretariat for this bug (which started early last week). The work around
is: convert with https://xml2rfc.tools.ietf.org/, and only upload the .txt file.

Regards
   Brian Carpenter

On 23/11/2016 11:13, Jim Schaad wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 23 Nov 2016 09:17:37 +0100

On Wed, Nov 23, 2016 at 01:17:15PM +1300,
 Brian E Carpenter <[email-masked]> wrote 
 a message of 33 lines which said:

> the secretariat for this bug

Indeed [www.ietf.org/rt #149401]. Unfortunately, no action yet :-(

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 23 Nov 2016 13:12:03 +0100

> Indeed [www.ietf.org/rt #149401]. Unfortunately, no action yet :-(

The secretariat has forwarded the information to me, and I've made some
changes, but haven't been able to pinpoint where to apply the necessary
fix.  Simply downgrading from the bad package version inside the datatracker
environment has not been sufficient to fix this.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 23 Nov 2016 13:26:07 +0100

Hi Jim,

> worked just time.  The time is Tue 10:10 UTC.

Ok, thanks.  Should be fixed now (requests lib downgraded from 2.12.1 to 
2.11.1).

Best regards,

	Henrik

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 23 Nov 2016 14:42:13 +0100

On Wed, Nov 23, 2016 at 01:26:07PM +0100,
 Henrik Levkowetz <[email-masked]> wrote 
 a message of 74 lines which said:

> Should be fixed now (requests lib downgraded from 2.12.1 to 2.11.1).

Indeed (I just uploaded draft-bortzmeyer-dprive-step-2-04)