Subject: [xml2rfc] Specifying a reference's author(s)

From: Robert Moskowitz <[email-masked]>
Date: Tue, 5 Sep 2017 10:42:15 -0400

How do I expand:

<author/>

??

Minimally I want one author

     <author>Nadia Heninger</author>

That that does not work.

I would like to cite them all:

     <author>
     Nadia Heninger
     Zakir Durumeric
     Eric Wustrow
     J. Alex Halderman
     </author>

No guide to this in FAQ.

Thanks

---

From: Julian Reschke <[email-masked]>
Date: Tue, 5 Sep 2017 17:08:12 +0200

> I would like to cite them all:

Spec: <https://www.greenbytes.de/tech/webdav/rfc7749.html#element.author>

Example: 
<https://github.com/reschke/xml2rfc/blob/master/rfc2629xslt.xml#L2556>

Best regards, Julian

---

From: Fred Baker <[email-masked]>
Date: Tue, 5 Sep 2017 08:14:57 -0700

Last I checked, it was something like

<author fullname="Fred Baker" initials="F.J." surname="Baker"> 
	<organization/> 
	<address> 
		<postal> 
			<street/> 
			<city>Santa Barbara</city> 
			<code>93117</code> 
			<region>California</region> 
			<country>USA</country> 
		</postal> 
		<email>[email-masked]</email> 
	</address> 
</author> 

And multiple blocks like that for multiple authors. Did I miss something?

> On Sep 5, 2017, at 7:42 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> How do I expand:
> 
> <author/>
> 
> ??
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 5 Sep 2017 11:22:41 -0400

Julian pointed me to:

2.6. <author>

Provides information about a document's author. This is used both for 
the document itself (at the beginning of the document) and for 
referenced documents (inside of <reference>).

So references does not use a different structure from doc authors...

OK.

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 5 Sep 2017 11:33:19 -0400

OK.  Got this fixed.

thanks