Subject: [xml2rfc] Also date in reference

From: Robert Moskowitz <[email-masked]>
Date: Tue, 5 Sep 2017 10:43:36 -0400

It did not like:

     <date>2011</date>

Actually would like July, 2011

thanks

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 5 Sep 2017 11:36:07 -0400

And got this:

<date month="July" year="2011"/>

On 09/05/2017 10:43 AM, Robert Moskowitz wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 5 Sep 2017 13:19:23 -0400

Which reminds me:

Why isn’t the year optional?

This works:

<date year=“2017”/> and it fills in the day and month.

Why can’t this work?

<date />

It should fill in the day, month, and year.

Tom

> On Sep 5, 2017, at 11:36 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> And got this:
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 5 Sep 2017 13:59:37 -0400

> It should fill in the day, month, and year.

Then what indicates you do not want a date?  Changing the behavior so 
that the date option with no sub-fields results in today's date would 
cause a lot of existing xml to suddenly start adding the date when none 
was wanted.  Perhaps something like:

<date today/>

Bob

---

From: Fred Baker <[email-masked]>
Date: Tue, 5 Sep 2017 11:06:49 -0700

> On Sep 5, 2017, at 10:59 AM, Robert Moskowitz <[email-masked]> wrote:
> 
>> Why can’t this work?
>> 
>> <date />
>> 
> Then what indicates you do not want a date?  Changing the behavior so that the date option with no sub-fields results in today's date would cause a lot of existing xml to suddenly start adding the date when none was wanted.  Perhaps something like:

Current (v2) xml2rfc accepts <date/> as "insert today's date", in the metadata for the draft. I'm OK with <date today/>, but that means I have to change every XML file I'm using.

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 5 Sep 2017 14:17:10 -0400

I remember trying

<date />

And it didn’t give me Today’s date but I’ll try it again. I don’t care about not having a date on a draft. Why would you want that?

Tom

> On Sep 5, 2017, at 1:59 PM, Robert Moskowitz <[email-masked]> wrote:
> 
> 
>

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 5 Sep 2017 14:24:20 -0400

Plus, if you don’t want a date, then don’t put a date object in your document at all. 

Tom

> On Sep 5, 2017, at 2:17 PM, Tom Pusateri <[email-masked]> wrote:
> 
> I remember trying
> 
> <date />
>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 5 Sep 2017 22:13:11 +0200

> Plus, if you don’t want a date, then don’t put a date object in your document at all.

In XML2RFC, the date object is required but can be empty. Yes, that's silly.

See 
<https://www.greenbytes.de/tech/webdav/rfc7991.html#n-additional-changes-from-v2>.

Best regards, Julian