Subject: [xml2rfc] New xml2rfc release: v2.8.3

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 04 Jan 2018 05:28:10 -0800

Hi,

This is an automatic notification about a new xml2rfc release, 
v2.8.3, generated when running the mkrelease script.

Release notes:

xml2rfc (2.8.3) ietf; urgency=low
  * Changed the python 3 code that reads in an xml file to read as binary, 
    in order to not run into issues with unicode conversion before we have had 
    time to look at the encoding attribute of the <xml/> element.

The preferred way to install xml2rfc is by doing 'pip install xml2rfc',
and 'pip install --upgrade xml2rfc' to upgrade.

The new version is also available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/xml2rfc/tags/cli/2.8.3'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Randy Bush <[email-masked]>
Date: Thu, 04 Jan 2018 23:52:44 +0900

the klutz does it again

macosx 10.13.2 with an intel chip inside :)

ryuu.rg.net:/Users/randy# pip install --upgrade xml2rfc
The directory '/Users/randy/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/Users/randy/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting xml2rfc
  Downloading xml2rfc-2.8.3.tar.gz (1.7MB)
    100% |################################| 1.7MB 781kB/s 
Collecting lxml>=2.2.8 (from xml2rfc)
  Downloading lxml-4.1.1-cp27-cp27m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (8.7MB)
    100% |################################| 8.7MB 154kB/s 
Requirement already up-to-date: requests>=2.5.0 in /Library/Python/2.7/site-packages (from xml2rfc)
Collecting six (from xml2rfc)
  Downloading six-1.11.0-py2.py3-none-any.whl
Collecting certifi>=2017.4.17 (from requests>=2.5.0->xml2rfc)
  Downloading certifi-2017.11.5-py2.py3-none-any.whl (330kB)
    100% |################################| 337kB 1.3MB/s 
Requirement already up-to-date: chardet<3.1.0,>=3.0.2 in /Library/Python/2.7/site-packages (from requests>=2.5.0->xml2rfc)
Requirement already up-to-date: idna<2.7,>=2.5 in /Library/Python/2.7/site-packages (from requests>=2.5.0->xml2rfc)
Requirement already up-to-date: urllib3<1.23,>=1.21.1 in /Library/Python/2.7/site-packages (from requests>=2.5.0->xml2rfc)
Installing collected packages: lxml, six, xml2rfc, certifi
  Found existing installation: lxml 4.0.0
    Uninstalling lxml-4.0.0:
      Successfully uninstalled lxml-4.0.0
  Found existing installation: six 1.4.1
    DEPRECATION: Uninstalling a distutils installed project (six) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will only partially uninstall the project.
    Uninstalling six-1.4.1:
Exception:
Traceback (most recent call last):
  File "/Library/Python/2.7/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/Library/Python/2.7/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/Library/Python/2.7/site-packages/pip/req/req_set.py", line 778, in install
    requirement.uninstall(auto_confirm=True)
  File "/Library/Python/2.7/site-packages/pip/req/req_install.py", line 754, in uninstall
    paths_to_remove.remove(auto_confirm)
  File "/Library/Python/2.7/site-packages/pip/req/req_uninstall.py", line 115, in remove
    renames(path, new_path)
  File "/Library/Python/2.7/site-packages/pip/utils/__init__.py", line 267, in renames
    shutil.move(old, new)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 302, in move
    copy2(src, real_dst)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 131, in copy2
    copystat(src, dst)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 103, in copystat
    os.chflags(dst, st.st_flags)
OSError: [Errno 1] Operation not permitted: '/var/folders/n5/5bnd84lj4fs52mrhxgb8k5l80000gn/T/pip-KIZ4Lu-uninstall/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/six-1.4.1-py2.7.egg-info'

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 4 Jan 2018 16:51:25 +0100

Hi Randy,

On 2018-01-04 15:52, Randy Bush wrote:

...

>     DEPRECATION: Uninstalling a distutils installed project (six) has been deprecated and will be removed in a future version. This is due to the fact that uninstalling a distutils project will onl…

...

Yeah, this happens with some combinations of system- and pip-installed
packages.

Please try:

  $ pip install --upgrade --no-deps xml2rfc

Best,

	Henrik

---

From: Randy Bush <[email-masked]>
Date: Fri, 05 Jan 2018 00:55:30 +0900

>   $ pip install --upgrade --no-deps xml2rfc

bingo

thanks

randy