Subject: [xml2rfc] Reference short names

From: Tom Pusateri <[email-masked]>
Date: Wed, 28 Feb 2018 13:50:21 -0500

Is there a way to reference Internet Drafts by a shorter name than the standard I-D.ietf-tls-tls13 ?

I have a co-author who insists on using short names and includes the whole reference manually for drafts and they have to be updated each time they are changed. If we used the standard references, they wouldn’t need to be updated but then we get the ugly names. It would be nice to have a way to alias ugly draft names with shorter, more meaningful names.

As an example, here is the declaration to TLS 1.3:

<!ENTITY I-D.ietf-tls-tls13                SYSTEM  "http://xml.resource.org/public/rfc/bibxml3/reference.I-D.ietf-tls-tls13.xml”>

which can then be used later in the draft as <xref target="I-D.ietf-tls-tls13”>

But I would prefer to use <xref target=“TLS1.3”> if possible. Is there a way to alias this without losing the ability to suck in the reference?

Thanks,
Tom

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 Feb 2018 19:57:00 +0100

> But I would prefer to use <xref target=“TLS1.3”> if possible. Is there a way to alias this without losing the ability to suck in the reference?

Users of rfc2629.xslt can take advantage of 
<https://www.greenbytes.de/tech/webdav/rfc7991.html#element.displayreference> 
- so that would require on pre-processing step before feeding stuff into 
xml2rfc.

Best regards, Julian

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 28 Feb 2018 18:51:57 -0500

> On Feb 28, 2018, at 1:57 PM, Julian Reschke <[email-masked]> wrote:
> 
> Users of rfc2629.xslt can take advantage of <https://www.greenbytes.de/tech/webdav/rfc7991.html#element.displayreference> - so that would require on pre-processing step before feeding stuff into xml2rfc.
> 
> Best regards, Julian

Thanks! I’ll look forward to using v3.

Tom

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 1 Mar 2018 08:43:57 +0400

Being able to freely choose the reference anchor is a feature of kramdown-rfc.  Please see http://RFC.space

(I'm on vacation right now so unfortunately I can't offer my usual service of upconverting XML into markdown.)

Sent from mobile

> On 28. Feb 2018, at 22:50, Tom Pusateri <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
> 
>