Subject: [xml2rfc] Conversion Help --

From: "Russ White" <[email-masked]>
Date: Sat, 26 May 2018 02:08:51 -0400

Y'all --

I've always found the errors generated by xml2rfc to be rather... esoteric. But in this case, I am completely baffled. This is what I'm getting --

==
ERROR: Unable to validate the XML document: INPUT
 <string>: Line 285: Element section content does not follow the DTD, expecting ((t | figure | texttable | iref)* , section*), got (t t t t t figure CDATA xref CDATA)
==

I have no idea where to even begin looking for the error here. I've double checked all the <t>'s are matched with </t>'s, and all the other usual stuff. I have _no_ idea what to look for in order to find the problem and get this doc to compile. Any hints? I assume the problem is before line 285 in the xml file, but since I didn't change anything before line 285 since the last revision, I have no idea what it would be. The xml file is here --

https://www.dropbox.com/s/j4najz77ex9fcbh/draft-ietf-v6ops-ipv6rtr-reqs-04.xml?dl=0

😊 /r

---

From: Matthew Kerwin <[email-masked]>
Date: Sat, 26 May 2018 17:07:20 +1000

On 26 May 2018 at 16:08, Russ White <[email-masked]> wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

The error says that you have 'CDATA xref CDATA' after the <figure/>.
Line 371 ("The configuration datastores in this figure follow...") has
bare character data either side of an <xref/>; perhaps this line
should be wrapped in a <t/> element or something?

Cheers
-- 
  Matthew Kerwin
  https://matthew.kerwin.net.au/

---

From: "Russ White" <[email-masked]>
Date: Sat, 26 May 2018 03:13:57 -0400

> The error says that you have 'CDATA xref CDATA' after the <figure/>.

Which apparently means this --

> Line 371 ("The configuration datastores in this figure follow...") has bare
> character data either side of an <xref/>; perhaps this line should be wrapped
> in a <t/> element or something?

I was not looking for an error so many lines after the error line indicated by xml2rfc -- thanks. 

😊 /r

---

From: Randy Bush <[email-masked]>
Date: Sat, 26 May 2018 07:08:36 -0700

> indicated by xml2rfc -- thanks.

if you can quickly diagnose abd fix four xml2rfc errors, you should have
no problem with the most complex ikea furniture :)

---

From: Julian Reschke <[email-masked]>
Date: Sun, 27 May 2018 08:26:09 +0200

On 2018-05-26 09:13, Russ White wrote:
> ...

FWIW, rfc2629.xslt produces this warning:

> WARNING: No text content allowed inside &lt;section&gt;, but found:
> 
> The configuration datastores in this figure follow  (at line 313)

Best regards, Julian