Subject: [xml2rfc] needLines not working for me

From: Toerless Eckert <[email-masked]>
Date: Wed, 6 Jun 2018 19:48:21 +0200

Trying to fit a long artwork onto a single page, but xml2rfc.tools.ietf.org
fails me.

https://tools.ietf.org/id/draft-ietf-anima-autonomic-control-plane-13.xml

anchor="acp-grasp-picture"

<t>
   <?rfc needLines="100" ?>
   <figure anchor='acp-grasp-picture'>
              <artwork>
	               ACP:
		       ...

Doesn't matter where i  put the needLines. Either it doesn't do anything
(picture still cuts across page), or i put it into the artwork and
picture vanishes..

Any suggestions welcome.

Thanks
    Toerless

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 6 Jun 2018 20:59:42 +0200

On Jun 6, 2018, at 19:48, Toerless Eckert <[email-masked]> wrote:
> (picture still cuts across page), 

100 line figures won’t fit on a page.  Try shaving off a few lines and see if that works?

(Maybe needLines is better outside the <t>, though?)

Grüße, Carsten

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 7 Jun 2018 02:03:22 -0400

Toerless,

If the figure's really 100 lines long, then split it into two figures, so
you can control exactly where the page break will occur (between the top
and bottom parts of the figure).

Cheers,
Andy

On Wed, Jun 6, 2018 at 2:59 PM, Carsten Bormann <[email-masked]> wrote:

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 7 Jun 2018 21:19:08 +0200

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/344

Finding some xml where needLines did work helped me to figure it out.
Many needLines in current draft xml seem to be non-working 100 probably from
some pre-processors. 

On Wed, Jun 06, 2018 at 08:59:42PM +0200, Carsten Bormann wrote:
> 100 line figures won???t fit on a page.  Try shaving off a few lines and see if that works?
> 

-- 
---
[email-masked]

---

From: [email-masked] (Dale R. Worley)
Date: Sun, 10 Jun 2018 18:43:25 -0400

>    <?rfc needLines="100" ?>

The page size is fixed, so it's impossible to satisfy the specification
of "<?rfc needLines="100" ?>".  Really, XML2RFC should abort with a
clear error message.

Dale