Subject: [xml2rfc] xml2rfc for Fedora 28

From: Robert Moskowitz <[email-masked]>
Date: Sun, 3 Jun 2018 20:08:56 -0400

I have just done a new install of Fedora 28...

I see the following rpms in the repo:

python2-xml2rfc.noarch 2.5.2-4.fc28                    fedora
python3-xml2rfc.noarch 2.5.2-4.fc28                    fedora

yet:

# dnf install xml2rfc
Last metadata expiration check: 2:22:41 ago on Sun 03 Jun 2018 05:33:23 
PM EDT.
No match for argument: xml2rfc
Error: Unable to find a match

I suspect for my system that python3 might be needed explicitly.

And anyway this is old, as I have xml2rfc-2.6.1.tar.gz from back last 
August.

The IETF page: https://tools.ietf.org/tools/

says

There's a tutorial available on how to install from PyPi, or if you're 
impatient you can try the following commands on the command line:
   pip install xml2rfc
if that fails:
   easy_install pip
   pip install xml2rfc
if that fails, go to the tutorial above.

What is the recommended way to install this?  I got to get working on a 
BUNCH of drafts this week....

thanks

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 4 Jun 2018 02:23:37 +0200

Hi Bob,

I would recommend:

  $ pip install xml2rfc

(or if needed on your system,
  $ sudo pip install xml2rfc).

If there's no pip, there should be a system package for that, which in
turn should pull in python if needed.

xml2rfc will run under both python 2.7 and 3.x (for most x), so you should
not have to worry about which is your system installed python, just go
with the one you have.

Best regards,

	Henrik

On 2018-06-04 02:08, Robert Moskowitz wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 3 Jun 2018 20:40:13 -0400

Henrik,

Thanks.  pip was already installed, so I now have your latest version 
and now to get serious writing....

Bob