Subject: [xml2rfc] #348 (Version_3_cli_txt): xml2rfc 2.10.0 (v3 xml): no section names generated

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 05 Aug 2018 11:11:50 -0000

#348: xml2rfc 2.10.0 (v3 xml): no section names generated

 xml2rfc version: 2.10.0

 Using RFC 7991 to generate XML and let xml2rfc generate text, the
 following generates a section number by no title:

 {{{
     <section>
       <name>Syntax</name>
       <t>The high-order bit of the IP fragment offset field is the only
 unused
 bit in the IP header.  Accordingly, the selection of the bit position
 is not left to IANA.</t>
       <t>The bit field is laid out as follows:</t>
     </section>
 }}}

 Attaching all XML and text output. There is also something weird the
 <bcp14> tag handling

-- 
-------------------------------+-----------------
 Reporter:  [email-masked]       |      Owner:
     Type:  defect             |     Status:  new
 Priority:  medium             |  Milestone:
Component:  Version_3_cli_txt  |    Version:
 Keywords:                     |
-------------------------------+-----------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/348>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sun, 05 Aug 2018 11:53:30 -0000

Comment (by [email-masked]):

 With `--v3` this fares better, leaves:

 {{{
 Parsing file x
 x(3): Warning: The document date (2018-04-01) is more than 3 days away
 from today's date
 x(2): Warning: Expected a category, one of std,historic,bcp,exp,info, but
 found none
 x(43): Warning: No renderer for <bcp14> found
 Created file x.txt
 }}}

-- 
--------------------------------+-----------------
Resolution:                     |   Keywords:
--------------------------------+-----------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/348#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>