Subject: [xml2rfc] #355 (Version_3_cli_txt): <postamble> really deprecated?

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 06 Aug 2018 20:10:45 -0000

#355: <postamble> really deprecated?

 Seems to be, by far the best way to type set a caption.

 Now I need to generated a paragraph *after* the figure, that seems
 strange. Esp because the content AST I'm parsing has the caption as a
 child of the figure.

 (not per se a rendering issue - or maybe haven't tried it because of this
 problem)

-- 
-------------------------------+-------------------
 Reporter:  [email-masked]       |      Owner:
     Type:  defect             |     Status:  new
 Priority:  medium             |  Milestone:
Component:  Version_3_cli_txt  |    Version:  2.4.x
 Keywords:                     |
-------------------------------+-------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/355>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 06 Aug 2018 20:16:40 -0000

Comment (by [email-masked]):

 Ok, so this

 {{{
 <figure>
 <artwork>println(&quot;some code&quot;)
 </artwork>
 <postamble>That's some nice code.
 </postamble>
 </figure>
 }}}
 doesn't get a deprecated warning, (yeah!), but is text rendered to
 {{{

    println("some code")

    That's some nice code.
 }}}

 I was, at minimum, promised a figure counter :-): "Contains a figure with
 a caption with the figure number".

 There more I look at the test in 7991, the less sense it makes; are
 captions and figure counters supported or not?

-- 
--------------------------------+-------------------
Resolution:                     |   Keywords:
--------------------------------+-------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/355#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 06 Aug 2018 22:16:56 -0000

Adding a <name> tag as mentioned in #356 and having this xml:
 {{{
 <figure>
   <artwork>
     <name>Artwork 1</name>
     println(&quot;some code&quot;)
 </artwork>
 <postamble>That's some nice code.
 </postamble>
 </figure>
 </section>
 }}}
 Leads to this being generated:
 {{{

    (Artwork only available as None: <None>)

    That's some nice code.

 }}}

 Think I've put the XML in the wrong spot, so FYI.

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/355#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Mon, 06 Aug 2018 22:19:46 -0000

yeah, having the correct XML, where <name> is a child of figure:
 {{{
 <figure>
     <name>Artwork 1</name>
   <artwork>println(&quot;some code&quot;)
 </artwork>
 <postamble>That's some nice code.
 </postamble>
 </figure>
 </section>
 }}}
 creates
 {{{
    println("some code")

                             Figure 1: Artwork 1

    That's some nice code.
 }}}
 probably should use <postamble>. So <name> is basically the new
 <postamble>? That not clear from the spec (if it is)

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/355#comment:3>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>