Subject: [xml2rfc] #360 (Version_3_cli_txt): Historic IPR values are now allowed

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 25 Aug 2018 06:49:48 -0000

#360: Historic IPR values are now allowed

 I'm trying values from https://tools.ietf.org/html/rfc7991#appendix-A.1
 But the historic ones are not allowed:

 {{{
 <?xml version="1.0" encoding="utf-8"?>
 <!-- name="GENERATOR" content="github.com/mmarkdown/mmark markdown
 processor for Go" -->
 <rfc version="3" ipr="*2026" submissionType="IETF" category="info"
 xml:lang="en" consensus="false"
 xmlns:xi="http://www.w3.org/2001/XInclude">

 <front>
 <title abbrev="The Naming of Hosts">The Naming of Hosts</title><seriesInfo
 value="2100" stream="IETF" status="informational" name="RFC"></seriesInfo>
 ...
 }}}

 Leads to:
 {{{
 xml2rfc --text --v3 2100.xml && rm 2100.xml
 Parsing file 2100.xml
 2100.xml(3): Error: Unknown ipr attribute: *2026
 Cannot continue, quitting now
 }}}

-- 
-------------------------------+-------------------
 Reporter:  [email-masked]       |      Owner:
     Type:  defect             |     Status:  new
 Priority:  medium             |  Milestone:
Component:  Version_3_cli_txt  |    Version:  2.4.x
 Keywords:                     |
-------------------------------+-------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/360>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 25 Aug 2018 12:40:55 +0200

>  But the historic ones are not allowed:

Correct.  Additional historic values may (but no promises) be added at a
later date.

	Henrik