Subject: Re: [xml2rfc] #370 (Version_3_cli_txt): xml2rfc crash with empty artwork

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 15 Sep 2018 15:32:55 -0000

#370: xml2rfc crash with empty artwork

Comment (by [email-masked]):

 Replying to [comment:1 miek@…]:
 > The text rendering is also not that great
 > {{{
 > 1.  Introduction
 >
 >    (Artwork only available as None: )
 >
 >    (Artwork only available as None: )(Artwork only available as
 None: )
 >                             Figure 1: Mama Mia.
 > }}}

 Umm.  I'm going to add a warning during preptool run when reading an empty
 artwork src file.  But when we arrive at rendering, and have no text
 content, and no type value has been set, what would be a better message?

-- 
--------------------------------+-------------------
  Reporter:  [email-masked]       |      Owner:
      Type:  defect             |     Status:  new
  Priority:  medium             |  Milestone:
 Component:  Version_3_cli_txt  |    Version:  2.4.x
Resolution:                     |   Keywords:
--------------------------------+-------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/370#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 15 Sep 2018 15:39:38 -0000

From [2563]:

 Added error messages for empty artwork files.  Tweaked the error message
 for missing artwork text.  Addresses issue #370

Ticket URL: </ticket/370#comment:3>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Tue, 18 Sep 2018 22:48:10 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Lacking further input, I'm closing this as fixed.

-- 
--------------------------------+--------------------
  Reporter:  [email-masked]       |      Owner:
      Type:  defect             |     Status:  closed
  Priority:  medium             |  Milestone:
 Component:  Version_3_cli_txt  |    Version:  2.4.x
Resolution:  fixed              |   Keywords:
--------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/370#comment:4>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>