Subject: [xml2rfc] new ID cited in another document

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 10 Oct 2018 20:56:07 +0200

Hi,

I've submitted some minutes ago a new document (draft-bp-v6ops-ipv6-ready-dns-dnssec-00).

This document is being cited by another document, using
<xref target="I-D.bp-v6ops-ipv6-ready-dns-dnssec"/>

And I've, at Informative References section:
<?rfc include="reference.I-D.bp-v6ops-ipv6-ready-dns-dnssec.xml" ?>

I'm using the same format in the same and other documents and it works, but in this case, when I use the xml2rfc to make a txt version, I get:

INPUT: Line 1610: Unable to resolve external request: "reference.I-D.bp-v6ops-ipv6-ready-dns-dnssec.xml"

If I try to submit it, get "An exception occurred when trying to process the XML file:"

There is any delay so citations get indexed or something like?

Thanks!

Regards,
Jordi

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Fred Baker <[email-masked]>
Date: Wed, 10 Oct 2018 12:15:43 -0700

The first question I would ask is whether the cron job that creates the bibliographic entry has run yet. I think it runs daily. For safety, you might create the reference object manually (then you know it exists), and use the import when you update the document.

> On Oct 10, 2018, at 11:56 AM, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 10 Oct 2018 21:50:28 +0200

Hi Jordi,

On 2018-10-10 20:56, JORDI PALET MARTINEZ wrote:
> Hi,
> 
> I've submitted some minutes ago a new document
> (draft-bp-v6ops-ipv6-ready-dns-dnssec-00).
> 
> This document is being cited by another document, using <xref
> target="I-D.bp-v6ops-ipv6-ready-dns-dnssec"/>
> 
> And I've, at Informative References section: <?rfc
> include="reference.I-D.bp-v6ops-ipv6-ready-dns-dnssec.xml" ?>
> 
> I'm using the same format in the same and other documents and it
> works, but in this case, when I use the xml2rfc to make a txt
> version, I get:
> 
> INPUT: Line 1610: Unable to resolve external request:
> "reference.I-D.bp-v6ops-ipv6-ready-dns-dnssec.xml"
> 

Yes.  New reference files are generated once per hour (unless the machine
is heavily loaded; then there can be delays).

I just checked, and the reference file has been generated and is available
on the server now.

Now, if xml2rfc tried to fetch the reference file before it was available,
the local cache may remember that, and wait for the cache to time out.

If you don't get better results now that the file is available on the
server, you should ask xml2rfc to clear its local cache with the command:

  xml2rfc --clear-cache

Best regards,

	Henrik

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 10 Oct 2018 22:02:46 +0200

Hi Henrik,

It worked just waiting, thanks a lot!

Regards,
Jordi

-----Mensaje original-----
De: Henrik Levkowetz <[email-masked]>
Fecha: miércoles, 10 de octubre de 2018, 21:50
Para: JORDI PALET MARTINEZ <[email-masked]>
Asunto: Re: [xml2rfc] new ID cited in another document

    Hi Jordi,

    

    
      xml2rfc --clear-cache

    Best regards,
    
    	Henrik