Subject: [xml2rfc] url ref

From: Randy Bush <[email-masked]>
Date: Fri, 02 Nov 2018 13:58:57 +0700

a recent update seems to have changed

    <?rfc include="https://xml2rfc.tools.ietf.org/public/rfc/bibxml-doi/reference.DOI.10.1145/2975159.xml?anchor=JUPITER"?>

what should i be doing?

randy

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 2 Nov 2018 14:10:06 +0700

What has changed and how is this unexpected/undesirable?

Grüße, Carsten

> On Nov 2, 2018, at 13:58, Randy Bush <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Randy Bush <[email-masked]>
Date: Fri, 02 Nov 2018 14:11:48 +0700

>>    <?rfc include="https://xml2rfc.tools.ietf.org/public/rfc/bibxml-doi/reference.DOI.10.1145/2975159.xml?anchor=JUPITER"?>

this worked a rev or two back.  it does not now.  not working is
undesirable and unexpected.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 2 Nov 2018 14:54:36 +0700

Sorry, I thought something might be wrong with the data at that URI, and these looked fine to me.
So I conclude xml2rfc itself doesn’t do the include right, any more, and that is indeed a surprise.
However, it seems to work for me (xml2rfc-2.12.3), so more information would be useful.

Grüße, Carsten

> On Nov 2, 2018, at 14:11, Randy Bush <[email-masked]> wrote:
>

---

From: "Randy Bush" <[email-masked]>
Date: Fri, 02 Nov 2018 15:02:20 +0700

> However, it seems to work for me (xml2rfc-2.12.3), so more information 

ryuu.rg.net:/Users/randy> xml2rfc --version
xml2rfc 2.12.3

on a macinslosh high sierra

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 2 Nov 2018 15:08:19 +0700

Same here:

sev [~]$ uname -v
Darwin Kernel Version 17.7.0: Wed Oct 10 23:06:14 PDT 2018; root:xnu-4570.71.13~1/RELEASE_X86_64
sev [~]$ xml2rfc --version
xml2rfc 2.12.3

What is the symptom of “not working”?

Grüße, Carsten

> On Nov 2, 2018, at 15:02, Randy Bush <[email-masked]> wrote:
>

---

From: "Randy Bush" <[email-masked]>
Date: Fri, 02 Nov 2018 15:11:17 +0700

ignore me.  reinstalled.  now happy <blush>