Subject: [xml2rfc] New version of xml2rfc?

From: Eric Burger <[email-masked]>
Date: Fri, 23 Nov 2018 16:15:35 -0500

Hmmm. New version of xml2rfc this morning. As of this afternoon, none of my XML files compile. Coincidence? Well, I tried to convert well-known xml files, like of published RFC’s, and they fail, too.

Typical response in error window: (this is trying on https://tools.ietf.org/id/draft-ietf-sipcore-name-addr-guidance-02.xml <https://tools.ietf.org/id/draft-ietf-sipcore-name-addr-guidance-02.xml> )

Generating Text output in ASCII format

Expanding internal references and generating Text

Using XML_LIBRARY=/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7:/home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8

Parsing file INPUT
Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.3261.xml
Loaded from cache reference.RFC.3261.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5234.xml
Loaded from cache reference.RFC.5234.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.2119.xml
Loaded from cache reference.RFC.2119.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.8174.xml
Loaded from cache reference.RFC.8174.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.3515.xml
Loaded from cache reference.RFC.3515.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.3892.xml
Loaded from cache reference.RFC.3892.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.4508.xml
Loaded from cache reference.RFC.4508.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5360.xml
Loaded from cache reference.RFC.5360.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.3325.xml
Loaded from cache reference.RFC.3325.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5002.xml
Loaded from cache reference.RFC.5002.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5318.xml
Loaded from cache reference.RFC.5318.xml
Resolving entity... https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5502.xml
Loaded from cache reference.RFC.5502.xml
Error: Unable to validate the XML document: INPUT
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 23 Nov 2018 22:22:28 +0100

Hi Eric,

On 2018-11-23 22:15, Eric Burger wrote:
> Hmmm. New version of xml2rfc this morning. As of this afternoon, none
> of my XML files compile. Coincidence? Well, I tried to convert
> well-known xml files, like of published RFC’s, and they fail, too.
> 
> Typical response in error window: (this is trying on
> https://tools.ietf.org/id/draft-ietf-sipcore-name-addr-guidance-02.xml
> <https://tools.ietf.org/id/draft-ietf-sipcore-name-addr-guidance-02.xml>
> )

Thanks for the alert.  I'll look at this immediately.

Best regards,

	Henrik
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 23 Nov 2018 22:48:31 +0100

Hi Eric,

Could you try again please?  Version 2.14.1 is now out with a fix for
the issue, and installed on the tools servers.

	Henrik

---

From: Eric Burger <[email-masked]>
Date: Fri, 23 Nov 2018 18:32:34 -0500

Awesome! Thanks.

> On Nov 23, 2018, at 4:48 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Eric,
>