Subject: [xml2rfc] #379 (Version_3_cli_txt): failure with missing consensus attribute

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 17 Nov 2018 14:02:40 -0000

#379: failure with missing consensus attribute

 yields:

 {{{
 foo.xml(11): Warning: Expected a valid submissionType (stream) setting,
 one of IETF, IAB, IRTF, independent, but found None.  Will use 'IETF'
 Traceback (most recent call last):
   File "/bin/xml2rfc", line 11, in <module>
     sys.exit(main())
   File "/usr/lib/python3.6/site-packages/xml2rfc/run.py", line 423, in
 main
     xmlrfc.tree = prep.prep()
   File "/usr/lib/python3.6/site-packages/xml2rfc/writers/preptool.py",
 line 377, in prep
     func(e, e.getparent())
   File "/usr/lib/python3.6/site-packages/xml2rfc/writers/preptool.py",
 line 471, in check_attribute_values
     consensus = consensus_values[0]
 TypeError: 'dict_keys' object does not support indexing

 }}}

 but RFC 7991 defines a default of "false".

-- 
-----------------------------------+--------------------
 Reporter:  [email-masked]  |      Owner:
     Type:  defect                 |     Status:  new
 Priority:  medium                 |  Milestone:
Component:  Version_3_cli_txt      |    Version:  2.13.x
 Keywords:                         |
-----------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/379>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 17 Nov 2018 14:26:52 -0000

Comment (by [email-masked]):

 I don't see this here when I run 2.13.0 with options --html --v3 (guessing
 at the options you may have used).  What was your command line, please?

-- 
------------------------------------+--------------------
Resolution:                         |   Keywords:
------------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/379#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 17 Nov 2018 14:48:32 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [2744]:

 Under python 3.6, dictionary keys() return a set-like object that cannot
 be indexed.  Convert to list for our purposes.  Fixes issue #379

-- 
------------------------------------+--------------------
  Reporter:  [email-masked]  |      Owner:
      Type:  defect                 |     Status:  closed
  Priority:  medium                 |  Milestone:
 Component:  Version_3_cli_txt      |    Version:  2.13.x
Resolution:  fixed                  |   Keywords:
------------------------------------+--------------------

Ticket URL: </ticket/379#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 17 Nov 2018 17:01:13 -0000

Comment (by [email-masked]):

 just "--v3", no "--html"...

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/379#comment:3>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 17 Nov 2018 17:08:32 -0000

Thanks.  Should be fixed in 2.13.1, just out.

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/379#comment:4>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>