Subject: [xml2rfc] Having Travis build RFCs

From: Roland Hedberg <[email-masked]>
Date: Tue, 4 Dec 2018 16:20:20 +0100

Hi!

I have a GitHub repo with a XML file that I want xml2rfc to build text and html versions of.

I have no problem building text and html versions locally on my own machine but it doesn’t work on Travis.

The repo can be found here https://github.com/rohe/oidcfederation <https://github.com/rohe/oidcfederation>

The error I get looks like this:

$ xml2rfc draft/oidcfed.hf.xml --text -o public/oidcfed-05.txt
Parsing file draft/oidcfed.hf.xml
Error: Unable to validate the XML document: draft/oidcfed.hf.xml
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
 <string>: Line 1: No declaration for attribute base of element reference
travis_time:end:29eb956e:start=1543934300589404521,finish=1543934305893353330,duration=5303948809

The command "xml2rfc draft/oidcfed.hf.xml --text -o public/oidcfed-05.txt" exited with 1.
Any help is appreciate !!

— Roland

The higher up you go, the more mistakes you are allowed. Right at the top, if you make enough of them, it's considered to be your style. 
-Fred Astaire, dancer, actor, singer, musician, and choreographer (10 May 1899-1987)

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 4 Dec 2018 17:06:09 +0100

Hi Roland,

I think this is an issue with xml2rfc, resulting from a change to make
included files have an xml:base attribute showing from where they were
fetched.

I'll have a fix out later today.

Best regards,

	Henrik

On 2018-12-04 16:20, Roland Hedberg wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 4 Dec 2018 17:12:20 +0100

Ok, fix in place.  You should have better luck now.  Let me know how it goes.

Bästa hälsningar,

	Henrik

---

From: Roland Hedberg <[email-masked]>
Date: Tue, 4 Dec 2018 17:52:59 +0100

Yeah !! It worked !

Thanks ever so much!

Tack så hemskt mycket :-)

> On 4 Dec 2018, at 17:12, Henrik Levkowetz <[email-masked]> wrote:
> 

— Roland