Subject: [xml2rfc] Weird HTML interpretation

From: Roland Hedberg <[email-masked]>
Date: Sat, 19 Jan 2019 10:17:36 +0100

Hi!

I have XML where a part looks like this (only a snippet here, the whole
XML file is here https://github.com/rohe/oidcfederation/blob/devel/draft/oidcfed.hf.xml <https://github.com/rohe/oidcfederation/blob/devel/draft/oidcfed.hf.xml>):

          <list style="hanging">
            <t hangText="subset_of">
              <vspace/>
              The resulting value of the claim will be the intersection of the
              values specified here and the values of the claim. For
              instance, the Claim policy:
              <figure>
                <artwork><![CDATA[
  "response_types": {
    "subset_of": ["code", "code token", "code id_token"]}
]]></artwork>
              </figure>

              if applied to a metadata statement with:
              <figure>
                <artwork><![CDATA[
  "response_types": ["code", "code id_token token", "code id_token"]
]]></artwork>
              </figure>
              will result in the statement:

              <figure>
                <artwork><![CDATA[
  "response_types": ["code", "code id_token"]
]]></artwork>
              </figure>
            </t>
A number of similar items before the list is closed.
I had not expected the ‘code snippets’ to end up outside the list in the HTML representation but that is what they did.
I got 
<pre>
  "response_types": {
    "subset_of": ["code", "code token", "code id_token"]}
</pre>
<pre>
  "response_types": ["code", "code id_token token", "code id_token"]
</pre>
<pre>
  "response_types": ["code", "code id_token"]
</pre>
and then the <dl> part
<dl>
<dt>subset_of</dt>
<dd style="margin-left: 8">
<br> The resulting value of the claim will be the intersection of the values specified here and the values of the claim. For instance, the Claim policy: </dd>

In the text representation everything turned out as expected:
subset_of
   The resulting value of the claim will be the intersection of the
   values specified here and the values of the claim.  For instance,
   the Claim policy:

  "response_types": {
    "subset_of": ["code", "code token", "code id_token"]}

   if applied to a metadata statement with:

  "response_types": ["code", "code id_token token", "code id_token"]

   will result in the statement:

  "response_types": ["code", "code id_token"]

Weird!

Running xml2rfc 2.16.3
— Roland
Can anything be sadder than work left unfinished? Yes, work never begun. -Christina Rossetti, poet (5 Dec 1830-1894)

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 19 Jan 2019 14:16:48 +0100

Hi Roland,

Yes, the default HTML output (which will soon be the legacy HTML output) is
known to have a number of deficiencies.  Since current work is going into
the v3 output formats, maybe the v3 html output would work for your, if you
need HTML?

I enclose a sample, this is generated from your xml file after setting a valid
ipr attribute and full URLs for reference files (also attached).

This was produced with the command 'xml2rfc --html --v3 oidcfed.hf.xml'

( That line is actually a shortcut for first converting the legacy format xml
  file to v3 xml:

    'xml2rfc --v2v3 oidcfed.hf.xml'

  and then running the v3 html formatter on the result:

    'xml2rfc --html oidcfed.hf.v2v3.xml'
)

Best regards,

	Henrik

On 2019-01-19 10:17, Roland Hedberg wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>