Subject: Re: [xml2rfc] The bibxml entry of RFC 8516 creates an error with xml2rfc

From: Ludwig Seitz <[email-masked]>
Date: Fri, 1 Feb 2019 09:02:48 +0100

On 31/01/2019 16:31, Henrik Levkowetz wrote:
> Hi Ludwig,
> 
> On 2019-01-31 15:05, Ludwig Seitz wrote:
>> On 31/01/2019 14:13, Carsten Bormann wrote:
>>
>>> Something appears to be really broken on your side.  How does “ä” (which is &#228;) turn into &#258;[currency units]?
>>>
>>
>> More data:
>>
>> I'm also using xml2rfc version 2.5.1 on a Ubuntu 18.04 machine. I can
>> reproduce the error (even after manually deleting the cache file).
> 
> Version 2.5.1 is quite old (released 19 Oct 2015) and a lot has happened
> since then with respect to non-ascii support.  I'd suggest upgrading to
> a newer version through 'pip install'.  If the 2.5.1 release had the --utf8
> switch, you could try to do a run with that switch specified to get around
> the immediate issue.  But even if that works, upgrading to a newer version
> seems advisable.

Confirmed, after doing some back-flips (see below) to get xml2rfc 2.17.2 
installed and deleting the cache file it now compiles correctly.

The old xml2rfc version is the culprit. Thanks for the help in hunting 
that down!

/Ludwig

PS: Backflips = pip uninstall xml2rfc, pip3 install xml2rfc, xml2rfc -V, 
hmmm... still  V2.5.1, pip3 uninstall xml2rfc, pip install xml2rfc (out 
of sheer despair), xml2rfc -V, oops suddenly V2.17.2

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

---

From: Ludwig Seitz <[email-masked]>
Date: Thu, 31 Jan 2019 16:46:47 +0100

On 31/01/2019 16:31, Henrik Levkowetz wrote:
> Regards
> 	Henrik

"pip install xml2rfc" gives me version 2.5.1 on Ubuntu 18.04.

/Ludwig

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

---

From: Ari Keränen <[email-masked]>
Date: Fri, 1 Feb 2019 11:35:23 +0000

On 31 Jan 2019, at 15.13, Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:

Ari Keränen really doesn’t need all those pesky umlauts ;-)

I’ll let Ari decide that :-)

Heh, as I mentioned to Ludwig in another thread, I actually used my proper läst name when I started at the IETF +10 years ago but run into so many problems that I stopped pretty fast. After that I've been careful to use the version without extended ASCII in all my drafts, but seems that IETF tools now somehow figured out my real last name.

I've been pretty happy so far with my name without those umlauts, but if we can get this finally fixed, that'd be great!

As discussed later in the thread, some tools turn "ä" into "ae". IMHO, that would be the worst option out of the three. So I much rather use Keranen than that.

Thank you for taking the effort to help fixing this!

Cheers,
Ari

---

From: Samuel Marks <[email-masked]>
Date: Sat, 2 Feb 2019 00:11:35 +1100

Favourite thread on xml2rfc

+1

!!!!

On Fri, 1 Feb 2019 at 10:35 pm, Ari Keränen <[email-masked]>
wrote:

>
>
> On 31 Jan 2019, at 15.13, Carsten Bormann <[email-masked]> wrote:
>
>
> Heh, as I mentioned to Ludwig in another thread, I actually used my
> proper läst name when I started at the IETF +10 years ago but run into so
> many problems that I stopped pretty fast. After that I've been careful to
> use the version without extended ASCII in all my drafts, but seems that
> IETF tools now somehow figured out my real last name.
>
> I've been pretty happy so far with my name without those umlauts, but if
> we can get this finally fixed, that'd be great!
>
> As discussed later in the thread, some tools turn "ä" into "ae". IMHO,
> that would be the worst option out of the three. So I much rather use
> Keranen than that.
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>
-- 
Samuel Marks
http://linkedin.com/in/samuelmarks