Subject: [xml2rfc] #397 (Version_3_cli_txt): xml2rfc crash in handling <author>

From: "xml2rfc issue tracker" <[email-masked]>
Date: Wed, 27 Feb 2019 11:17:59 -0000

#397: xml2rfc crash in handling <author>

 Output:

 {{{
 Traceback (most recent call last):
   File "/bin/xml2rfc", line 10, in <module>
     sys.exit(main())
   File "/usr/lib/python2.7/site-packages/xml2rfc/run.py", line 474, in
 main
     pagedwriter.write(filename)
   File "/usr/lib/python2.7/site-packages/xml2rfc/writers/base.py", line
 1417, in write
     self._build_document()
   File "/usr/lib/python2.7/site-packages/xml2rfc/writers/base.py", line
 1355, in _build_document
     self.write_reference_list(reference_list)
   File "/usr/lib/python2.7/site-packages/xml2rfc/writers/raw_txt.py", line
 754, in write_reference_list
     author_string = self._format_author_string(authors)
   File "/usr/lib/python2.7/site-packages/xml2rfc/writers/base.py", line
 707, in _format_author_string
     elif len(initials) > 0:
 TypeError: object of type 'NoneType' has no len()
 }}}

 I suspect that this has to do with the changes from 2.19.

-- 
-----------------------------------+--------------------
 Reporter:  [email-masked]  |      Owner:
     Type:  defect                 |     Status:  new
 Priority:  medium                 |  Milestone:
Component:  Version_3_cli_txt      |    Version:  2.20.*
 Keywords:                         |
-----------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/397>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Wed, 27 Feb 2019 12:24:53 -0000

Comment (by [email-masked]):

 Command line switches used?

-- 
------------------------------------+--------------------
Resolution:                         |   Keywords:
------------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/397#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Wed, 27 Feb 2019 12:33:18 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Fixed in [3032]:

 Handle initials==Null return value from short_author_name_parts().  Fixes
 issue #397

-- 
------------------------------------+--------------------
  Reporter:  [email-masked]  |      Owner:
      Type:  defect                 |     Status:  closed
  Priority:  medium                 |  Milestone:
 Component:  Version_3_cli_txt      |    Version:  2.20.*
Resolution:  fixed                  |   Keywords:
------------------------------------+--------------------

Ticket URL: </ticket/397#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>