Subject: [xml2rfc] #395 (Version_3_cli_html): html generation fails for SVG artwork

From: "xml2rfc issue tracker" <[email-masked]>
Date: Fri, 22 Feb 2019 09:44:40 -0000

#395: html generation fails for SVG artwork

 Given the attached example, generation of HTML output fails with:

 Parsing file abnftest.xml
 abnftest.xml(12): Error: Expected ascii-art artwork for <artwork type="">,
 but found <artwork xmlns:xlink="http://www.w3.org/1999/xlink"
 xmlns:svg="http://www.w3.org/2000/svg"
 xmlns:xi="http://www.w3.org/2001/XInc...
 Not creating output file due to errors (see above)

-- 
-----------------------------------+--------------------
 Reporter:  [email-masked]  |      Owner:
     Type:  defect                 |     Status:  new
 Priority:  medium                 |  Milestone:
Component:  Version_3_cli_html     |    Version:  2.19.*
 Keywords:                         |
-----------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/395>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Fri, 22 Feb 2019 12:37:43 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => invalid

Comment:

 With no type information given, the interpretation is that this is legacy
 artwork, and thus ascii-art is expected.

-- 
------------------------------------+--------------------
  Reporter:  [email-masked]  |      Owner:
      Type:  defect                 |     Status:  closed
  Priority:  medium                 |  Milestone:
 Component:  Version_3_cli_html     |    Version:  2.19.*
Resolution:  invalid                |   Keywords:
------------------------------------+--------------------

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/395#comment:1>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>

---

From: "xml2rfc issue tracker" <[email-masked]>
Date: Sat, 23 Feb 2019 11:24:25 -0000

Comment (by [email-masked]):

 I think, given the v3 grammar, that interpretation is clearly incorrect.

Ticket URL: <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/395#comment:2>
xml2rfc <http://tools.ietf.org/tools/xml2rfc/>