Subject: [xml2rfc] <dl>, <dt> and <dd>

From: Christian Hopps <[email-masked]>
Date: Tue, 05 Feb 2019 09:53:24 -0500

I'm having a heck of a time getting a <dl> (definition list) working.

I see in the xml2rfc code that it talks about <dl> and hanging lists being deprecated etc, but I cannot get xml2rfc to actual produce any output when I use them. I have to disable DTD validation to even get it to parse.

Can someone help me with a short example of using a <dl> that xml2rfc will understand?

Thanks,
Chris.

---

From: Randy Bush <[email-masked]>
Date: Tue, 05 Feb 2019 08:03:52 -0800

> I'm having a heck of a time getting a <dl> (definition list) working.

i failed, so use hangText

> I see in the xml2rfc code that it talks about <dl> and hanging lists
> being deprecated etc

that will be painful

randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 5 Feb 2019 17:26:31 +0100

Hi Christian,

On 2019-02-05 15:53, Christian Hopps wrote:
> being deprecated etc, but I cannot get xml2rfc to actual produce any
> output when I use them. I have to disable DTD validation to even get
> it to parse.
> 

I think the issue here is that the legacy parser and formatters don't
understand the new vocabulary introduced with RFC 7991.  If you wish
to use that, you should give xml2rfc the --v3 switch, in order to tell
it to run in v3 mode.

Alternatively, you can indicate that your xml source file uses the
v3 vocabulary by setting the attribute version="3" on the <rfc> element.

When v3 mode is deemed mature, it will become the default, and the xml2rfc
version will shift from 2.*.* to 3.*.*.

I hope that helps.

Regards,

	Henrik

---

From: Christian Hopps <[email-masked]>
Date: Tue, 05 Feb 2019 18:54:23 -0500

Hi Henrik,

Yes the --v3 flag did the trick! For some reason I must have tuned out on the CLI help at the --v2v3 option prior to arriving at the --v3 in the lower formatting section. :)

I've been updating the libslax/oxtradoc util to convert org mode to the newer format. In this case to make use of org mode definition lists:

 - Foo :: A foo is special.
 - Bar :: A bar is better.

I'll try feeding the changes back to Phil when done, or sending a pointer to my repo if that doesn't work.

What I'd really like to do is a direct org mode exporter for emacs directly -- we'll see.

Thanks,
Chris.

---

From: Christian Hopps <[email-masked]>
Date: Tue, 12 Feb 2019 06:16:11 -0500

> What I'd really like to do is a direct org mode exporter for emacs directly -- we'll see.

Done.

Waiting on melpa merge for auto-install option before announcing this to ietf@ et al; however, it is available now at:

    https://github.com/choppsv1/org-rfc-export

Thanks,
Chris.