Subject: [xml2rfc] Pagination missing in v3 format (xml2rfc 2.18.0)

From: Christian Hopps <[email-masked]>
Date: Fri, 08 Feb 2019 17:37:08 -0500

So I switched to V3 xml2rfc format, mostly to get <dl><dt><dd> lists, and I cannot seem to get xml2rfc to produce paginated output. The TOC is missing page numbers, which makes sense b/c there are no page breaks/headers/footers/etc. When I do an HTML output the TOC is missing altogether.

Is there something extra I need to do to get pagination?

Thanks,
Chris.

---

From: Miek Gieben <[email-masked]>
Date: Sat, 9 Feb 2019 08:50:52 +0000

This is by design. In the text output there are no pages, just a long
stretch of text.

On Fri, 8 Feb 2019, 22:37 Christian Hopps <[email-masked] wrote:

>
> So I switched to V3 xml2rfc format, mostly to get <dl><dt><dd> lists, and
> I cannot seem to get xml2rfc to produce paginated output. The TOC is
> missing page numbers, which makes sense b/c there are no page
> breaks/headers/footers/etc. When I do an HTML output the TOC is missing
> altogether.
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 9 Feb 2019 10:20:14 +0100

Yes, I got the impression that the v3 design team wanted it that way.  But
it seems that the IESG may want pagination for draft submissions, so we
could still be getting an option to do pagination.

	Henrik

---

From: Christian Hopps <[email-masked]>
Date: Sat, 09 Feb 2019 06:42:03 -0500

Huh, how about that.

I also discovered the that HTML TOC was sitting there on the right side of my browser window as well and I simply missed it, which may sound dumb, but let me try and reason why.

I use a large monitor and a single browser window (normally) so the text is sort of centered in the window with lots of white space on the left and right, then the TOC is on the far right side. This far right side is where Ads normally go, and I guess my brain has literally been trained now to ignore almost any content on the far right.

Has putting the TOC on the left side been considered? I sort of like having it separate and easily clickable anytime, but I fear I won't be the only one experiencing right-side filtering.

Thanks,
Chris.

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 9 Feb 2019 13:49:15 +0100

Hi Chris,

On 2019-02-09 12:42, Christian Hopps wrote:
> 
> Huh, how about that.
> 
> I also discovered the that HTML TOC was sitting there on the right
> side of my browser window as well and I simply missed it, which may
> sound dumb, but let me try and reason why.
> 
> I use a large monitor and a single browser window (normally) so the
> text is sort of centered in the window with lots of white space on
> the left and right, then the TOC is on the far right side. This far
> right side is where Ads normally go, and I guess my brain has
> literally been trained now to ignore almost any content on the far
> right.
> 
> Has putting the TOC on the left side been considered?

I don't know; the creator of the basic CSS will have to answer that.

> I sort of like
> having it separate and easily clickable anytime, but I fear I won't
> be the only one experiencing right-side filtering.

Hmm.  The body text has a width limitation, but I see that in a very
wide window the ToC migrates right, away from the body.  That seems
like a bug.  My first adjustment would be to make it stick next to the
body when the body has reached max width.

	Henrik

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 11 Feb 2019 05:04:47 -0800

Hi folks,

> On Feb 9, 2019, at 1:20 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> 

For this one, yes, pagination was a rather contentious issue and the final rough consensus in the design team was to not support it in the plain text. The ToC is still considered of value in that it provides ordering and summary of material, and people can jump/text search down to the section they are looking for.

The IESG has not discussed pagination for draft submissions as far as I know.

-Heather

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 11 Feb 2019 14:33:16 +0100

I think the confusion is about the transition strategy.
Right now, I can’t ask authors to start working with v3, and if the v3 tools continue to not support the transition, that may never happen.
How are we planning to get there?  In a Big Bang?

Grüße, Carsten

---

From: Heather Flanagan <[email-masked]>
Date: Mon, 11 Feb 2019 05:39:11 -0800

> On Feb 11, 2019, at 5:33 AM, Carsten Bormann <[email-masked]> wrote:
> 

A Big Bang would … really hurt. Let’s not do that. 

I am working with the project team on a plan. First step will be for the data tracker to accept v3 drafts; I don’t see this happening until (shortly) after IETF 104. Until then, we definitely appreciate community testers, but it’s not a terribly organized or coordinated activity. 

I’ll post more information when I have it.

-HEather

---

From: Christian Hopps <[email-masked]>
Date: Mon, 11 Feb 2019 08:44:07 -0500

I warmed up to it after learning it wasn't a bug. All those headers and footers and wasted space and weird diffs not worth it. :)

Thanks,
Chris.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 11 Feb 2019 14:57:35 +0100

On 11.02.2019 14:44, Christian Hopps wrote:
> 
> I warmed up to it after learning it wasn't a bug. All those headers and 
> footers and wasted space and weird diffs not worth it. :)
> 
> Thanks,
> Chris.

+1