Subject: [xml2rfc] Trying to cite RFC 20 produces errors

From: Watson Ladd <[email-masked]>
Date: Tue, 5 Feb 2019 10:13:43 -0800

Dear XML2RFC people,

I am trying to cite RFC 20. Despite the URL in the entity definition
in the head, http:///xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml,
pointing me to the right thing,
the xml2rfc tool produces an error:

Parsing file INPUT
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
Resolving entity...
/usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5280.xml
Loaded from cache reference.RFC.5280.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.5905.xml
Loaded from cache reference.RFC.5905.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.7384.xml
Loaded from cache reference.RFC.7384.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.8174.xml
Loaded from cache reference.RFC.8174.xml
Resolving entity...
http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml
Loaded from cache reference.RFC.2119.xml
Resolving entity...
https://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
 ... 400 https://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
URL retrieval failed with status code 400 for
'https://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml'
Resolving entity...
https://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
 ... 400 https://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
URL retrieval failed with status code 400 for
'https://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml'
Resolving entity...
http://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
 ... 400 http://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
URL retrieval failed with status code 400 for
'http://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml'
Resolving entity...
http://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
 ... 400 http://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
URL retrieval failed with status code 400 for
'http://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml'
Error: Unable to resolve external request:
"../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml",
trying the following location(s):
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    /home/www/tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    https://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    https://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    http://xml2rfc.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
    http://xml2rfc.tools.ietf.org/../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
Error: Unable to parse the XML document: INPUT
 <string>: Line 238: Failure to process entity RFC0020
 <string>: Line 238: Entity 'RFC0020' not defined

Please let me know what I'm doing wrong. I'm happy to minimize the
input on request.

Sincerely,
Watson Ladd

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 5 Feb 2019 19:50:18 +0100

Hi,

On line 13 of your file, please change "http:///xml2rfc.ietf.org" (three
slashes) to "http://xml2rfc.ietf.org" (two slashes).  Or even better, use
"https://xml2rfc.ietf.org" (two slashes).

Regards,

	Henrik

On 2019-02-05 19:13, Watson Ladd wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 5 Feb 2019 14:07:06 -0500

Or, the following works for me:

In the text:

<t>
This is a reference to RFC 20 <xref target="RFC0020"/>.
</t>

At the bottom:

<back>
    <references title="Normative References">
    <?rfc include="reference.RFC.0020"?>
    </references>
</back>

Cheers,
Andy

On Tue, Feb 5, 2019 at 1:50 PM Henrik Levkowetz <[email-masked]>
wrote:

> > in the head, http:///
> xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml,
> >  ... 400
> > '
> '
> >  ... 400
> > '
> '
> >  ... 400
> > '
> '
> >  ... 400
> > '
> '
> > "../../../home/www/
> tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> ",
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml2/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml3/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml4/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml5/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml6/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml7/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >     /home/www/
> tools.ietf.org/tools/xml2rfc/web/public/rfc/bibxml8/../../../home/www/tools.ietf.org/tools/xml2rfc/http:/xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml
> >