Subject: [xml2rfc] only fullname fails in references.

From: Christian Hopps <[email-masked]>
Date: Mon, 25 Feb 2019 06:47:06 -0500

If one has only the 'fullname' attribute set on 'author' tags in references, the author is not listed in the reference. For the document authors one is not required to list 'initials' or 'surname' attributes for the correct thing to happen. I think this is a bug, as the code should be able to re-use the method it has for document authors to generate initials and surname values.

Thanks,
Chris.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 25 Feb 2019 13:27:54 +0100

On 25.02.2019 12:47, Christian Hopps wrote:
> 
> If one has only the 'fullname' attribute set on 'author' tags in 
> references, the author is not listed in the reference. For the document 
> authors one is not required to list 'initials' or 'surname' attributes 
> for the correct thing to happen. I think this is a bug, as the code 
> should be able to re-use the method it has for document authors to 
> generate initials and surname values.

As far as I understand, there is no reliable code to do that, otherwise 
we wouldn't need the additional attributes in the first place.

I think it's ok for an processor to skip incomplete entries, but it 
would be good to generate a warning message.

Best regards, Julian

---

From: Christian Hopps <[email-masked]>
Date: Mon, 25 Feb 2019 08:01:54 -0500

Julian Reschke <[email-masked]> writes:

>> If one has only the 'fullname' attribute set on 'author' tags in references,
>> the author is not listed in the reference. For the document authors one is not
>> required to list 'initials' or 'surname' attributes for the correct thing to
>> happen. I think this is a bug, as the code should be able to re-use the method
>> it has for document authors to generate initials and surname values.
>
> As far as I understand, there is no reliable code to do that, otherwise we
> wouldn't need the additional attributes in the first place.

But it works fine for the document author tags so there must be code in there to do this.

There's reason for the attributes even with auto-generation -- it could be that one does not like the auto-generation results. For example I prefer my abbreviated name to appear as "C. Hopps" (not "C. E. Hopps"), but at least in the past have listed my full name as "Christian E. Hopps".

Thanks,
Chris.

> I think it's ok for an processor to skip incomplete entries, but it would be
> good to generate a warning message.
>
> Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 25 Feb 2019 14:05:39 +0100

On 25.02.2019 14:01, Christian Hopps wrote:
> ...

I wasn't aware of that. I'll claim that this is a non-feature, because 
it's not going to work properly in general.

> There's reason for the attributes even with auto-generation -- it could 
> be that one does not like the auto-generation results. For example I 

...or that they are completely incorrect, such as by missing up family 
name and given name.

> prefer my abbreviated name to appear as "C. Hopps" (not "C. E. Hopps"), 
> but at least in the past have listed my full name as "Christian E. Hopps".
> ...

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 25 Feb 2019 14:06:47 +0100

Hi Chris,

On 2019-02-25 14:01, Christian Hopps wrote:
> There's reason for the attributes even with auto-generation -- it
> could be that one does not like the auto-generation results. For
> example I prefer my abbreviated name to appear as "C. Hopps" (not "C.
> E. Hopps"), but at least in the past have listed my full name as
> "Christian E. Hopps".

Right.

This sounds like a bug.  It may be fixed in the --v3 formatters, though.
I'll investigate further.

Best regards,

	Henrik