Subject: Re: [xml2rfc] bibxml to BibTeX (again?)

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 20 Mar 2019 03:05:22 +0000

Since I didn’t see any responses to this query, there doesn’t appear to be any.

Care to write one?

                Tony Hansen

From: xml2rfc <[email-masked]> on behalf of Behcet Sarikaya <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Thursday, February 21, 2019 at 12:12 PM
To: "[email-masked]" <[email-masked]>
Subject: [xml2rfc] bibxml to BibTeX (again?)

Hi,

Is there a URL I can get bibxml references in bib tex format?
Or a converter (in python) to convert my XMLRFC references into BibTeX format?

Thanks,

Behcet

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 20 Mar 2019 07:41:59 +0100

First three google results:

https://datatracker.ietf.org/doc/rfc8446/bibtex/  (what is behind that?)
https://github.com/iluxonchik/rfc-bibtex
http://notesofaprogrammer.blogspot.com/2014/11/bibtex-entries-for-ietf-rfcs-and.html

Not sure that solved exactly the problem posed, but certainly interesting starting points.

Grüße, Carsten

> On Mar 20, 2019, at 04:05, HANSEN, TONY L <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 20 Mar 2019 14:09:27 +0100

> https://datatracker.ietf.org/doc/rfc8446/bibtex/  (what is behind that?)

Datatracker code, contributed by Lars Eggert 2015-12-02:
  https://trac.tools.ietf.org/tools/ietfdb/changeset/10529

Bästa hälsningar,

	Henrik

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 20 Mar 2019 09:53:32 -0500

Thank you Henrik.

So the procedure is:

go one by one on the reference list
find the entry on data tracker (I am not sure the drafts have a Datatracker
entry, what about tools?),
get its bibtex

Is there a version of Lars Eggert's Python program that runs on my
reference list (input file) and get a file with all the BibTeX references
(output file)?

Bästa hälsningar,

Behcet

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 20 Mar 2019 15:55:08 +0100

Hi Behcet,

> entry, what about tools?),

All drafts have a Datatracker entry, yes

> reference list (input file) and get a file with all the BibTeX references

Not that I'm aware of.

	Henrik

---

From: William Atwood <[email-masked]>
Date: Wed, 20 Mar 2019 07:16:04 -0400

One final step:

Visually verify the BibTeX entry.  Since they are produced by a computer
script, they are sometimes wrong.  The probability of them being wrong
increases as the RFC number gets smaller... 

  Bill

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8