Subject: [xml2rfc] Compilation breaks on: # Foo\n\n ### Bar \n\n

From: Samuel Marks <[email-masked]>
Date: Thu, 28 Mar 2019 17:36:59 +1100

Was scratching my head on this one last week, ended up nailing it down to
this simple example.

Replication steps (mmark 2.0.40, xml2rfc 2.22.0):
$ mmark index.md > index.xml
$ xml2rfc index.xml -o index.html
Error: Unable to parse the XML document: index.xml
 <string>: Line 24: Opening and ending tag mismatch: middle line 17 and
section
 <string>: Line 24: Opening and ending tag mismatch: middle line 17 and
section
 <string>: Line 28: Opening and ending tag mismatch: rfc line 3 and section
 <string>: Line 30: Extra content at the end of the document

index.md:
%%%
title = "Alpha Beta"
abbrev = "AB"
area = "Internet"
workgroup = "Offscale.io"
keyword = ["compilers"]
#date = 2019-12-07T00:00:00Z

[seriesInfo]
name = "RFC"
value = "ABv0.0.1"
status = "informational"

[[author]]
surname="Marks"
fullname="Samuel Marks"
organization = "Sydney Scientific"
  [author.address]
  email = "[email-masked]"
%%%

{mainmatter}

# Overview

#### Underview

## Sideview

{backmatter}

---

From: Julian Reschke <[email-masked]>
Date: Thu, 28 Mar 2019 07:42:54 +0100

On 28.03.2019 07:36, Samuel Marks wrote:
> Was scratching my head on this one last week, ended up nailing it down
> to this simple example.
>
>    email = "[email-masked] <mailto:[email-masked]>"
> %%%
>
> {mainmatter}
>
> # Overview
>
> #### Underview
>
> ## Sideview
>
> {backmatter}

It would be helpful if you attached the generated XML...

Best regards, Julian

---

From: Samuel Marks <[email-masked]>
Date: Thu, 28 Mar 2019 18:10:44 +1100

This could be a bug to report to mmark and not xml2rfc:

<?xml version="1.0" encoding="utf-8"?>
<!-- name="GENERATOR" content="github.com/mmarkdown/mmark Mmark Markdown
Processor - mmark.nl" -->
<rfc version="3" ipr="trust200902" submissionType="IETF" category="info"
xml:lang="en" consensus="true" xmlns:xi="http://www.w3.org/2001/XInclude">

<front>
<title abbrev="AB">Alpha Beta</title><seriesInfo value="ABv0.0.1"
status="informational" name="RFC"></seriesInfo>
<author surname="Marks" fullname="Samuel Marks"><organization>Sydney
Scientific</organization><address><postal><street></street>
</postal><email>[email-masked]</email>
</address></author>
<date/>
<area>Internet</area>
<workgroup>Offscale.io</workgroup>
<keyword>compilers</keyword>

</front>

<middle>

<section anchor="overview"><name>Overview</name>

<section anchor="underview"><name>Underview</name>
</section>
</section>
</section>

<section anchor="sideview"><name>Sideview</name>
</section>
</section>

</middle>

<back>

</back>

</rfc>

---

From: Jim Schaad <[email-masked]>
Date: Thu, 28 Mar 2019 08:22:33 +0100

Yes this is an mmark problem.  You have one extra close section 

From: xml2rfc <[email-masked]> On Behalf Of Samuel Marks
Sent: Thursday, March 28, 2019 8:11 AM
To: Julian Reschke <[email-masked]>
Cc: XML2RFC Interest Group <[email-masked]>
Subject: Re: [xml2rfc] Compilation breaks on: # Foo\n\n ### Bar \n\n

<?xml version="1.0" encoding="utf-8"?>
<!-- name="GENERATOR" content="github.com/mmarkdown/mmark <http://github.com/mmarkdown/mmark>  Mmark Markdown Processor - mmark.nl <http://mmark.nl> " -->
<rfc version="3" ipr="trust200902" submissionType="IETF" category="info" xml:lang="en" consensus="true" xmlns:xi="http://www.w3.org/2001/XInclude">

<front>
<title abbrev="AB">Alpha Beta</title><seriesInfo value="ABv0.0.1" status="informational" name="RFC"></seriesInfo>
<author surname="Marks" fullname="Samuel Marks"><organization>Sydney Scientific</organization><address><postal><street></street>
</postal><email>[email-masked] <mailto:[email-masked]> </email>
</address></author>
<date/>
<area>Internet</area>
<workgroup>Offscale.io</workgroup>
<keyword>compilers</keyword>

</front>

<middle>

</middle>

<back>

</back>

</rfc>

On Thu, Mar 28, 2019 at 5:42 PM Julian Reschke <[email-masked] <mailto:[email-masked]> > wrote:

On 28.03.2019 07:36, Samuel Marks wrote:
>    email = "[email-masked] <mailto:[email-masked]>  <mailto:[email-masked] <mailto:[email-masked]> >"
> %%%
>
> {mainmatter}
>
> # Overview
>
> #### Underview
>
> ## Sideview
>
> {backmatter}

Best regards, Julian

---

From: Miek Gieben <[email-masked]>
Date: Thu, 28 Mar 2019 07:28:49 +0000

Looks easy to fix, can you cut and paste this into an mmark issue at GitHub?

On Thu, 28 Mar 2019, 07:24 Jim Schaad, <[email-masked]> wrote:

> *From:* xml2rfc <[email-masked]> *On Behalf Of *Samuel Marks
> *Sent:* Thursday, March 28, 2019 8:11 AM
> *To:* Julian Reschke <[email-masked]>
> *Cc:* XML2RFC Interest Group <[email-masked]>
> *Subject:* Re: [xml2rfc] Compilation breaks on: # Foo\n\n ### Bar \n\n
>
>
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>