Subject: [xml2rfc] 2.21.1 Version of xml2rfc

From: Acee Lindem <[email-masked]>
Date: Sun, 17 Mar 2019 19:37:07 -0400

I just installed the latest version of xml2rfc using pip and I get this Traceback?

Acee-Lindems-iMac-2:bin acee$ xml2rfc
Traceback (most recent call last):
  File "/usr/local/bin/xml2rfc", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3095, in <module>
    @_call_aside
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3081, in _call_aside
    f(*args, **kwargs)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 660, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 673, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 851, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (six 1.4.1 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('six>=1.9'), set(['html5lib']))

It must be something obvious.

Thanks,
Acee

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 Mar 2019 13:05:25 +0100

Hi Acee,

It looks as if your system version of the Python 'six' library is less
than the required one.  I think I'll have to check if six version 1.4.1
will work in the app, and if so lower the requirement.

Best regards,

	Henrik

On 2019-03-18 00:37, Acee Lindem wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Acee Lindem <[email-masked]>
Date: Tue, 19 Mar 2019 14:00:11 -0400

Hi Hendrik, 

I updated the Xcode on the Mac in question and this did not meet the requirements. Is there an easy way to upgrade without hitting all sorts of other dependency issues?

Thanks,
Acee

> On Mar 18, 2019, at 8:05 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Acee,
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 19 Mar 2019 20:02:55 +0100

Most people who try to run contemporary open source software on Macs use a tool like homebrew to install recent copies of prerequisites like compilers, interpreters, and libraries.

https://brew.sh

As can be seen there, the installation starts out with one copy and paste to a terminal window, which may be a bit scary.  From then on it’s simple commands like “brew install python” and “brew upgrade”.  Because the homebrew system is completely separate from macOS itself, you can’t(*) break the latter.  (Obviously, you *are* installing software, so there are security implications; so far, the experience with homebrew(**) has been good.)

Grüße, Carsten

(*) It’s not fully sandboxed, so you theoretically can.  Experience just says, you don’t.
(**) Over the decades, there has been a succession of tools filling this role: fink, macports, homebrew.  I strongly recommend using the newest, most active one: homebrew.
It’s actually good enough to now have a Linux offshoot and a Windows 10 WSL version.

> On Mar 19, 2019, at 19:00, Acee Lindem <[email-masked]> wrote:
> 
> Hi Hendrik, 
>