Subject: [xml2rfc] https://xml2rfc.ietf.org/public/rfc/bibxml seems to ban certain User Agent strings

From: Julian Reschke <[email-masked]>
Date: Sun, 14 Apr 2019 12:54:58 +0200

Hi there,

<https://xml2rfc.ietf.org> currently redirects to
<https://xml2rfc.tools.ietf.org> for most user agents.

However some receive a 403, which makes things very hard to debug if
this happens.

Example:

 >  curl -s -D- -A Java/1.8.0
https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0952.xml

yields

> HTTP/1.1 403 Forbidden
> Date: Sun, 14 Apr 2019 10:52:45 GMT
> Server: Apache
> Content-Length: 368
> Connection: close
> Content-Type: text/html; charset=iso-8859-1
>
> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> <html><head>
> <title>403 Forbidden</title>
> </head><body>
> <h1>Forbidden</h1>
> <p>You don't have permission to access /public/rfc/bibxml/reference.RFC.0952.xml
> on this server.<br />
> </p>
> <p>Additionally, a 403 Forbidden
> error was encountered while trying to use an ErrorDocument to handle the request.</p>
> </body></html>

while

 > curl -s -D- -A foobar
https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.0952.xml

returns:

> HTTP/1.1 302 Found
> Date: Sun, 14 Apr 2019 10:53:45 GMT
> Server: Apache
> Location: https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.0952.xml
> Content-Length: 255
> Content-Type: text/html; charset=iso-8859-1
>
> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> <html><head>
> <title>302 Found</title>
> </head><body>
> <h1>Found</h1>
> <p>The document has moved <a href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.0952.xml">here</a>.</p>
> </body></html>

Is this intentional?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 22 Apr 2019 07:17:12 +0200

On 14.04.2019 12:54, Julian Reschke wrote:
> ...

FWIW, this was indeed a User Agent ban, which has been removed since.

Best regards, Julian