Subject: [xml2rfc] Change in the results of using the "author" tag

From: Charlie Perkins <[email-masked]>
Date: Sun, 7 Apr 2019 13:24:30 -0700

Hello folks,

My file contains the following source lines of .xml:

>           <author surname="Dorothy Stanley">
>             <organization>"IEEE 802 Wireless"</organization>

The citation has not changed in a good while, but I noticed the 
following change in the output from November to March:

>    [ietf_802-11]
>               "Dorothy Stanley", "IEEE 802.11 multicast capabilities",
>               Nov 2015.

versus

>    [ietf_802-11]
>               "IEEE 802 Wireless", "IEEE 802.11 multicast capabilities",
>               Nov 2015.

I prefer that the bibliographic citation show Dorothy Stanley as author, 
not IEEE 802 Wireless.  Is this still possible?  Or, if not, what is the 
correct way to express the authorship to get the desired result?

Thanks in advance for your consideration of my request.

Regards,
Charlie P.

---

From: Julian Reschke <[email-masked]>
Date: Sun, 7 Apr 2019 23:23:08 +0200

> Thanks in advance for your consideration of my request.

You should be able to get the author name back by specifying surname and
initials attributes.

Best regards, Julian

PS: for the details about what changed, Henrik should know...

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Apr 2019 03:13:03 +0200

Dorothy Stanley would be an unusual surname in the English-speaking world.
So I’m not surprised that the handling of that is weird and even changed between versions.

The logic in the version I’m looking at (cli/xml2rfc/util/name.py, rev 2851 ~ December 2018) is:

The attributes initials and surname are only used if both are set, otherwise fullname is used (with some heuristics for generating abbreviated initials that don’t work, e.g., in Spanish names), and if that doesn’t exist either there is no name (which means that the organization will be used if there is one).

Which seems to be exactly what you are seeing.

The only way to get Dorothy’s name with unabbreviated initials seems to be to make that the org.  But that lack of a feature is kind of OK, because that’s not the way we do this:

RFC 7322, 4.8.6.6.  Referencing Other Standards Development Organizations (SDOs)

Grüße, Carsten

> On Apr 7, 2019, at 22:24, Charlie Perkins <[email-masked]> wrote:
> 
> Hello folks,
> 
> The citation has not changed in a good while, but I noticed the following change in the output from November to March:
> 
>>    [ietf_802-11]
> I prefer that the bibliographic citation show Dorothy Stanley as author, not IEEE 802 Wireless.  Is this still possible?  Or, if not, what is the correct way to express the authorship to get the desired result?
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 8 Apr 2019 13:35:12 +0200

Apart from the points Carsten make, which all seem valid, a brief lookup on
Linked In and a bit of googling has me pretty convinced that a reasonable
author entry would be:

  <author fullname="Dorothy Stanley" initials="D." surname="Stanley">
    <organization>IEEE 802.11 Wireless Local Area Networks</organization>
    <address>
      <email>[email-masked]</email>
    </address>
  </author>

and that constructing an entry with no initials and surname="Dorothy Stanley"
is a red herring ,:-)

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Apr 2019 16:04:39 +0200

> and that constructing an entry with no initials and surname="Dorothy Stanley"

Right, but outside of (e.g. Spanish or Indonesian) names where the heuristics don’t work, why are we even putting the attributes initials/surname in?  If we can rely on the heuristics being present, we shouldn’t have to.

(Right now, kramdown-rfc runs a [probably slightly broken] copy of the heuristics if “ins” [Initials/Surname] are not given.  So XML always sees initials/surname.  I’m mainly asking to find out if I can get rid of that.)

BTW, what is the right way to handle Indonesian (not only used there) single-name names?
(I remember having to duplicate a student’s name into both first and last name fields to get things rolling through the campus management systems…)  Empty initials attribute?   Just giving the fullname does work in XML2RFC, apparently…

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 9 Apr 2019 13:24:46 +0200

Hi Carsten,

On 2019-04-08 16:04, Carsten Bormann wrote:
> Right, but outside of (e.g. Spanish or Indonesian) names where the
> heuristics don’t work, why are we even putting the attributes
> initials/surname in? If we can rely on the heuristics being present,
> we shouldn’t have to.

Agreed.

> (Right now, kramdown-rfc runs a [probably slightly broken] copy of
> the heuristics if “ins” [Initials/Surname] are not given. So XML
> always sees initials/surname. I’m mainly asking to find out if I can
> get rid of that.)

xml2rfc does this, too, and I have no intention or plan to remove that.

> BTW, what is the right way to handle Indonesian (not only used there)
> single-name names? (I remember having to duplicate a student’s name
> into both first and last name fields to get things rolling through
> the campus management systems…) Empty initials attribute? Just giving
> the fullname does work in XML2RFC, apparently…

I think just giving the fullname would be right, yes.

Best regards,

	Henrik

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 9 Apr 2019 09:43:40 -0700

Hello Julian,

I followed your suggestion.  Now it shows that the author is "D. Stanley".

The actual document shows that the author is "Dorothy Stanley".

Regardless of what the IETF says about handling names for RFCs, I think 
that external citations should reflect the authorship as indicated in 
the external publication.

I also tried simply deleting 'initials="D" surname="Stanley"' from the 
citation.  xml2rfc imposes the requirement anyway.

Can we please have it to respect the actual authorship as shown in the 
publications which we cite?

Regards,
Charlie P.

PS. How to I get a URI to be shown in the citation?  One way that does 
not work is to use 
<uri>https://mentor.ieee.org/802.11/dcn/15/11-15-1261-03-0arc-multicast-performance-optimization-features-overview-for-ietf-nov-2015.ppt</uri>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 9 Apr 2019 19:10:37 +0200

> the external publication.

Well, that contradicts the RFC Style Guide.

> publications which we cite?

That's a discussion you need to lead with the RFC Editor, not the tools
implementers.

> <uri>https://mentor.ieee.org/802.11/dcn/15/11-15-1261-03-0arc-multicast-performance-optimization-features-overview-for-ietf-nov-2015.ppt</uri>

<https://greenbytes.de/tech/webdav/rfc7749.html#element.reference.attribute.target>

Best regards, Julian

---

From: Martin J. Dürst <[email-masked]>
Date: Wed, 10 Apr 2019 05:23:19 +0000

> Well, that contradicts the RFC Style Guide.

It not only contradicts the RFC Style Guide, it also contradicts wide 
practice in other publications. Each publication has their own style 
(e.g. initial(s) only or full given names, family names first or given 
names first, capitalization of whole names,...), and typesetting and 
publishing software (e.g. (La)TeX) adjusts the information for each 
publication style.

Regards,   Martin.