Subject: [xml2rfc] hangIndent

From: Randy Bush <[email-masked]>
Date: Tue, 23 Apr 2019 13:00:06 -0700

<?rfc subcompact="yes"?>
    <t>ULP Type:
      <list style="hanging" hangIndent="6">
      <t hangText="0:">BGP</t>
      <?rfc subcompact="no"?></list></t>

produces

   ULP Type:

   0:    BGP

the list element is not indented, spaces are inserted after the hangText

clue bat, please

randy

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Apr 2019 05:46:09 +0200

> the list element is not indented, spaces are inserted after the hangText

Works as designed.

Do you *really* think you need something else?

Best regards, Julian

---

From: Randy Bush <[email-masked]>
Date: Tue, 23 Apr 2019 22:08:46 -0700

> Do you *really* think you need something else?

empty lists indent.  so yes, i kinda want other lists to indent

randy

---

From: Julian Reschke <[email-masked]>
Date: Wed, 24 Apr 2019 09:30:31 +0200

On 24.04.2019 07:08, Randy Bush wrote:
> ...

Well. The purpose of xml2rfc in general is to capture semantics, and to
format that consistently. Not having complete control of the output is
intentional.

My recommendation would be to just live with whatever the formatter
gives you. Does it really matter that much?

Best regards, Julian