Subject: [xml2rfc] url ref confusion

From: Randy Bush <[email-masked]>
Date: Fri, 19 Apr 2019 10:59:23 -0700

https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html#name-how-do-i-reference-a-url
says

    <reference anchor="W3C" target="https://www.w3.org/">
        <front>
            <title>World Wide Web Consortium (W3C)</title>
            <author/>
        </front>
    </reference>

i try

    <reference anchor="Clos" target="https://en.wikipedia.org/wiki/Clos_network/">
      <front>
        <title>Clos Network</title>
	<author/>
        </front>
      </reference>

i get

Error: Unable to validate the XML document: foo.xml
 <string>: Line 1552: Element front content does not follow the DTD, expecting (title , author+ , date , area* , workgroup* , keyword* , abstract? , note*), got (title author)

what am i doing wrongly this time?

randy

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 19 Apr 2019 20:19:03 +0200

Hi Randy,

Huh.  That has the same problem as your <reference>:

> <string>: Line 1552: Element front content does not follow the DTD,
> expecting (title , author+ , date , area* , workgroup* , keyword* ,
> abstract? , note*), got (title author)

... which is that the <date> element is not optional.  If you look at
the error message, it says ... expecting (title , author+ , date , ...;
i.e., with no '*' or '?' after 'date', it cannot be omitted.  If you
add a <date/> you should do better.

Best regards,

	Henrik

---

From: Randy Bush <[email-masked]>
Date: Fri, 19 Apr 2019 11:21:32 -0700

> ... which is that the <date> element is not optional.

doh.  thanks!

randy

---

From: Julian Reschke <[email-masked]>
Date: Fri, 19 Apr 2019 21:58:36 +0200

> add a <date/> you should do better.

....FWIW, it *is* optional in v3.

Best regards, Julian