Subject: Re: [xml2rfc] Can not find a reference xml for an expired draft

From: Harald Alvestrand <[email-masked]>
Date: Fri, 7 Jun 2019 09:13:54 +0200

My guess is that he didn't upload the XML in the first place.

Try emailing Johan.

On 5/30/19 1:52 PM, Davey Song wrote:
> Hi folks,
>
> I'm not sure if it is the best place to ask this question. But it is
> appreciated if you can help.
>  
> The reference xml file line is not available for a expired draft. 
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ihren-dnsext-threshold-validation-01.xml  
>
> The online draft is here
> :https://tools.ietf.org/html/draft-ihren-dnsext-threshold-validation-01
>
> Anything wrong with this draft?
>
> Best regards,
> Davey
>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

-- 
Surveillance is pervasive. Go Dark.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 7 Jun 2019 09:37:06 +0200

Unless you want to specifically reference the version -01, you should be using the “series” URL:

https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.ihren-dnsext-threshold-validation.xml

Now, interestingly, both

https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ihren-dnsext-threshold-validation-00.xml

and

are 404, which sounds like a daemon didn’t do its job properly some time in 2004.

(Compare with, say, 

https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-cbor-cddl-00.xml
To
https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-cbor-cddl-08.xml
As well as
https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.ietf-cbor-cddl.xml

which are the version-specific references as well as the series one.  Note that these all anchor to I-D.ietf-cbor-cddl, so you cannot have multiple version specific references to the same draft or one of these and the series reference in the same document unless you rewrite, e.g., the way kramdown-rfc can do for you.)

> On May 30, 2019, at 13:52, Davey Song <[email-masked]> wrote:
> 
> Hi folks,
> 
> I'm not sure if it is the best place to ask this question. But it is appreciated if you can help.
>  
> The online draft is here :https://tools.ietf.org/html/draft-ihren-dnsext-threshold-validation-01
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 7 Jun 2019 14:50:58 +0200

Hi Davey,

> https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ihren-dnsext-threshold-validation-01.xml

That URL is not the proper one for the reference you want.  It should not
contain the 'draft-' part after '.I-D.'.  The correct URL is:

Regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 7 Jun 2019 15:30:23 +0200

> https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.ihren-dnsext-threshold-validation.xml

That is one correct reference URL, but the previous one also is — as a way to reference a specific version of a draft.  I showed this in the examples in the previous message.  

Not sure that Davey actually wants this and didn’t use the version-specific variant by accident.  But the question remains why the version-specific variants aren’t there for this particular draft.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 7 Jun 2019 16:33:09 +0200

On Jun 7, 2019, at 15:30, Carsten Bormann <[email-masked]> wrote:
> 
> But the question remains why the version-specific variants aren’t there for this particular draft.

Quickly looking at the directory: Of 27455 I-D series I can find, 6071 do not have any version-specific reference files.  Didn’t check for completeness of those which did have at least one (but they sure seem to have gaps).  There seem to be no version-specific reference files without a corresponding series reference file.  Haven’t analyzed further.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 7 Jun 2019 16:56:18 +0200

Hi Carsten,

On 2019-06-07 15:30, Carsten Bormann wrote:
> That is one correct reference URL, but the previous one also is — as
> a way to reference a specific version of a draft.  I showed this in
> the examples in the previous message.

Right. Sorry.

> Not sure that Davey actually wants this and didn’t use the
> version-specific variant by accident.  But the question remains why
> the version-specific variants aren’t there for this particular
> draft.

The sources used by the script that generates the reference .xml files
aren't available, so I can't check this, but one possibility would be
that the datatracker, when generating the 1id-abstracts.txt file at the
time, used Johan's surname with a non-ascii character: Ihrén, and that
botched the creation of the reference file.

Inspection of the bibxml3 directory makes me think there must be a different
cause, though, as I see that for year 2004, there are 1365 reference files
of the generic kind, not using 'draft-' in the name, while I see only 25
version-specific reference files.

	Henrik

---

From: Davey Song <[email-masked]>
Date: Thu, 20 Jun 2019 18:33:31 +0800

Sorry for late reply.

> https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.ihren-dnsext-threshold-validation.xml
Yes It works. Now I can cite that draft in my draft now. Thank you very
much.

Best regards,
Davey