Subject: [xml2rfc] Fwd: Last Call: <draft-ietf-intarea-frag-fragile-12.txt> (IP Fragmentation Considered Fragile) to Best Current Practice

From: Fred Baker <[email-masked]>
Date: Fri, 21 Jun 2019 20:38:48 +0300

I have a question for some wise person regarding XML2RFC. I have attached the current XML and TXT versions of a draft we have in last call right now, and I'm casting round for the correct fix for the second of the nits pointed out in this email. What is the proper way to reference a URL in the context I did in this draft?

I suspect it's in a reference , but it's a structure that I have never quite gotten my head around.

> Begin forwarded message:
> 
> From: "C. M. Heard" <[email-masked]>
> Subject: Re: Last Call: <draft-ietf-intarea-frag-fragile-12.txt> (IP Fragmentation Considered Fragile) to Best Current Practice
> Date: June 21, 2019 at 6:27:20 PM GMT+3
> To: [email-masked]
> Cc: Suresh Krishnan <[email-masked]>, intarea-chairs <[email-masked]>
> Resent-From: <[email-masked]>
> Resent-To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> 
> I've got a couple of nits to bring to the attention of the authors and thee shepherd. Since they are editorial and not substantive I'm sparing the WG and IETF lists.
> 
> 1.) Section 1, Introduction, end of 2nd paragraph (page 3):  the phrase "(e.g. PLPMTU)" (a) has the acronym mis-spelled (should be PLPMTUD) and (b) uses the acronym before it is first expended (in Section 2.3). There are lots of ways to fix this; an easy one is to delete the parenthetical phrase.
> 
> 2.) Section 4.6, Security Vulnerabilities, 2nd bullet (page 11): it took me some poking around to figure out that I was supposed to splice the two URLS together to get https://web.archive.org/web/20110723091910/http://www.digital.net/~gandalf/Rose_Frag_Attack_Explained.htm <https://web.archive.org/web/20110723091910/http://www.digital.net/~gandalf/Rose_Frag_Attack_Explained.htm>. I'm aware that the problem of rendering the long URL is due to the line length limit of RFCs, but is there maybe a way to get the underlying hyperlink to come out right in the html version of the published RFC, as is done with the references?
> 
> Sorry for not catching these things earlier during the WG process.
> 
> Mike Heard

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Julian Reschke <[email-masked]>
Date: Fri, 21 Jun 2019 19:51:13 +0200

On 21.06.2019 19:38, Fred Baker wrote:
> I have a question for some wise person regarding XML2RFC. I have
> attached the current XML and TXT versions of a draft we have in last
> call right now, and I'm casting round for the correct fix for the second
> of the nits pointed out in this email. What is the proper way to
> reference a URL in the context I did in this draft?
>
> ...
>> 2.) Section 4.6, Security Vulnerabilities, 2nd bullet (page 11): it
>> took me some poking around to figure out that I was supposed to splice
>> the two URLS together to get
>> https://web.archive.org/web/20110723091910/http://www.digital.net/~gandalf/Rose_Frag_Attack_Explained.htm.
>> I'm aware that the problem of rendering the long URL is due to the
>> line length limit of RFCs, but is there maybe a way to get the
>> underlying hyperlink to come out right in the html version of the
>> published RFC, as is done with the references?
>>
> ...

There is no published proper HTML. What tools.ietf.org has is the text
version, converted to HTML with heuristics that transforms certain parts
of the text into HTML links. So if a long URI is broken across lines in
the text, it's unlikely to be treated "correctly" by that transformation.

The published ID currently says:

    o  Resource exhaustion attacks (such as the Rose Attack,
       https://web.archive.org/web/20110723091910/
       http://www.digital.net/~gandalf/Rose_Frag_Attack_Explained.htm)

I'd recommend to use the following XML:

> <eref target="https://web.archive.org/web/20110723091910/http://www.digital.net/~gandalf/Rose_Frag_Attack_Explained.htm>https://web.archive.org/web/20110723091910/http://www.digital.net/~gandalf/Rose_Frag_Attack_Explained.htm</eref>

If there *was* a published proper HTML version (once the transition to
xml2rfc v3 has happened), this should work.

Best regards, Julian

---

From: Fred Baker <[email-masked]>
Date: Fri, 21 Jun 2019 20:52:21 +0300

Thanks much.

> On Jun 21, 2019, at 8:51 PM, Julian Reschke <[email-masked]> wrote:
>