Subject: [xml2rfc] new <u> element help

From: Tom Pusateri <[email-masked]>
Date: Mon, 5 Aug 2019 14:42:26 -0400

I tried to convert to the new <u> format (which isn’t defined in the xml2rfc v2 vocabulary) and I get this error for the following input:

TTL<u format="{char}">≥</u>0<vspace />

xml2rfc draft-ietf-dnssd-push.xml -o draft-ietf-dnssd-push.txt --text
Parsing file draft-ietf-dnssd-push.xml
Error: Expected <unicode> expansion parts to include at least "num", but found format="{char}"
Error: Expected <unicode> expansion parts to include at least "num", but found format="{char}"
Created file draft-ietf-dnssd-push.txt

This seems like it would be valid in:

https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-09#appendix-A.1

So I’m not sure how I’m supposed to just get the GREATER-THAN OR EQUAL without quotes and without the number notation.

Thanks,
Tom

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 5 Aug 2019 22:30:37 +0200

Hi Tom,

Short answer:  This requires math support, and is not covered by the
functionality provided by the <u> element, as the intention of that
element is to _always_ provide a rendering-agnostic codepoint value
in order to make the use of non-ASCII codepoints in protocol
specifications explicit, independent of the rendering format.

Math support has been discussed; I think it's a good idea, and I have
a proposal, but it's not currently part of any specification.

The best way, currently, to achieve what you want in a v3 XML source,
is to present the full equation as <artwork> or <sourcecode>.

One more point inline:

> https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-09#appendix-A.1

Yes, that should point out that 'num' always is required with <u>.  I'll
add that.  It's mentioned for the simplified format (in A.1.1) but should
also be mentioned in A.1.2.

Regards,

	Henrik

> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 21 Aug 2019 19:06:06 +0200

On 05.08.2019 22:30, Henrik Levkowetz wrote:
> ...

Which reminds me that the current definition of <u> is not in sync with
RFC 7997; see
<https://trac.tools.ietf.org/tools/xml2rfc/trac/attachment/ticket/416/>.

Best regards, Julian