Subject: [xml2rfc] Scaling of SVG artwork

From: Anders Rundgren <[email-masked]>
Date: Sat, 5 Oct 2019 07:31:55 +0200

Scaling images has always been a problem in HTML.
In RFC XML V3 using SVG it gets worse since there is no way to control scaling.
"ascii-art" does not have the same problem since it comes with a scrollbar if it doesn't fit horizontally and the elements are size-wise aligned with the rest of the document.

Anders

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 5 Oct 2019 07:43:21 +0200

THere is not enough data here to let me debug anything.

	Henrik

On 2019-10-05 07:31, Anders Rundgren wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 9 Oct 2019 13:24:48 +1300

I see that RFC7996 allows viewbox, and according to this rather comprehensive post:
https://css-tricks.com/scale-svg/
viewbox is your friend. Whether your preferred SVG drawing tool supports viewbox is a separate question. Whether the relevant CSS and your preferred HTML viewer interpret viewbox correctly is also a separate question.

Henrik, would you like a test file that produces some unwelcome scaling behaviour? I can send it off list. Overall, I'm afraid we are not yet ready for prime time in the SVG department.

Regards
   Brian Carpenter

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 9 Oct 2019 06:44:53 +0200

On 2019-10-09 02:24, Brian E Carpenter wrote:
> Henrik, would you like a test file that produces some unwelcome scaling behaviour? I can send it off list.

I could create a couple of dummy I-Ds and publish them on my github for anybody to test.

> Overall, I'm afraid we are not yet ready for prime time in the SVG department.

+1

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 9 Oct 2019 08:00:56 +0200

Hi Brian,

On 2019-10-09 02:24, Brian E Carpenter wrote:
> I see that RFC7996 allows viewbox, and according to this rather
> comprehensive post: https://css-tricks.com/scale-svg/ viewbox is your
> friend. Whether your preferred SVG drawing tool supports viewbox is a
> separate question. Whether the relevant CSS and your preferred HTML
> viewer interpret viewbox correctly is also a separate question.
> 
> Henrik, would you like a test file that produces some unwelcome
> scaling behaviour?

Yes, certainly.  I've had only a limited selection of 'real life' SVG files
to test with so far.

> I can send it off list. Overall, I'm afraid we are
> not yet ready for prime time in the SVG department.

Then I'll work to fix things.

Best regards,

	Henrik

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 9 Oct 2019 23:17:43 -0400

> On Oct 9, 2019, at 2:00 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Brian,
> 

There’s an SVG creator called Boxy SVG (https://boxy-svg.com <https://boxy-svg.com/>) that is an Electron app and runs on MacOS, Linux, & WIndows. I use this for my drawings because github will incorporate SVG in Markdown files so you can have a drawing in the README.md.

You can create all kinds of examples pretty easily with it.

Tom

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Oct 2019 16:47:39 +1300

On 10-Oct-19 16:17, Tom Pusateri wrote:
... 
> There’s an SVG creator called Boxy SVG (https://boxy-svg.com) that is an Electron app and runs on MacOS, Linux, & WIndows. I use this for my drawings because github will incorporate SVG in Markdown files so you can have a drawing in the README.md.
> 

There are many tools that generate SVG; the question is whether they can readily
generate SVG that matches RFC7996, gets through the xml2rfcv3 tool chain, and
gives you what you want in the final html (or pdf).

    Brian