Subject: Re: [xml2rfc] xml2rfc.tools.ietf.org::xml2rfc.bibxml/bibxml3

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 7 Nov 2019 03:56:43 +0000

On 10/28/19, 10:00 AM, "xml2rfc on behalf of Henrik Levkowetz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Carsten,
    
    On 2019-10-27 20:16, Carsten Bormann wrote:
    > On Oct 27, 2019, at 19:35, Henrik Levkowetz <[email-masked]> wrote:
    >> 
    >> Cronjobs to generate new I-D reference entries are started every 30
    >> minutes, at 15 and 45 minutes past the hour.
    > 
    > (Ceterum censeo: this is not often enough when one is juggling webs of interdependent drafts.
    > I hope these are generated with a Makefile-like logic; this should be possible every minute or so.)
    
    No.  These are old TCL scripts inherited from Marshall Rose.  I'm very
    eager to scrap them and instead generate reference.*.xml entries on the
    fly in the datatracker.  It's very overdue.  I actually started work on
    that around 2018-04-16, but what with the regular v3 xml2rfc work I've
    never found time and quiet to go back and complete it :-(

Yeah, I started writing a replacements a few times too. I think the proper mechanism is through a Django template.

	Tony

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 7 Nov 2019 06:53:35 +0100

> Yeah, I started writing a replacements a few times too. I think the proper mechanism is through a Django template.

Probably, as long as you prepend a cache.
The last thing we need is longer access times for the bibxml fetches…

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 9 Nov 2019 16:40:50 +0100

Hi,

> The last thing we need is longer access times for the bibxml fetches…

My trial implementation of bibxml3 entries generated on-the-fly from the
datatracker database is now deployed.

I'd appreciate people trying it out.

The URLs are of the form

  https://datatracker.ietf.org/doc/bibxml3/<DRAFTNAME>.xml
and
  https://datatracker.ietf.org/doc/bibxml3/<DRAFTNAME>-<REV>.xml

Best regards,

	Henrik

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 26 Nov 2019 12:07:16 -0800

Hi Henrik

Thanks for your quick work on this.  

Just fyi that I tested this — the reference entry matches output from entries pointing to https://xml2rfc.ietf.org/public/rfc/bibxml3/, but I don’t think it’s solved the issue regarding having references for the most recent versions of the I-Ds.  For example, when I use the following: 

<xi:include href="https://datatracker.ietf.org/doc/bibxml3/reference.I-D.palet-v6ops-464xlat-opt-cdn-caches.xml"/>

I get a ref for -03, even though the datatracker shows draft-palet-v6ops-464xlat-opt-cdn-caches-04. 

I also tried using the version number
<xi:include href="https://datatracker.ietf.org/doc/bibxml3/reference.I-D.palet-v6ops-464xlat-opt-cdn-caches-04.xml"/>

but I got the following error:
Error: Unable to resolve external request: "https://datatracker.ietf.org/doc/bibxml3/reference.I-D.palet-v6ops-464xlat-opt-cdn-caches-04.xml"
Error: XInclude processing failed: could not load https://datatracker.ietf.org/doc/bibxml3/reference.I-D.palet-v6ops-464xlat-opt-cdn-caches-04.xml, and no fallback was found, line 1597
Unable to complete processing rfc8683.xml

Thanks,
Sandy 

> On Nov 9, 2019, at 7:40 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 26 Nov 2019 21:31:01 +0100

Hi Sandy,

On 2019-11-26 21:07, Sandy Ginoza wrote:
> Just fyi that I tested this — the reference entry matches output from
> entries pointing to https://xml2rfc.ietf.org/public/rfc/bibxml3/, but
> I don’t think it’s solved the issue regarding having references for
> the most recent versions of the I-Ds. For example, when I use the
> following:
> 

Umm.  Yes, that's not the right form.  You're probably getting an old copy
from cache.  The form available currently (I'm changing that to accept the
form you used for the next release, based in part on your experience) is
this:

<xi:include href="https://datatracker.ietf.org/doc/bibxml3/draft-palet-v6ops-464xlat-opt-cdn-caches.xml"/>

> I get a ref for -03, even though the datatracker shows draft-palet-v6ops-464xlat-opt-cdn-caches-04.

... which (the correct form above) has -04 content.

> Unable to complete processing rfc8683.xml

Yes, same problem -- you're using
'reference.I-D.palet-v6ops-464xlat-opt-cdn-caches-04.xml' as part of the
URL, instead of 'draft-palet-v6ops-464xlat-opt-cdn-caches-04.xml'.

Best regards,

	Henrik

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 26 Nov 2019 12:50:42 -0800

Hi Henrik,

Ahh, thanks!  Apologies for assuming the string would still start with "reference.I-D”.  I’m happy to be rid of that construction, but it seems like a good idea to continue to accept "reference.I-D” since that is what appears in the already published v3 RFCs.

I retested — the only unexpected difference is the appearance of Jordi’s name in the references.  See 

https://www.rfc-editor.org/v3test/rfc8683.xml 
https://www.rfc-editor.org/v3test/rfc8683-rfcdiff.html

Looking at this now, I question whether showing J. Palet is correct, but that is how his name has appeared in the references in the past. 

Thanks,
Sandy 

> On Nov 26, 2019, at 12:31 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Sandy,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 26 Nov 2019 22:11:59 +0100

Hi Sandy,

On 2019-11-26 21:50, Sandy Ginoza wrote:
> Hi Henrik,
> 
> Ahh, thanks!  Apologies for assuming the string would still start
> with "reference.I-D”.  I’m happy to be rid of that construction, but
> it seems like a good idea to continue to accept "reference.I-D” since
> that is what appears in the already published v3 RFCs.

Indeed.

> Looking at this now, I question whether showing J. Palet is correct,
> but that is how his name has appeared in the references in the past.

I believe the correct surname for Jordi is 'Palet Martinez'.  If one is
to omit one, omitting the maternal surname ('Martinez') is in my 
understanding (usually) the correct thing to do for Spanish surnames, so
past usage seems acceptable.

I think we need to refine the name handling in the datatracker even more
to deal correctly with author names.  With input in the form of xml
submissions, we will have better incoming data than before.

Best regards,

	Henrik

---

From: Julian Reschke <[email-masked]>
Date: Wed, 27 Nov 2019 06:31:04 +0100

On 26.11.2019 21:50, Sandy Ginoza wrote:
> ...

The published RFCs are expected to have the references inlined, no?

Best regards, Julian

---

From: Sandy Ginoza <[email-masked]>
Date: Wed, 27 Nov 2019 09:10:37 -0800

> On Nov 26, 2019, at 9:31 PM, Julian Reschke <[email-masked]> wrote:
> 

Good point! 

I imagine it would still be good to continue to accept "reference.I-D” because that is what most authors use in their I-Ds.  

Henrik, I haven’t tested this much, so we’ll continue to do that and let you know if we come across any issues.  

Thanks,
Sandy