Subject: [xml2rfc] forcing new line in Hanging lists for definitions

From: Robert Moskowitz <[email-masked]>
Date: Wed, 11 Dec 2019 16:32:19 -0500

I don't like the way Hanging lists work when you have long names you are 
defining.  I would like the definition to start on a new line below the 
term.

Look at the following:

     <section title="Definitions">
     <t>
         <list style="hanging">
         <t hangText="Keccak (KECCAK Message Authentication Code):">
             The family of all sponge functions with a KECCAK-f
             permutation as the underlying function and multi-rate
             padding as the padding rule.
         </t>
         <t hangText="cSHAKE (The customizable SHAKE function):">
             Extends the SHAKE scheme to allow users to customize their
             use of the function.
         </t>
         <t hangText="SHAKE (Secure Hash Algorithm KECCAK):">
             A secure hash that allows for an arbitrary output length.
         </t>
         <t hangText="XOF (eXtendable-Output Function):">
             A function on bit strings (also called messages) in which
             the output can be extended to any desired length.
         </t>
         </list>
     </t>
     </section>

which produces:

2.3.  Definitions

    Keccak (KECCAK Message Authentication Code):  The family of all
       sponge functions with a KECCAK-f permutation as the underlying
       function and multi-rate padding as the padding rule.

    cSHAKE (The customizable SHAKE function):  Extends the SHAKE scheme
       to allow users to customize their use of the function.

    SHAKE (Secure Hash Algorithm KECCAK):  A secure hash that allows for
       an arbitrary output length.

    XOF (eXtendable-Output Function):  A function on bit strings (also
       called messages) in which the output can be extended to any
       desired length.

I would like to get the content after those : to start on a new line for 
better readability (at least in my opinion).

thanks

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 11 Dec 2019 22:45:25 +0100

Kramdown-rfc (http://rfc.space):

> (1.0.2:) An IAL attribute "vspace" can be added to a definition list to break after the definition term:
> 
> {: vspace="0"}
> word:
> : definition
> 
> anotherword:
> : another definition

Translate that to XML to remind me how to do this in RFCXMLv2:

$ kramdown-rfc2629
{: vspace="0"}
word:
: definition

anotherword:
: another definition
➔
<t><list style="hanging">
  <t hangText='word:'><vspace blankLines='0'/>
  definition</t>
  <t hangText='anotherword:'><vspace blankLines='0'/>
  another definition</t>
</list></t>
$

ISTR this was fixed in v3 by introducing proper definition lists with an attribute to request the usual formatting (<dl hanging=“false”>, but I think this is unstable: https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/38).

Grüße, Carsten

> On Dec 11, 2019, at 22:32, Robert Moskowitz <[email-masked]> wrote:
> 
> I don't like the way Hanging lists work when you have long names you are defining.  I would like the definition to start on a new line below the term.
> 
> Look at the following:
> 
> I would like to get the content after those : to start on a new line for better readability (at least in my opinion).
> 
> thanks
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 12 Dec 2019 00:01:22 +0100

The attribute in v3 is is newline="true" (default: "false").  In v2 you
need to use <vspace/>.

	Henrik

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 11 Dec 2019 19:35:14 -0500

> The attribute in v3 is is newline="true" (default: "false").  In v2 you

Where/how is newline= used?  I tried a couple things, but the parser did 
not like my attempts.

thanks

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 12 Dec 2019 07:04:36 +0100

Hi Bob,

> Where/how is newline= used?  I tried a couple things, but the parser did 

This should do the trick, using v3 elements:

 <dl newline="true">
    <dt>word:</dt>
    <dd>definition</dd>
    <dt>anotherword:</dt>
    <dd>another definition</dd>
 </dl>

Regards,

	Henrik

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 12 Dec 2019 06:06:11 -0500

>      <dd>another definition</dd>

The <dl> tag is new to me.  Shows how much of this stuff I do.  I will 
read up on it and give it a try instead of my old standby <list>...

thanks