Subject: [xml2rfc] NIT: double spacing after e.g.

From: Robert Moskowitz <[email-masked]>
Date: Thu, 12 Mar 2020 09:58:46 -0400

I have the following in a draft:

, e.g. <xref target="CS-RID_Reg" format="default"/>,

Where CS-RID_Reg is a section anchor.

I am getting a double space after e.g. as if it is the end of a sentence.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 12 Mar 2020 15:44:49 +0100

Hi Bob,

> On 2020-03-12, at 14:58, Robert Moskowitz <[email-masked]> wrote:
> 

That may be a bug, but it is never triggered.
Any correct usage of “e.g.” is followed by a comma, as in

> , e.g., <xref target="CS-RID_Reg" format="default"/>,

> I am getting a double space after e.g. as if it is the end of a sentence.

Which you don’t get after the comma.

(Insert the usual squabble about whether the double space is the right thing to do.
Unfortunately, the current fashion of not doing them is defined by typographers who apparently never have to consume large gobs of text.  Enough said.)

Grüße, Carsten