Subject: [xml2rfc] Indenting a sublist

From: Robert Moskowitz <[email-masked]>
Date: Fri, 20 Mar 2020 13:59:30 -0400

In v3,

Inside a <ul>, how do I get <li> to indent under the previous <li>

I am just missing this.  I tried <li indent="6"> and that obviously is 
not it...

Thanks

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Mar 2020 19:01:44 +0100

> Inside a <ul>, how do I get <li> to indent under the previous <li>

You need to express the sublist:

<ul>
  <li>
    <ul>
     <li>

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 20 Mar 2020 14:06:41 -0400

> You need to express the sublist:

     <ul>
         <li>
             B-RID can more readily be implemented directly in the UA.
             N-RID will more frequently be provided by the GCS or a
             pilot's Internet connected device.
         </li>
             <ul>
                 <li>
                     If Command and Control (C2) is bi-directional over
                     a direct radio connection, B-RID could be a
                     straight-forward addition.
                 </li>
                 <li>
                     Small IoT devices can be mounted on UA to provide 
B-RID.
                 </li>
             </ul>
         <li>
             B-RID can also be used by the UA to assist in Detect and
             Avoid (DAA).
         </li>
         <li>
             B-RID is available to observers even in situations with no
             Internet like natural disaster situations.
         </li>
     </ul>

Error: Did not expect element ul there, at 
/rfc/middle/section[3]/section[2]/ul/ul

Same error if I move the inner <ul> into the above <li></li>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Mar 2020 19:08:13 +0100

The ul is in an li

> On 2020-03-20, at 19:06, Robert Moskowitz <[email-masked]> wrote:
> 
> Error: Did not expect element ul there, at /rfc/middle/section[3]/section[2]/ul/ul

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 20 Mar 2020 14:12:43 -0400

<ul>
         <li>

  Error: Element li has extra content: ul, at 
/rfc/middle/section[3]/section[2]/ul/li[1]/ul

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 20 Mar 2020 19:35:21 +0100

Hi Bob,

>>> Error: Did not expect element ul there, at /rfc/middle/section[3]/section[2]/ul/ul
		
If you want a sequence of text followed by <ul> here, you need to
place the text in <t>:

               <t>
>              pilot's Internet connected device.
               </t>

> /rfc/middle/section[3]/section[2]/ul/li[1]/ul

I think it is confusing that the new v3 grammar permits _either_ plain
text, _or_ a sequence of <t>/<ul>/<ol> etc. elements, because it leads
to this kind of failure when adding pieces iteratively.

Always requiring the <t> would make the grammar easier to understand.

I proposed that here:

https://tools.ietf.org/html/draft-levkowetz-xml2rfc-v3-implementation-notes-10#section-3.1.10.2

but the change was rejected.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Mar 2020 19:37:13 +0100

Oh.  RFC 7991 seems to avoid mixed content; I had suppressed that in my recollection.
So, for this specific case, you have to wrap text in t.
I’m already looking forward to programming this :-)

Grüße, Carsten

> On 2020-03-20, at 19:12, Robert Moskowitz <[email-masked]> wrote:
> 
> 
> 
<t>
</t>
>                     Small IoT devices can be mounted on UA to provide B-RID.
>                 </li>
>             </ul>
>         </li>
>         <li>

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 20 Mar 2020 14:48:25 -0400

Thanks Henrik,

That worked and is totally non-obvious.