Subject: [xml2rfc] requests for https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5652.xml timing out

From: Julian Reschke <[email-masked]>
Date: Thu, 5 Mar 2020 12:55:39 +0100

Is it just me?

> > nslookup xml2rfc.ietf.org
> ... > Name:    ietf.org
> Addresses:  2001:1900:3001:11::2c
>           4.31.198.44
> Aliases:  xml2rfc.ietf.org

HTTP:

> > curl http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5652.xml
>   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
>                                  Dload  Upload   Total   Spent    Left  Speed
> 100   255  100   255    0     0    255      0  0:00:01 --:--:--  0:00:01   710
> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> <html><head>
> <title>302 Found</title>
> </head><body>
> <h1>Found</h1>
> <p>The document has moved <a href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.5652.xml">here</a>.</p>
> </body></html>

But with HTTPS:

> > curl https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5652.xml
>   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
>                                  Dload  Upload   Total   Spent    Left  Speed
>   0     0    0     0    0     0      0      0 --:--:--  0:00:20 --:--:--     0curl: (7) Failed to connect to xml2rfc.ietf.org port 443: Timed out

Best regards, Julian

PS: AFAIR, the same happened yesterday at some point of time.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Mar 2020 13:01:03 +0100

> Is it just me?

WFM

Grüße, Carsten

$ curl -LI http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5652.xml
HTTP/1.1 302 Found
Date: Thu, 05 Mar 2020 12:00:20 GMT
Server: Apache
Location: https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.5652.xml
Content-Type: text/html; charset=iso-8859-1

HTTP/1.1 200 OK
Date: Thu, 05 Mar 2020 12:00:21 GMT
Server: Apache/2.2.22 (Debian)
Last-Modified: Sat, 29 Feb 2020 22:08:45 GMT
ETag: "39c146a-295-59fbe32985540"
Accept-Ranges: bytes
Content-Length: 661
Content-Type: application/xml

---

From: Julian Reschke <[email-masked]>
Date: Thu, 5 Mar 2020 14:02:28 +0100

> Content-Type: application/xml

Hm.

4.31.198.44 fails for me (that's what DNS gives me). 4.31.198.61 works
(that's that Firefox sees for some reason).

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Mar 2020 14:11:38 +0100

> (that's that Firefox sees for some reason).

Does anyone know of a curl/wget-like tool that actually tries all the DNS results for a URI?
Like happy eyeballs, but for all addresses.

Grüße, Carsten