Subject: [xml2rfc] Style Format in <ol>

From: Robert Moskowitz <[email-masked]>
Date: Fri, 17 Apr 2020 15:07:01 -0400

The FAQ

https://xml2rfc.tools.ietf.org/xml2rfcFAQ.html#anchor20

shows:

REQ1:
REQ2:  is   <list style="format REQ%d:">
REQ3:

How do I specify this  with in the new <ol> method?

thanks

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Apr 2020 21:20:49 +0200

Hi Bob,

> How do I specify this  with in the new <ol> method?

Use the 'type' attribute, https://tools.ietf.org/html/rfc7991#section-2.34.5:

  <ol type="REQ%d:">
    <li>....</li>
    <li>....</li>
  </ol>

Best regards,

	Henrik

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 17 Apr 2020 12:22:32 -0700

Hi Robert,

> On Apr 17, 2020, at 12:07 PM, Robert Moskowitz <[email-masked]> wrote:
> 
> The FAQ
> 

I believe this should work:
<ol type="REQ%d:">

See <https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html#name-using-lists>.

Thanks,
Sandy 

> 
> thanks
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Robert Moskowitz <[email-masked]>
Date: Sat, 18 Apr 2020 22:30:57 -0400

> See <https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html#name-using-lists>.

I missed this newer FAQ, thanks for that pointer.

Now how do I get the list indented a bit.  In my case, where I really 
would like the list in a tab:

     <ol type="Type %d:">
         <li>
             a static, manufacturer assigned, hardware serial number per
             ANSI/CTA-2063-A "Small Unmanned Aerial System Serial
             Numbers" <xref target="CTA2063A" format="default"/>.
         </li>
         <li>
             a CAA assigned (presumably static) ID.
         </li>
         <li>
             a UAS Traffic Management (UTM) system assigned UUID <xref
             target="RFC4122" format="default"/>, which can but need not
             be dynamic.
         </li>
     </ol>

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 20 Apr 2020 17:49:14 -0700

Hi Robert, 

> On Apr 18, 2020, at 7:30 PM, Robert Moskowitz <[email-masked]> wrote:
> 
> 
> 
> Now how do I get the list indented a bit.  In my case, where I really would like the list in a tab:

Wrapping the <ol> within <ul empty=“true”> may achieve the indentation you desire.  It’s not clear whether this is considered good practice, but that is the only way we are aware of to get added indentation.  

Thanks,
Sandy

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 20 Apr 2020 21:46:26 -0400

Doesn't work...

> Wrapping the <ol> within <ul empty=“true”> may achieve the indentation you desire.  It’s not clear whether this is considered good practice, but that is the only way we are aware of to get added in…

<ul empty="true">
     <ol type="Type %d:">
         <li>
</ul>

results in:

xml2rfc --v3 draft-card-drip-arch-02.xml
draft-card-drip-arch-02.xml(144): Error: Did not expect element ol 
there, at /rfc/middle/section[1]/ul[2]/ol
draft-card-drip-arch-02.xml(144): Error: Element ul has extra content: 
ol, at /rfc/middle/section[1]/ul[2]/ol
draft-card-drip-arch-02.xml(15): Error: Invalid document before running 
preptool.
Unable to complete processing draft-card-drip-arch-02.xml

Oh well.  Indenting, IMHO would be nice.  Here is what I am getting 
without the extra indent:

    [F3411-19] specifies 3 UAS ID types.

    Type 1:  a static, manufacturer assigned, hardware serial number per
             ANSI/CTA-2063-A "Small Unmanned Aerial System Serial
             Numbers" [CTA2063A].

    Type 2:  a CAA assigned (presumably static) ID.

    Type 3:  a UAS Traffic Management (UTM) system assigned UUID
             [RFC4122], which can but need not be dynamic.

    The EU allows only Type 1; the US allows Types 1 and 3, but requires

It would read better if the Type... list were indented.

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 20 Apr 2020 19:32:17 -0700

> On Apr 20, 2020, at 6:46 PM, Robert Moskowitz <[email-masked]> wrote:
> 
> Doesn't work…

See below.

> draft-card-drip-arch-02.xml(144): Error: Did not expect element ol there, at /rfc/middle/section[1]/ul[2]/ol
> draft-card-drip-arch-02.xml(144): Error: Element ul has extra content: ol, at /rfc/middle/section[1]/ul[2]/ol
> draft-card-drip-arch-02.xml(15): Error: Invalid document before running preptool.

You can try adding <li>; I tested this and believe it works:

<ul empty="true"><li>
    <ol type="Type %d:">
        <li>                                                                                                   
            Numbers".                                                                                          

    </ol></li>
</ul>

> Oh well.  Indenting, IMHO would be nice.  Here is what I am getting without the extra indent:

Imho, the list below is clear; no indentation needed.