Subject: [xml2rfc] Word enforcing 1 space between sentences

From: Robert Moskowitz <[email-masked]>
Date: Tue, 28 Apr 2020 15:12:10 -0400

I recently saw a fluff piece about MS Word now enforcing 1 space between 
sentences.  If you put in 2 you get the terrible squiggly line (which 
you can always turn off with a right-click, ignore all).

The argument for single space is the font handles inter-sentence spacing 
just fine as mono-spacing went out with the typewriter....

I wonder what it does if your font IS mono-space?

Like our style guide....

Enjoy!

---

From: William Atwood <[email-masked]>
Date: Tue, 28 Apr 2020 15:16:28 -0400

LaTeX (my favorite text processor) _uses_ the double-space after a
period to _detect_ the end of a sentence.

Down with WORD!!

  jwa

On 2020-04-28 3:12 p.m., Robert Moskowitz wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

-- 
Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: Bret Jordan <[email-masked]>
Date: Thu, 30 Apr 2020 13:41:12 -0600

It is important to note that you can change this behavior in settings. I use a double space out of muscle memory. I learned to type in type class because my parents knew that one day people would have their own computers and I would need to know how to type. 

Like all things like this, this style guides will come and go and change with the whims of who ever is in the position of power of the day. All organizations are often highly influenced by a small number of very vocal individuals that try to force their view of the world on others.

Bret

> On Apr 28, 2020, at 1:12 PM, Robert Moskowitz <[email-masked]> wrote:
> 
> I recently saw a fluff piece about MS Word now enforcing 1 space between sentences.  If you put in 2 you get the terrible squiggly line (which you can always turn off with a right-click, ignore all).
> 
> The argument for single space is the font handles inter-sentence spacing just fine as mono-spacing went out with the typewriter....
>

---

From: Nico Williams <[email-masked]>
Date: Thu, 30 Apr 2020 14:56:56 -0500

On Tue, Apr 28, 2020 at 03:12:10PM -0400, Robert Moskowitz wrote:
> sentences.  If you put in 2 you get the terrible squiggly line (which you
> can always turn off with a right-click, ignore all).
> 

This debate is a recurring one.  Opinions vary.

IMO:

 - Two spaces after sentence-ending periods function as markup that
   distinguishes from non-sentence-ending periods and avoids the need
   for either explicit markup or sentence-ending heuristics.

   Editors should let me type two spaces to end sentences because that's
   a damned common thing to do.  They can turn it into something else, I
   don't care, as long as the intended purpose is served.

 - Rendering such '.  ' as . and a wider space is perfectly fine and
   desirable.

> I wonder what it does if your font IS mono-space?

I hope you get two spaces after the sentence-ending period.  Anything
else would be a bug.

Anyways, prepare for this to turn into a bit of a flame war, or for it
to end with a reference to past ones.

Nico
--

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 30 Apr 2020 21:58:14 +0200

Hi Bob,

> On 2020-04-28, at 21:12, Robert Moskowitz <[email-masked]> wrote:
> 

As Bret said, this probably can be configured.

> The argument for single space is the font handles inter-sentence spacing just fine as mono-spacing went out with the typewriter....

Well, this is a long story I don't want to re-tell here.
Let's just say that there are some typographic fashions that don't respect the prime directive: Legibility.
I tend to ignore those.

But as Bill notes, the question of typographic presentation is somewhat distinct from the keyboarding convention.
People who expertly keyboard manuscripts for usage by document processing systems always try to indicate where sentence ends are and where they aren't.  
The document processing system can then decide on the presentation style of the day.

A double space is a conventional signal for keyboarding a sentence end; it has been for half a century now.
As is a newline.

I am (and I'd want to believe most people who have been using document processing systems since the 1970s are) used to the latter: end each sentence with a newline.
Look, ma, no double spaces in the manuscript, and still clearly indicated sentence ends!
(And look how much more readable the message becomes that way.
And, you'll notice, your git diffs do, too!)

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 30 Apr 2020 16:07:08 -0400

> to end with a reference to past ones.

I had my typing class in '64 (9th grade US) on a Royal manual 
typewriter.  You had to type at 40WPM after corrections to pass.  I 
still have my typing style guide with lots of things not done today.  2 
spaces after a sentence is a small one!  My  wife and I occasionally 
argue (she came through the program 4 years later and they had already 
changed business letter layouts).

I use to write for Network Computing Magazine (back in the mid-90s).  My 
editor and I reached an agreement that I typed as I learned and she 
changed it to the Mag's style guide.  Made for a much better 
interaction.  Of course I was the acronym king of the writers and she 
had a struggle figuring out which to expand and which to leave to the 
readers as I had a 500w budget and typically hit it on the head.

So in large measure I care little what they are teaching today and what 
styles are being enforced.  I will write as I do and if some editor 
enforces a style guide, have at it.

Have a good day!

---

From: Jay Daley <[email-masked]>
Date: Fri, 1 May 2020 08:12:31 +1200

Science is on the side of us over-40s:

https://www.independent.co.uk/life-style/gadgets-and-tech/news/one-space-or-two-spaces-after-a-full-stop-scientists-have-finally-found-the-answer-a8337646.html

Jay (whose mother is a typesetter and knows more about this than anyone else I’ve met)

> On 1/05/2020, at 7:58 AM, Carsten Bormann <[email-masked]> wrote:
> 
> Hi Bob,
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 30 Apr 2020 16:14:11 -0400

> I am (and I'd want to believe most people who have been using document processing systems since the 1970s are) used to the latter: end each sentence with a newline.

Hemingway would have had a tough time with this.  Not Faulkner or Conrad 
(in "the Niger of the Narcissus" there is a sentence a page long and it 
reads beautifully, but it can take a few readings to get all the imagery 
from it).

I will still pull my copy of "Typhoon" from the shelf and reread it.  I 
never did like "Lord Jim", his earlier works IMHO were much better.  Ah, 
the age of sail just at its end.

Put those in your document processing systems.