Subject: [xml2rfc] unreachable?

From: Randy Bush <[email-masked]>
Date: Sat, 18 Apr 2020 13:56:08 -0700

Error: Failure fetching URL https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.8481 (HTTPSConnectionPool(host='xml2rfc.tools.ietf.org', port=443): Max retries exceeded with url: /public/rfc/bibxml/reference.RFC.8481 (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x105b6cb10>: Failed to establish a new connection: [Errno 51] Network is unreachable',)))

% ping xml2rfc.ietf.org
PING ietf.org (4.31.198.44): 56 data bytes
64 bytes from 4.31.198.44: icmp_seq=0 ttl=56 time=7.075 ms
64 bytes from 4.31.198.44: icmp_seq=1 ttl=56 time=7.184 ms

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 18 Apr 2020 23:32:57 +0200

Not eally unreachable, but connection refused on the tools server for me:

$ curl -LI https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.8481
HTTP/1.1 302 Found
Date: Sat, 18 Apr 2020 21:28:07 GMT
Server: Apache
Location: https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.8481
Content-Type: text/html; charset=iso-8859-1

curl: (7) Failed to connect to xml2rfc.tools.ietf.org port 443: Connection refused
$ host xml2rfc.tools.ietf.org
xml2rfc.tools.ietf.org is an alias for durif.tools.ietf.org.
durif.tools.ietf.org has address 4.31.198.61
durif.tools.ietf.org has IPv6 address 2001:1900:3001:11::3d
$ ping xml2rfc.tools.ietf.org
PING durif.tools.ietf.org (4.31.198.61): 56 data bytes
64 bytes from 4.31.198.61: icmp_seq=0 ttl=57 time=213.952 ms
64 bytes from 4.31.198.61: icmp_seq=1 ttl=57 time=235.747 ms
^C
--- durif.tools.ietf.org ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 213.952/224.850/235.747/10.897 ms
$ telnet xml2rfc.tools.ietf.org 80
Trying 4.31.198.61...
telnet: Unable to connect to remote host: Connection refused
$ telnet xml2rfc.tools.ietf.org 443
Trying 4.31.198.61...
telnet: Unable to connect to remote host: Connection refused
$

Grüße, Carsten

> On 2020-04-18, at 22:56, Randy Bush <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc