Subject: [xml2rfc] Problem with Swedish characters in Region

From: Robert Moskowitz <[email-masked]>
Date: Sun, 5 Apr 2020 16:08:58 -0400

Andrei Gurtov sent me this xml block for his address:

     <author fullname="Andrei Gurtov" initials="A." surname="Gurtov">
     <organization>Linköping University</organization>
     <address>
       <postal>
         <street>IDA</street>
         <city>Linköping</city>
         <region>Östergötland</region>
         <code>58183</code>
         <country>Sweden</country>
       </postal>
       <email>[email-masked]</email>
     </address>
     </author>

I got the error:

draft-moskowitz-drip-secure-nrid-c2-00.xml(59): Warning: Postal address 
part filled in, but not used: <region>: Östergötland

The address block in the draft is:

    Andrei Gurtov
    Linköping University
    IDA
    SE-58183 Linköping
    Sweden

    Email: [email-masked]

===============

How do I 'fix' this?  It seems it is ok in organization and city, but 
not region?

Henrik, this strikes kind of close to home????

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 5 Apr 2020 23:36:07 +0200

On 2020-04-05, at 22:08, Robert Moskowitz <[email-masked]> wrote:
> 
> draft-moskowitz-drip-secure-nrid-c2-00.xml(59): Warning: Postal address part filled in, but not used: <region>: Östergötland

Hmm, draft-levkowetz-xml2rfc-v3-implementation-notes-10.txt points to
http://microformats.org/wiki/hcard and says that region is mapped to country-area there.  But hcard has a region and not a country-area.  So I’m not sure what the (current beta) spec says.

The implementation stuffs the input into a library called i18naddress (the I-D talks about something with a similar name but doesn’t say what that actually might be); it seems to be the prerogative of the library whether a state/province/canton/… is used in the country being used in the address or not.  That library seems to know that providing the federal state in an address would be rather unusual in the country of Germany (*), so maybe it thinks the same about Sweden.

Grüße, Carsten

(*) 5 million stupid online shops that force me to enter that information notwithstanding

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 5 Apr 2020 17:41:25 -0400

On 4/5/20 5:36 PM, Carsten Bormann wrote:
> http://microformats.org/wiki/hcard and says that region is mapped to country-area there.

Is there a <country-area> tag?

> But hcard has a region and not a country-area.  So I’m not sure what the (current beta) spec says.
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 6 Apr 2020 12:12:02 +0200

Hi Bob,

> The address block in the draft is:

And the postal address format information the tool has is right.  In
Sweden, postal addresses do not use regions, the information is quite
superfluous and could even be confusing for some postal employees.

Simply remove the region, I'd say.

Best regards,

	Henrik

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 6 Apr 2020 06:47:58 -0400

> Simply remove the region, I'd say.

That is what Andrei just told me to do...