Subject: [xml2rfc] https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5730.xml timing out

From: Julian Reschke <[email-masked]>
Date: Thu, 16 Apr 2020 12:10:03 +0200

> curl -v https://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5730.xml
>   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
>                                  Dload  Upload   Total   Spent    Left  Speed
>   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying 4.31.198.44...
> * TCP_NODELAY set
>   0     0    0     0    0     0      0      0 --:--:--  0:00:20 --:--:--     0* connect to 4.31.198.44 port 443 failed: Timed out
> * Failed to connect to xml2rfc.ietf.org port 443: Timed out
> * Closing connection 0
> curl: (7) Failed to connect to xml2rfc.ietf.org port 443: Timed out

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 16 Apr 2020 14:41:36 +0200

I generally have more luck with xml2rfc.tools.ietf.org; saves one 302 and reduces two SPOFs to one SPOF.

Grüße, Carsten

> On 2020-04-16, at 12:10, Julian Reschke <[email-masked]> wrote:
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc

---

From: Julian Reschke <[email-masked]>
Date: Thu, 16 Apr 2020 15:23:35 +0200

On 16.04.2020 14:41, Carsten Bormann wrote:
> ...

Understood.

It's just that I'm running a large test suite against historic
documents, and these are really not supposed to break, right?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Thu, 16 Apr 2020 16:15:23 +0200

> documents, and these are really not supposed to break, right?
FWIW, https://datatracker.ietf.org resolves to the same IP and times out
as well.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 16 Apr 2020 16:43:06 +0200

> FWIW, https://datatracker.ietf.org resolves to the same IP

Right.

> and times out

WFM.  Did you traceroute?

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Thu, 16 Apr 2020 17:20:59 +0200

>> FWIW, https://datatracker.ietf.org resolves to the same IP

I did not. I just moved, and now I get a success (over a German Telekom
network). The NW over which it was failing IMHO is UnityMedia.

Best regards, Julian