Subject: [xml2rfc] question about ?anchor= in xi:include

From: Robert Moskowitz <[email-masked]>
Date: Wed, 27 May 2020 09:13:15 -0400

In the usage below:

<xi:include 
href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.card-drip-reqs.xml?anchor=drip-reqs"/>

Where at the beginning of <back> there is:

<displayreference target="I-D.card-drip-reqs" to="drip-requirements"/>

What value is the anchor?

I can't use it in a xref target=

If I leave it out, there is no difference in the resultant draft.

When I look at the v3 FAQ, it seems that the anchor is used when no 
displayreference?

thanks

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 May 2020 15:28:21 +0200

Hi Bob,

> On 2020-05-27, at 15:13, Robert Moskowitz <[email-masked]> wrote:
> 
> In the usage below:
> 
> <xi:include href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.card-drip-reqs.xml?anchor=drip-reqs"/>

The HTTP query part would need to be interpreted by the bibxml server, but it is not implemented for bibxml3 (it *is* for DOI and IANA).  So this is right now completely equivalent to:

> <xi:include href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.card-drip-reqs.xml"/>

> What value is the anchor?

I-D.card-drip-reqs

> When I look at the v3 FAQ, it seems that the anchor is used when no displayreference?

You use the anchor in target= attributes (for elements such as xref or displayreference).

The output sees the value of the to= attribute of the display reference, if any, or the anchor otherwise.

(This is all a bit simpler in kramdown-rfc, thanks to a contribution by Martin Thomson:

informative:
  drip-requirements: I-D.card-drip-reqs

Then you can use {{drip-requirements}} and will see [drip-requirements] as the displayed reference.)

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Wed, 27 May 2020 15:30:26 +0200

> What value is the anchor?

In the URI

https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.card-drip-reqs.xml?anchor=drip-reqs

the "anchor" query parameter doesn't seem to be used; the XML is:

<reference anchor="I-D.card-drip-reqs">
<front>
<title>Drone Remote Identification Protocol (DRIP) Requirements</title>

<author initials="S" surname="Card" fullname="Stuart Card">
     <organization/>
</author>

<author initials="A" surname="Wiethuechter" fullname="Adam Wiethuechter">
     <organization/>
</author>

<author initials="R" surname="Moskowitz" fullname="Robert Moskowitz">
     <organization/>
</author>

<date month="April" day="20" year="2020"/>

<abstract><t>This document defines the requirements for Drone Remote
Identification Protocol (DRIP) Working Group protocols and services to
support Unmanned Aircraft System Remote Identification (UAS RID).
Objectives include: complementing external technical standards as
regulator-accepted means of compliance with UAS RID regulations;
facilitating use of existing Internet resources to support UAS RID and
to enable enhanced related services; and enabling verification that UAS
RID information is trustworthy (to some extent, even in the absence of
Internet connectivity at the receiving node).</t></abstract>

</front>

<seriesInfo name="Internet-Draft" value="draft-card-drip-reqs-02"/>
<format type="TXT"
target="http://www.ietf.org/internet-drafts/draft-card-drip-reqs-02.txt"/>
</reference>

So, as anchor you'll need to use "I-D.card-drip-reqs". The
<displayreference> just changes what's displayed in the references.

> I can't use it in a xref target=

You are not supposed to :-)

> When I look at the v3 FAQ, it seems that the anchor is used when no

<displayreference> only affects *display*. See
<https://greenbytes.de/tech/webdav/rfc7991.html#element.displayreference>.

Best regards, Julian

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 27 May 2020 09:39:50 -0400

thank you Carsten and Julian.