Subject: [xml2rfc] SVG and Kramdown

From: Brian E Carpenter <[email-masked]>
Date: Wed, 1 Jul 2020 17:00:26 +1200

OK, I've seen the draft but it didn't help me one bit.

What do I write in a kramdown source to embed SVG artwork, and is it possible to embed it in-line, or must it be an external file?
 
Regards
   Brian Carpenter

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Jul 2020 07:10:43 +0200

> What do I write in a kramdown source to embed SVG artwork, and is it possible to embed it in-line, or must it be an external file?

See the example I just sent.  You can write the XML right into the kramdown source.  This *is* a bit unwieldy, so try {::include fn} if you want to avoid the prepping stage (a simple -v2v3 conversion will then do).

What tool do you use to generate the SVG?  If it is generated from plaintext input, I might want to add support for it.  Goat, ditaa, plantuml, and mscgen are “supported" right now, with potential surprises in the code that turns the output into bi-level black-and-white.

(I’m fighting with mermaid right now — svgcheck gives me a lot of black rectangles; I probably have to further complicate my pipeline to actually apply the styles left by mermaid.)

Grüße, Carsten