Subject: [xml2rfc] nbhy entity in xml2rfc v3

From: Ted Lemon <[email-masked]>
Date: Thu, 29 Oct 2020 13:54:44 -0400

I’m trying to convert an I-D from v2 to v3, and the only real problem I’ve run into is that I get a ton of errors like this when I try to use xml2rfc.tools.ietf.org:

 INPUT: Line 54: Entity 'nbhy' not defined

Am I supposed to add some directive somewhere to make this work? The FAQ seems to say pretty definitely that this _should_ work…

---

From: Julian Reschke <[email-masked]>
Date: Thu, 29 Oct 2020 19:02:05 +0100

Am 29.10.2020 um 18:54 schrieb Ted Lemon:
> ...

Does the v2 source refer to a DTD (and does *that* work on
xml2rfc.tools.ietf.org?)? Does the v3 source?

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 29 Oct 2020 19:03:19 +0100

Hi Ted,

> Am I supposed to add some directive somewhere to make this work? The FAQ seems to say pretty definitely that this _should_ work…

&nbhy; isn't natively understood by xml parsers, it has to be defined.

If you start out with running the v2 to v3 converter, it will insert
an entry "<!DOCTYPE rfc SYSTEM "rfc2629-xhtml.ent">" near the top of
the converted file.  "rfc2629-xhtml.ent" is packaged with xml2rfc, and
contains the needed definitions.

Best regards,

	Henrik

---

From: Ted Lemon <[email-masked]>
Date: Thu, 29 Oct 2020 14:19:43 -0400

> contains the needed definitions.

Yes, that was the issue. It’s probably worth mentioning this in the FAQ: https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html <https://www.rfc-editor.org/materials/FAQ-xml2rfcv3.html>