Subject: [xml2rfc] Dealing with IPv6 reverse DNS entries

From: Robert Moskowitz <[email-masked]>
Date: Sat, 31 Oct 2020 22:50:38 -0400

Using v 3.0.0

Not surprisingly the following is too long:

<artwork name="" type="" align="left" alt="">
<![CDATA[
e.9.6.a.0.d.a.0.2.5.9.1.d.a.3.a.4.1.0.0.8.2.0.0.4.1.0.0.1.0.0.2.ip6.arpa.
]]>
</artwork>

And that is without the "IN PTR ..."

How are ip6.arpa entries best handled?

thanks

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 1 Nov 2020 16:28:46 +1300

Hi Bob,

If you don't want to split it over 2 lines, you are a bit stuck in
ASCII. The following will generate a properly scaling figure
in v3 HTML, and a silly comment in v3 txt:

<figure anchor="ptr-example">
<name>IPv6 PTR Record</name>
<artset>

<artwork align="left" type="ascii-art">
<![CDATA[
IPv6 PTR Records are too long for ASCII art.
]]></artwork>

<artwork align="center" type="svg">
<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="26 19 502 30">
  <text font-size="12.8" x="26" y="31" fill="#000000" text-anchor="start" font-family="sans-serif" font-style="normal" font-weight="normal">
    <tspan x="26" y="31"/>
  </text>
  <text font-size="12.8" x="39" y="25" fill="#000000" text-anchor="start" font-family="sans-serif" font-style="normal" font-weight="normal">
    <tspan x="39" y="25"/>
  </text>
  <text font-size="12.8" x="35" y="45" fill="#000000" text-anchor="start" font-family="sans-serif" font-style="normal" font-weight="normal">
    <tspan x="35" y="45">IN PTR e.9.6.a.0.d.a.0.2.5.9.1.d.a.3.a.4.1.0.0.8.2.0.0.4.1.0.0.1.0.0.2.ip6.arpa.</tspan>
  </text>
</svg>

</artwork></artset>
</figure> 

Regards
   Brian Carpenter

On 01-Nov-20 15:50, Robert Moskowitz wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>