Subject: [xml2rfc] What's going on with embedded unicode in xml2rfc v3?

From: Ted Lemon <[email-masked]>
Date: Sat, 21 Nov 2020 09:57:45 -0500

See: https://www.ietf.org/archive/id/draft-ietf-dnssd-srp-06.html#name-acknowledgments <https://www.ietf.org/archive/id/draft-ietf-dnssd-srp-06.html#name-acknowledgments>

I thought at one point that it would be required that we do something special to insert unicode, but RFC7991 says that it’s just supported.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 21 Nov 2020 16:20:17 +0100

On 2020-11-21, at 15:57, Ted Lemon <[email-masked]> wrote:
> 
> See: https://www.ietf.org/archive/id/draft-ietf-dnssd-srp-06.html#name-acknowledgments
> 

If you need beyond-ASCII characters outside of artwork, use

<contact fullname="»üñîçøðé«"/>

or

{{{»üñîçøðé«}}}

in kramdown-rfc.

(Yes, that is abuse of the semantic markup, but it seems to be all we have right now.)

Grüße, Carsten

---

From: Ted Lemon <[email-masked]>
Date: Sat, 21 Nov 2020 10:53:48 -0500

On Nov 21, 2020, at 10:20 AM, Carsten Bormann <[email-masked]> wrote:
> <contact fullname="»üñîçøðé«”/>

That did it. Thanks!