Subject: [xml2rfc] xml2rfc/Web - rfcMarkup's reference links do not work anymore

From: Anders Rundgren <[email-masked]>
Date: Wed, 4 Nov 2020 07:39:31 +0100

Reference links are now generated like this: http://tools.ietf.org/html//rfc2119

To be sure that I had not screwed up I downloaded https://tools.ietf.org/tools/templates/draft-davies-template-bare-07.xml and got the same result when using the XML2RFC Web tool.

Thanx,
Anders

---

From: Julian Reschke <[email-masked]>
Date: Wed, 4 Nov 2020 09:51:25 +0100

Am 04.11.2020 um 07:39 schrieb Anders Rundgren:
> To be sure that I had not screwed up I downloaded
> https://tools.ietf.org/tools/templates/draft-davies-template-bare-07.xml
> and got the same result when using the XML2RFC Web tool.
>
> Thanx,
> Anders

1) What do you have in the source code?
2) How do you generate the output? (xml2rfv version? offline/online?)
3) What exactly is in the output?

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 4 Nov 2020 10:02:39 +0100

> Reference links are now generated like this: http://tools.ietf.org/html//rfc2119

That (double slash) is a bug in rfcmarkup, but why does the subject say “do not work any more”?

Grüße, Carsten

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 4 Nov 2020 10:55:43 +0100

> 3) What exactly is in the output?

Hi Julian,

I used (downloaded) the most recent (valid?) IETF template https://tools.ietf.org/tools/templates/draft-davies-template-bare-07.xml "as is" although I had to update the year to make it pass through https://xml2rfc.tools.ietf.org/

The template contains a line <xref target="RFC2629" format="default">RFC&nbsp;2629</xref> which in the RfcMarkup version doesn't work as expected: the link is dead because it is incorrectly formatted.

BTW, in RfcMarkup version there is a direct link to the RFC (in RfcMarkup) in the reference section while in the HTML version it is just a name.

Best regards,
Anders

> 
> Best regards, Julian
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 4 Nov 2020 11:11:14 +0100

> That (double slash) is a bug in rfcmarkup, but why does the subject say “do not work any more”?

Well, the hyper-linked references are dead when you click on them in a browser.

This appears to be a regression bug.

Regards,
Anders

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 4 Nov 2020 13:46:59 +0100

Pardon me, the problem only occurs in the "Debug" mode using the Web tool.
Apparently the malformed links work anyway.

Thanx again,
Anders

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 4 Nov 2020 14:29:36 +0100

Hi Anders,

Way too little information.  And it's not the first time I have to ask you
for more info from you.

Please indicate exactly where you observed this, an exact URL if applicable,
or if running rfcmarkup on the command-line, indicate which switches you
used.

	Henrik