Subject: [xml2rfc] Problem with IEEE 802.15.4-2015 DOI

From: Robert Moskowitz <[email-masked]>
Date: Tue, 15 Dec 2020 09:26:15 -0500

IEEE 802.15.4-2015 is available from:

https://ieeexplore.ieee.org/document/7460875

and shows the DOI of

10.1109/IEEESTD.2016.7460875

When I try:

wget 
https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.1109/IEEESTD.2016.7460875.xml

It aborts with a 404 NOT FOUND

When I try

https://doi.org/10.1109/IEEESTD.2016.7460875

it loops right back to the ieeexplore page above.

can anyone help me?  I can contact the 802 EC on issues (like the date 
problem in 802.11-2016), but I need information to show them.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Dec 2020 16:22:55 +0100

> On 2020-12-15, at 15:26, Robert Moskowitz <[email-masked]> wrote:
> 

There is very little useful metadata under that DOI:

$ doilit -h=foo 10.1109/IEEESTD.2016.7460875
  foo:
    seriesinfo:
      IEEE: standard
      DOI: 10.1109/ieeestd.2016.7460875
    title: IEEE Standard for Low-Rate Wireless Networks

> When I try:
> 
> wget https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.1109/IEEESTD.2016.7460875.xml
> 

The IEEE DOI server is super-flaky; it can take a minute to get the data, and something on the IETF server may time out the request.

> it loops right back to the ieeexplore page above.

Try

curl -sLH "Accept: application/citeproc+json" https://dx.doi.org/10.1109/IEEESTD.2016.7460875 | jq 

for the original data (leave out the “| jq” if you don’t have that installed).  Not all of these data are picked up by doilit.
I wouldn’t mind suggestions for what else should be (e.g., there is no “issued” metadata here, but there is “approved”).

Grüße, Carsten