Subject: Re: link-local-0.2 txt

From: Stuart Cheshire <[email-masked]>
Date: Mon, 2 Apr 2001 23:50:17 -0700

>Would it be a good idea to give a definition of on-link and off-link
>thus showing that hosts connected to different physical segments
>connected by bridges are all on-link.

Can you suggest some proposed text?

>I doubt the general applicability of the motivation. In a "stable" home
>network connections via a Residential Gateway can prove to be rather
>volatile with a duration of a few minutes to dowload some document or
>music. For the download of another document, a new connection can be
>opened with an allocation of a different IP address by the IP service
>provider.

Good point.

>Many people may mind the term: extremely simple device. A set-top box is
>actually not simple. I suggest to remove extremely simple and replace it
>with cost efficient if an adjective is needed at all.

The point here is not so much how much it costs, but how powerful a 
computing device it is. Powerful computing devices can more easily 
implement stronger security. The argument here is that very simple 
devices do not have that luxury -- they may be pushing their limits just 
to implement basic link-local IP.

>Tunnelling for off-link access.
>I suggest removing this paragraph for the same reasons as cited by 
>earlier comments by (Aboba?)

Agreed.

>Is it possible to make a list of items that have to be addressed by a
>physical medium standard that will be confronted with the link-local
>addresssing. The document already discusses several flavours of
>ethernet, but there are also flavours of for example USB and IEEE 1394
>
>Items such as:
>- ARP sending frequency,
>- Number of ARP packets

Will do.

>- physical (dis)connection behavior; especially as many IHDN standards 
>specify this in great detail

Can you suggest some proposed text?

By the way, I do not support the idea of sending gratuitous ARPs whenever 
a link-state change is detected, since this (a) wastes bandwidth, and (b) 
causes reconfigurations that may in fact not have been necessary, such as 
in the case of a wireless host momentarily passing into range.

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer
 * Chairman, IETF ZEROCONF
 * www.stuartcheshire.org

---

From: [email-masked]
Date: Wed, 4 Apr 2001 14:36:01 +0200

_____________________________________________________________________________-

>Can you suggest some proposed text?

below mij proposal:

A bridge connects two, possibly different, physical media such that all packets from one medium 
are forwarded to the other medium without modification to the IP related control information
(with exception of ARP packets) 
Routers change IP related control information (e.g. TTL) when routing packets from one medium 
to the other,

Two devices are called on-link when there is a path between them that passes via zero to n (n>0) bridges
and no routers. 

Two devices are called off-link when every path between them involves a router.

>in the case of a wireless host momentarily passing into range.

Your last remark prevents a simple solution.
The main idea of the following text is that two on-links hosts do not share the same IP address and
 ongoing communication may be stopped even if this was not absolutely necessary with hindsight.

A boundary condition exists:
In the home, applications are developed that maintain a view on the network configuration and
use. That allows the monitoring of streams between devices and stopping these streams when a
receiving device has been removed. Also they may be used for menu choices to support the selection
of devices by a user. It will be embarassing if devices are selected in one room that are removed
in another room (especially if this happened a few minutes ago; As long as no communication
 with the disconnected device is initiated, the device is considered connected).. 
Suggestion: a higher level protocol in the home looks after the presence of devices 
(membership protocol).

Below follows my proposal

Consider the two actions (connect and disconnect) separately;

- Consider disconnect
When a device disconnects, the link-local protocol is recommended not to take any action: 
Any ongoing IP communication will eventually signal that the host is unreachable. 
The IP address of the disconnected host can eventually be allocated to a new host. 

- Consider connect
three cases: the connected device was recently disconnected, the connected device
is repetetively connected and disconnected (wireless media)  or the connected device is reinserted 
after reboot. The last case is simple and the host will send "ARP probes" with its former address if
stored somewhere.

->Running comment:
->For the first two cases one may wonder when the device is considered disconnected, especially as 
->disconnection is not signalled.
-> For very short disconnection intervals all communication can go on and the device will keep
->its own IP address. For long disconnection intervals the device closes all it ongoing communcations
->selects its former IP address and sends an "ARP" probe. The question remains what is long.

A host considers itself correct when no disconnections have happened over a period longer than
a given correctness interval, C. The length of C is medium dependent.
Call "te" the time of the end of the last correctness interval. Assume t is the present clock time. Consider 
three states: (Connected, Possibly connected and Disconnected). A host decides to be in one
of these three states if
1) Connected: the interval [te,t) is small i.e. t-te < C1, where C1 is medium dependent
2) Possibly connected: the interval [te,t) is larger than C1 but smaller than C2, i.e. C1 <= t-te < C2, where C1 is
      a medium dependent constant
3) Disconnected: the interval [te,t) is larger than C2 but smaller than C3, i.e. C2 <= t - te < C3, where C3 is a medium
    dependent constant with C3 < C

Under condition 1, the host continues with the allocated IP address and continues ongoing communication.
Under condition 2, the host sends a gratuitous ARP and continues communication unless a conflict is detetected
Under condition 3, the host stops all ongoing communication, allocates its former IP address and sends "ARP probes" as
any starting host.

The correct values of the constants C1,C2, C3  and C are important. Typically C is longer than the period over which ARP probes
are sent by a host, while C3 is less than half the period over which ARP probes are sent by a host.