Subject: zeroconf implementation

From: Shailendra Suman <[email-masked]>
Date: Wed, 6 Mar 2002 05:35:29 -0800 (PST)

Hi Everybody,

I am very new in this area. I wanted to know is there
any implemetation of zeroconf for linux...while
searching on net I got zcip on
/pub/Linux/kernel.org/pub/software/network/zcip
. 
I downloaded this and compiled on redHat 7.1..

Now I don't know how to configure my m/c for
automatically assigning IP address.. I tried to run
zcip from command prompt 
it is running in loop probing for different ip-address
of series 169.254.x.x giving message address in
use....and unable to get IP address.

My machine is already on a network with dhcp
server...is this the reason for not getting IP using
zeroconf....How to test zcip....

Any other implementation for zeroconf for Linux....

Thanks in Advance..

Shaily

__________________________________________________
Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/

---

From: Sebastian Kuzminsky <[email-masked]>
Date: Wed, 06 Mar 2002 12:40:40 -0800

Shailendra Suman <[email-masked]> wrote:
] I am very new in this area. I wanted to know is there
] any implemetation of zeroconf for linux...while
] searching on net I got zcip on
] /pub/Linux/kernel.org/pub/software/network/zcip
] . 
] I downloaded this and compiled on redHat 7.1..
] 
] Now I don't know how to configure my m/c for
] automatically assigning IP address.. I tried to run
] zcip from command prompt 
] it is running in loop probing for different ip-address
] of series 169.254.x.x giving message address in
] use....and unable to get IP address.
] 
] My machine is already on a network with dhcp
] server...is this the reason for not getting IP using
] zeroconf....How to test zcip....

Hi, i'm the author of zcip.  It hasn't received very extensive
testing yet, though it works fine for us internally and i've verified
interoperability with a bunch of flavors of Windows.

zcip should work just fine on a network with a dhcp server, that's how
i do most of my testing.  (Of course if there's a dhcp server you're
probably better off using that to get your IP configuration.)

To help me debug the problem you're having, please run the following
commands and mail me all of the output:

    ifconfig
    route
    zcip

I also need to see a packet trace of zcip running, ie run "tcpdump -l -n"
before starting zcip, and mail me the output of that, too.

We'll get you going!

Sebastian