Subject: RE: On attribute-based queries

From: "Martin Layley" <[email-masked]>
Date: Wed, 7 Aug 2002 09:45:31 +0100

Stuart,
I can't remember who wrote the original note you are replying to, but I sometimes stagecrew for amateur theatre groups.  We often have only a few hours on a Sunday afternoon to completely rig a theatre for a show (let in at 12, with a rehearsal at 6 or 7pm).  In that time, as well as all of the scenery having to be placed, an entire lighting rig needs to be installed and positioned.  Currently, only part of the rig is networked - usually using DMX, but increasingly 10base-T is appearing for the more complex effects units.

A typical rig for a show in a 150 seat theatre will probably involve about 80 lamps, each with colour scrollers.  To avoid ladder or tower climbing, remote positioners would be nice (we can't afford to hire them yet....).  This comes to 240 devices which have to be installed, configured and tested in 6 hours.  When you start to look at the scale of the large touring rigs for rock bands, several thousand devices in one venue is not unthinkable.

		Martin Layley
		Samsung-SERI

-----Original Message-----
From: Stuart Cheshire [mailto:[email-masked]]
Sent: 07 August 2002 03:53
To: [email-masked]
Subject: Re: On attribute-based queries

>I work in a field (entertainment technology) where networks
>with several thousand devices came over the horizon
>a while ago and are now knocking on the door.

Really?

Several thousand devices?

Can you back this up with a real example?

I can imagine owning ten or twenty hi-fi components, but not several 
thousand.

I use X10 light switches in my house, but I don't have more than twenty 
or thirty of those.

The cheapest object I think I own is a pencil, but even for something 
that cheap I can't see any reason to own several thousand pencils. I have 
a hard time thinking of any object of which I own several thousand. If I 
do need to own several thousand network devices, that seems like a strong 
argument to make them as cheap and simple as possible.

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer
 * Chairman, IETF ZEROCONF
 * www.stuartcheshire.org

---

From: Tony de Rijk <[email-masked]>
Date: Wed, 07 Aug 2002 08:37:15 -0700

Martin,

I can back up your story for Stuart since I have done many large scale
entertainment projects, mostly using Ethernet to provide communications
using our Ethernet control units between consoles and lighting equipment.

I have done projects with up to 10000 lighting channels, however this
doesn't mean you need 10000 IP addresses. Lighting channels are normally
bundled in dimmer packs and moving lights etc. So the real demand in terms
of addressing capabilities is probably closer to less than 2000 in my
example.

Using AppleTalk over Ethernet we had systems like this set up in a very
short time with virtually no network configuration time.

Fortunately, zeroconf will allow us to do similar things based on IP.

On 8/7/02 1:45 AM, "Martin Layley" <[email-masked]> wrote:

> Stuart,
> I can't remember who wrote the original note you are replying to, but I
> sometimes stagecrew for amateur theatre groups.  We often have only a few
> hours on a Sunday afternoon to completely rig a theatre for a show (let in at
> 12, with a rehearsal at 6 or 7pm).  In that time, as well as all of the
> scenery having to be placed, an entire lighting rig needs to be installed and
> positioned.  Currently, only part of the rig is networked - usually using DMX,
> but increasingly 10base-T is appearing for the more complex effects units.
> 
> A typical rig for a show in a 150 seat theatre will probably involve about 80
> lamps, each with colour scrollers.  To avoid ladder or tower climbing, remote
> positioners would be nice (we can't afford to hire them yet....).  This comes
> to 240 devices which have to be installed, configured and tested in 6 hours.
> When you start to look at the scale of the large touring rigs for rock bands,
> several thousand devices in one venue is not unthinkable.
> 
> Martin Layley
> Samsung-SERI
>