Subject: DNS-SRV

From: Kevin Luehrs <[email-masked]>
Date: Wed, 7 Aug 2002 08:47:52 -0600

I am new to this list so forgive the newby question, but I would like to know if DNS-SRV [RFC2782] is under consideration as the service discovery mechanism for the Zeroconf initiative.

	Kevin Luehrs

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Kevin Luehrs
Project Director, CableHome Engineering
CableLabs
400 Centennial Parkway
Louisville, CO 80027
303 661 9100
fax 303 661 9199
[email-masked]

---

From: Erik Guttman <[email-masked]>
Date: Wed, 7 Aug 2002 18:07:35 +0200 (CEST)

On Wed, 7 Aug 2002, Kevin Luehrs wrote:

> I am new to this list so forgive the newby question, but I would
> like to know if DNS-SRV [RFC2782] is under consideration as the
> service discovery mechanism for the Zeroconf initiative.

There is no 'zeroconf initiative.'  The zeroconf working group is
chartered to produce two documents.  One is on the requirements
for zeroconf networking, the other is on IPv4 link local address
autoconfiguration.  Once these documents are published, the working
group will have fulfilled its charter, I believe.

Erik
ZEROCONF WG cochair

---

From: Robert Elz <[email-masked]>
Date: Sat, 10 Aug 2002 20:21:47 +0700

Date:        Wed, 7 Aug 2002 18:07:35 +0200 (CEST)
    From:        Erik Guttman <[email-masked]>
    Message-ID:  <Pine.SOL.3.96.1020807180417.6088B-100000@field>

  | The zeroconf working group is
  | chartered to produce two documents.  One is on the requirements
  | for zeroconf networking, the other is on IPv4 link local address
  | autoconfiguration.  Once these documents are published, the working
  | group will have fulfilled its charter, I believe.

That is possible - I kind of suspect however that if the requirements doc
says that, apart from link local addresses for V4, we also need X, Y and Z,
then either this WG, or perhaps several continuation WG's (depending upon
just what X Y and Z are) will be chartered to work on those.

I would kind of suspect that some form or service/server discovery mechanism
might be a useful requirement to have, as is likely to be some non DS kind of
name lookup mechanism (a zeroconf type of lookup).

kre